crash [@ mime_parse_stream_complete]

RESOLVED WORKSFORME

Status

MailNews Core
MIME
--
critical
RESOLVED WORKSFORME
8 years ago
2 years ago

People

(Reporter: wsmwk, Unassigned)

Tracking

({crash, testcase-wanted})

Trunk
x86
All
crash, testcase-wanted

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

8 years ago
crash [@ mime_parse_stream_complete]
#148 ranking for v3.0.4

two variations
1) frame 2 is nsImapCacheStreamListener 
2) frame 2+3 nsMsgProtocol::OnStopRequest, nsMailboxProtocol::OnStopRequest

1) frame 2 is nsImapCacheStreamListener 
most recent trunk crash is 
bp-f92fea18-339b-49c2-adaa-3e7c52100504 some dude still on 3.1a1
0	thunderbird-bin	mime_parse_stream_complete	 mailnews/mime/src/mimedrft.cpp:1394
1	thunderbird-bin	nsStreamConverter::OnStopRequest	mailnews/mime/src/nsStreamConverter.cpp:1068
2	thunderbird-bin	nsImapCacheStreamListener::OnStopRequest	mailnews/imap/src/nsImapProtocol.cpp:8332
3	thunderbird-bin	nsInputStreamPump::OnStateStop	netwerk/base/src/nsInputStreamPump.cpp:576
4	thunderbird-bin	nsInputStreamPump::OnInputStreamReady	netwerk/base/src/nsInputStreamPump.cpp:401
5	libxpcom_core.dylib	nsInputStreamReadyEvent::Run	xpcom/io/nsStreamUtils.cpp:112
6	libxpcom_core.dylib	nsThread::ProcessNextEvent	xpcom/threads/nsThread.cpp:527
7	libxpcom_core.dylib	NS_ProcessPendingEvents_P	nsThreadUtils.cpp:200
8	thunderbird-bin	nsBaseAppShell::NativeEventCallback	widget/src/xpwidgets/nsBaseAppShell.cpp:121
9	thunderbird-bin	nsAppShell::ProcessGeckoEvents	widget/src/cocoa/nsAppShell.mm:494 

bp-1a0ecaaa-ecac-4f0a-a224-5a73a2100428 v3.0.4 (patrick)
bp-1e82f57b-c41e-4049-815e-4e8342100507 v3.0.4 "Klicked the forward button on an email, instant crash"


2) frame 2+3 nsMsgProtocol::OnStopRequest, nsMailboxProtocol::OnStopRequest
bp-a361e189-c722-4fb5-8876-3c6462100415 v3.0.4 (kb5txs)
(Reporter)

Updated

8 years ago
Component: General → MIME
Product: Thunderbird → MailNews Core
QA Contact: general → mime
(Reporter)

Comment 1

7 years ago
#130 rank for v3.1.7

bp-6a7a30e7-8765-461f-999c-848372101227 (astorey) pinged for testcase
bp-57ef16a6-ee3e-4d94-bfeb-b2d352101015 (LSB) pinged for testcase
bp-8a3b1968-4fc7-4f35-b338-3924b2101028 (anne) pinged for testcase
mdd->messageBody->tmp_file is null
(Reporter)

Comment 3

7 years ago
(In reply to comment #2)
> mdd->messageBody->tmp_file is null

that's promising.

astorey reports "When we are reading our email or trying to send email Thunderbird does not respond.  We get a message at the top that says "Not Responding"."
(Assignee)

Updated

7 years ago
Crash Signature: [@ mime_parse_stream_complete]
(Reporter)

Comment 4

6 years ago
protz, can you do anything with comment 2?

~#100 crash for version 6.
eg bp-757a4aed-6c00-4f97-ba95-616d62110919
I'd need to get ahold of the faulty email that triggers the crash. Do you have such an email?
(Reporter)

Updated

6 years ago
Duplicate of this bug: 712597
(Reporter)

Comment 7

4 years ago
Doug, do you still see this crash?
Flags: needinfo?(dm)

Comment 8

4 years ago
Thunderbird has not been crashing on me regularly for quite some time.  I've frozen myself at version 17.0.8.
Flags: needinfo?(dm)
(Reporter)

Comment 9

2 years ago
Doug, 
could you get us a testcase message that causes crash?

(In reply to Doug Morse from comment #8)
> Thunderbird has not been crashing on me regularly for quite some time.  I've
> frozen myself at version 17.0.8.


bp-6d5f15d3-9f00-454b-b450-bb58b2160202 is an example with nsImapCacheStreamListener::OnStopRequest(nsIRequest*, nsISupports*, nsresult)

About 50 crashes per week for TB38.5.1
Flags: needinfo?(dm)
Keywords: testcase-wanted
See Also: → bug 844647
(Reporter)

Comment 10

2 years ago
reporter is gone. Crash rate in version 45 extremely low and not same stack as earlier crashs
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(dm)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.