Last Comment Bug 564774 - nsMacCharset.cpp looks obsolete
: nsMacCharset.cpp looks obsolete
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Internationalization (show other bugs)
: Trunk
: All Mac OS X
: -- trivial (vote)
: mozilla6
Assigned To: Makoto Kato [:m_kato]
:
Mentors:
Depends on:
Blocks: 680320
  Show dependency treegraph
 
Reported: 2010-05-10 04:10 PDT by Henri Sivonen (:hsivonen)
Modified: 2011-08-24 17:29 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (9.39 KB, patch)
2011-05-01 21:05 PDT, Makoto Kato [:m_kato]
smontagu: review+
Details | Diff | Splinter Review

Description Henri Sivonen (:hsivonen) 2010-05-10 04:10:48 PDT
It seems that nsMacCharset.cpp makes sense for the Classic Mac OS but is obsolete on Mac OS X, since Mac OS X doesn't have a platform encoding that'd vary by OS locale.

nsMacCharset.cpp should probably become similar to nsBeOSCharset.cpp
Comment 1 Makoto Kato [:m_kato] 2011-05-01 21:05:41 PDT
Created attachment 529412 [details] [diff] [review]
fix
Comment 2 Makoto Kato [:m_kato] 2011-05-08 19:16:16 PDT
http://hg.mozilla.org/mozilla-central/rev/0c911d0c3a62

Note You need to log in before you can comment on or make changes to this bug.