After upgrading to Thunderbird 6, Japanese signature text attached from a file turned into garbage characters

RESOLVED WONTFIX

Status

MailNews Core
Composition
RESOLVED WONTFIX
7 years ago
6 years ago

People

(Reporter: kohei, Assigned: m_kato)

Tracking

({intl, regression})

Trunk
All
Mac OS X
intl, regression

Thunderbird Tracking Flags

(thunderbird7-, thunderbird8-)

Details

(Whiteboard: [workaround=signature in utf-8])

(Reporter)

Description

7 years ago
After the Thunderbird 6 release, some Japanese users have reported via Twitter that their signature text got garbled. They seem to be Mac users who have a signature file with the X-MAC-JAPANESE charset, a Shift-JIS variant. No problem with an UTF-8 signature file.

https://twitter.com/#!/search/realtime/Thunderbird%20%E7%BD%B2%E5%90%8D
(Reporter)

Comment 1

7 years ago
Please add the issue to the Thunderbird 6 release notes.
Keywords: relnote
Duplicate of this bug: 679976
Whiteboard: [workaround=sugnature in utf-8]
(Assignee)

Updated

7 years ago
Assignee: smontagu → nobody
Component: Internationalization → Composition
QA Contact: i18n → composition
Hardware: x86 → All
Version: 6 → Trunk
Sancus, rebron can we add that to the relnote ?
Whiteboard: [workaround=sugnature in utf-8] → [workaround=signature in utf-8]
Duplicate of this bug: 680915
David, Ehsan, any ideas?
tracking-thunderbird7: --- → +
tracking-thunderbird8: --- → +

Comment 6

7 years ago
And this worked in TB 5? I don't know of anything that changed with our signature handling between TB 5 and TB 6. We use InsertHTML to insert the signature, in the html editor. Is the signature HTML?

Comment 7

7 years ago
NO, this signature was a TXT file... I can send you a copy if needed...
and yes it worked fine in TB 5...

Comment 8

7 years ago
Sure, you can send me the text file - are you using the html editor or the plain text editor?

Comment 9

7 years ago
I'm running on a Mac and I was using a plain editor called TextWrangler.
but I do not see how to attach a file here... 
also I'll need to send you an older signature, 'cause the current one I finally tweak it making it idutf-8 compatible.
(Assignee)

Comment 10

7 years ago
We should add auto-detection if text isn't UTF-8.
Assignee: nobody → m_kato
Depends on: 564774
Hmm, I think auto-detection of intl/ doesn't work for signature file since the text may be too short.

I had fixed this bug in bug 201071. But something was broken of this?
(Assignee)

Comment 12

7 years ago
(In reply to Masayuki Nakano (Mozilla Japan) from comment #11)

> I had fixed this bug in bug 201071. But something was broken of this?

I will remove 2nd param by bug 653031.  TextPlain doesn't need on m-c, If we should add it, we should move to c-c.
(Assignee)

Comment 13

7 years ago
or add pref.  L10N can choose charset.
(In reply to Makoto Kato from comment #13)
> or add pref.  L10N can choose charset.

sounds it's enough and simple :)

Comment 15

7 years ago
I'd rather first understand what we changed so that this doesn't work no more, and then search for a fix.

Adding a pref doesn't really go the distance, IMHO.
(Assignee)

Comment 16

7 years ago
(In reply to Axel Hecht [:Pike] from comment #15)
> I'd rather first understand what we changed so that this doesn't work no
> more, and then search for a fix.

bug 564774.  Mac OS X default becomes UTF-8 on Gecko.  If mailnews wants to get historical text encoding, we have to add same code to mailnews.
Not going to track this at the moment as the number of users affected is likely to be low, but we'll consider fixes to it.
tracking-thunderbird7: + → -
tracking-thunderbird8: + → -
We have shipped Tb7 already. I think that we can mark this bug as WONTFIX. Now, we have signature text editor, and there are two release version which have this bug. So, I think that all users who met this bug have recreated their signatures already with the built in editor. And also this bug needs a new API for getting default text file encoding on each platforms or something. So, I don't think we should fix this bug by wasting such cost.
(Reporter)

Comment 19

7 years ago
Agree with Masa.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
Keywords: relnote
You need to log in before you can comment on or make changes to this bug.