Trying to insert an English word in the middle of a Hebrew sentence doesn't have the desired BIDI outcome

RESOLVED DUPLICATE of bug 119857

Status

Thunderbird
Message Compose Window
--
major
RESOLVED DUPLICATE of bug 119857
8 years ago
8 years ago

People

(Reporter: Reuven M. Lerner, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.4) Gecko/20100503 Firefox/3.6.4
Build Identifier: 

I use Thunderbird (actually, the nightly Shredder download) on a regular basis.  When I use it to compose English, everything works fine.  When I use it to compose Hebrew, everything also works fine (except for the fact that text is sent flush left, but that's another issue).  

But if I'm writing a sentence in Hebrew that needs to contain an English word, this requires that I (a) start the sentence in Hebrew, (b) switch to the English keyboard, (c) type the word in English, (d) switch back to the Hebrew keyboard, and (e) keep typing in Hebrew.  This is standard on all word processors and text editors used by Hebrew speakers, and it's expected that the English word will then sit in the middle of the Hebrew sentence.

In Thunderbird, however, following this procedure results in the English word sitting to the right of the Hebrew words.  In effect, the sentence starts to flow from left to right, with the Hebrew and English interspersed, but in the wrong direction.

This happens when I have set the encoding to UTF-8.

Reproducible: Always

Steps to Reproduce:
1. Open a "new message" window
2. Go to the top of the message-body frame.
3. Switch to a Hebrew keyboard.
4. Write one word in Hebrew.
5. Switch to the English keyboard.
6. Write one word in English.
7. Switch back to the Hebrew keyboard.
8. Write a second word in Hebrew.
Actual Results:  
The output looks like this:

אבגדה abcde וזחטי

But the words should be in the opposite order.  That is, אבגדה should be to the right of abcde, and וזחטי should be to the left of abcde.
Installing http://bidiui.mozdev.org/mail/ will solve this problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 119857
... except that the extension may well not work with Shredder nightlies :(
You need to log in before you can comment on or make changes to this bug.