Update category names to match those from the design document

VERIFIED FIXED in mozilla2.0b7

Status

()

Toolkit
Add-ons Manager
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: whimboo, Assigned: mossop)

Tracking

Trunk
mozilla2.0b7
Points:
---
Bug Flags:
in-testsuite -
in-litmus -

Firefox Tracking Flags

(blocking2.0 beta7+)

Details

(Whiteboard: [rewrite][strings], URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.3a5pre) Gecko/20100511 Minefield/3.7a5pre ID:20100511030640

On bug 557240 we switched back to the category naming for older releases. Given by the design documents we will have to use the new names at some point. This bug should track that work.

Category names right now are:
* Get Add-ons
* Languages
* Search Engines
* Extensions
* Appearance
* Plugins
* Updates

Adding uiwanted to make sure we will get the final list of category names.
There's been a lot of discussion specifically about the naming of the "Get Add-ons"/"Discover" pane. I'll summarize:

* "Get Add-ons" is seen as more descriptive, and potentially a lot easier to understand for people who won't know much about addons
* "Discover" conflicts with addons that provide discovery services
* There have been troubles localizing "Get Add-ons" - whereas "Discover" is seen as an easier phrase to localize while keeping its meaning
Marking dup of Bug 553473.  As Blair said, we're keeping "Get-Addons" now
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Keywords: uiwanted
Resolution: --- → DUPLICATE
Duplicate of bug: 553473
(Reporter)

Comment 3

7 years ago
This bug is not only about "Get Addons" vs. Discover. Bug 553473 is definitely a part of it and I was aware of that bug when I have filed this one. Comparing the current design docs with the implemented category names shows a difference for the Themes vs. Appearances panel name. The other ones look fine but would need a clear definition we can work with.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Updated

7 years ago
blocking2.0: --- → final+
(Assignee)

Updated

7 years ago
Duplicate of this bug: 521363
(Assignee)

Updated

7 years ago
Assignee: nobody → bmcbride
(Assignee)

Comment 5

7 years ago
Needed by string freeze
blocking2.0: final+ → beta5+
The only string change needed here is "Themes" -> "Appearance" (but it needs changed in 2 places). 

Sadly, changing the entity name in extensions.properties is painful/not sanely possible while the appearance pane is implemented by the list view (since it determines the entity name programatically). Thankfully, this is changing (by work done in bug 520124), so once that's done, this will be trivially easy.
Er, and by "painful", I mean without special casing it. Its not possible to do it *nicely*.
(Assignee)

Comment 8

7 years ago
Well I was actually making that change in bug 520124 so I might as well just own this for now.
Assignee: bmcbride → dtownsend
Depends on: 520124
(Assignee)

Updated

7 years ago
blocking2.0: beta5+ → beta6+
(Assignee)

Updated

7 years ago
No longer depends on: 520124
(Assignee)

Comment 9

7 years ago
Now that we aren't making the new appearance pane do we still want to name it Appearance or do we stick with Themes?
Keywords: uiwanted
(In reply to comment #9)
> Now that we aren't making the new appearance pane do we still want to name it
> Appearance or do we stick with Themes?

Its still about changing the appearance, and not solely about normal themes. The purpose hasn't changed, just the UI for it. So I'd say keep it as Appearance.
(Assignee)

Comment 11

7 years ago
Created attachment 470986 [details] [diff] [review]
patch rev 1

Well now the header text is gone this is somewhat easier to do anyway.
Attachment #470986 - Flags: review?(bmcbride)
(Assignee)

Updated

7 years ago
Status: REOPENED → ASSIGNED
Attachment #470986 - Flags: review?(bmcbride) → review+
(Assignee)

Updated

7 years ago
Whiteboard: [rewrite] → [rewrite][strings]
(Assignee)

Comment 12

7 years ago
Landed: http://hg.mozilla.org/mozilla-central/rev/7c33210d1052
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago7 years ago
Flags: in-testsuite-
Flags: in-litmus-
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b6
Depends on: 592947
(Reporter)

Comment 13

7 years ago
Verified fixed with builds on all platforms like Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:2.0b6pre) Gecko/20100902 Firefox/4.0b6pre
Status: RESOLVED → VERIFIED
Keywords: uiwanted
No longer depends on: 592947
You need to log in before you can comment on or make changes to this bug.