Installer fails with error 5 installing on my Win2K box

VERIFIED FIXED in mozilla0.9.1

Status

P1
normal
VERIFIED FIXED
19 years ago
15 years ago

People

(Reporter: attinasi, Assigned: ssu0262)

Tracking

Trunk
mozilla0.9.1
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [xpibug][rtm-][dogfood-] relnote-user)

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
I tried installing the following and got the same error 5:

Daily build 10-13 from trunk and branch (Netscape from sweetlou)
PR3 from sweetlou
PR3 from www.netscape.com

I have successfully installed Nav4 from netscape.com but cannot install Netscape6
(Reporter)

Comment 1

19 years ago
Fixed typo in summary - sorry.

CC'ing harish since he reports having the problem too.
Summary: Installer fails with error 5 isntalling on my Win2K box → Installer fails with error 5 installing on my Win2K box

Comment 2

19 years ago
No problems in my end, with all the latest installer builds.
What's Error 5?

Comment 3

19 years ago
I'm getting the following error ( on Winnt ):

"Error occurred during installation:- 235 INSUFFICIENT_DISK_SPACE"

I have about 250MB free on my C:!!!!!!

Marking rtm,dogfood. Since I'm not able to use the app.
Keywords: dogfood, rtm
Sean, please talk to harishd and see if you can get a look at his machine. Talk
to attinasi, too -- error 5 (whatever it is) is not the same as insufficient
diskspace error -235 and shouldn't be lumped together.
Whiteboard: [rtm+ need info]
(Assignee)

Comment 5

19 years ago
I just took at look at Harish's machine.  The error -235 is caused by psm.xpi.  
This comes up because psm.xpi looks to see if there's a previous installation of 
psm.xpi.  If there is it'll use that as the install path.

It just so happened that Harish had psm previously installed to s:\...., where 
s: was a subst to f:\....  Since s: was missing this time around, psm.xpi 
failed.

This is a different bug from what the summary says.  It's more similar to bug 
#33070.

Harish can no longer reproduce the error 5 bug on his machine.  I still can't on 
my machines.

Marc, can you tell me what dialogs are on the screen when you see the error 5 
message?  Or what was just on the screen (if it disappeared before the error 5 
messaged showed)?
Status: NEW → ASSIGNED
(Reporter)

Comment 6

19 years ago
On my Win2K box, I see a dialog with two progress bars on it.

The title is 'Install Progress'

The top progress bar say (above it) 'Currently installing Netscape XPinstall
engine' and the progress bar shows 1 progress-box.

The bottom progress bar says (above it) 'Copying file: NEtscape []' and the
progress bar shows about 20 progress-boxes, just over half way across.

Then, a message box pops up over that dialog. Its title is 'Error' and it says:
Error occurred during installation: 5'

That is all I see. I have 3.45GB on drive D: (where I am installing to) and
about 1.2GB on drive C: (the boot drive and where Windows is installed).

Help | About Windows shows Windows 2000 (build 2195)
(Reporter)

Comment 7

19 years ago
As Sean suggested, I cannot create the required registry key when logged in as
myself. As Admin, of course, I can, and as Admin I can install too.

The error message should be a little bit more explanatory, so the user has a
clue what to do about it.
I don't think we can fix this, we'll have to release note it.

relnote: "On Windows 2000 and some Windows NT installations Netscape 6 must be
installed by a user with Administrator privileges. An installation that fails
with "Error 5" is a symptom of not having the required privileges to write to
the Windows Registry.  Log on as a sufficiently powerful user and install again."

So now what, do I remove the [rtm+ need info]? change it to rtm- for the fix and
count on the "relnoteRTM" as being enough for Vera to find it?
Keywords: relnoteRTM
(Reporter)

Comment 9

19 years ago
We cannot put in a better error message than 'error: 5'?

Can users read the release ntoes if they fail to install the browser?
(Assignee)

Comment 10

19 years ago
adding Steve to the CC: list for the readme.txt file.
At this point, no, we cannot change the error message without getting the
translation folks on our backs.
The release notes are linked from the same page as the product download, so the
user should be able to find it.

I should note that "Error 5" doesn't "mean" we failed to write to the registry,
it's an unexpected error that we have tied to that cause. We could not have
written a more descriptive error ahead of time for it.
Whiteboard: [rtm+ need info] → [rtm-]

Comment 13

19 years ago
Clearly the work-around (release note) will get visibility, and this won't stop
daily-use.  Marking dogfood-minus.

As noted, it is too late for UI change, but IMO, you should talk with teh
international folks about this.  Win2K is a big platform for us, and it might be
so valuable that we'd rather have English give a good warning, and not have this
translated, then have it stay as is.

I'm copying Miachell, as I suspect this may be a marketing call.
Whiteboard: [rtm-] → [rtm-][dogfood-]
Whiteboard: [rtm-][dogfood-] → [rtm-][dogfood-] relnote-user
I agree with Jar that this should be considered for a language change.  This
issue has already come up numerous times with folks wanting to distribute
seamonkey in Japan on Win2k, so I'd bet the international folks might be willing
to take this change.  I'm cc'ing a whole passle of them on the bug for a
response.  Changing the bug back to "need info".
Whiteboard: [rtm-][dogfood-] relnote-user → [rtm need info][dogfood-] relnote-user
Got no negative response from i18n folks, can I assume Michael's OK is good
enough to change text strings in the installer? Going, going, ......

Comment 16

19 years ago
I already added content to the read me file regarding the "Error 5" message. The
read me is viewable prior to installation. I agree that the dialog should be
changed, though.

What is the text you're proposing to use for the dialog?

Comment 17

19 years ago
OK, I just read the bug. I'd prefer no change is done to the UI and instead this
bug is documented in the readme. Please, do not change UI.

Comment 18

19 years ago
Can we please get this off the rtm radar now?
[rtm-] for any dialog changing. This will be release noted.
Whiteboard: [rtm need info][dogfood-] relnote-user → [rtm-][dogfood-] relnote-user

Comment 20

19 years ago
http://bugzilla.mozilla.org/show_bug.cgi?id=56538

        For Windows 2000 and Windows NT systems, you must have
	Administrator privileges to install Netscape 6. If you see
	an "Error 5" message during installation, log on with
	Administrator privileges and try installing again.
(Assignee)

Updated

19 years ago
Priority: P3 → P1

Comment 21

19 years ago
Removing myself from the list of cc's.
We need better error reporting at the very least. This particular one probably
requires changes to the win registry object to verify permissions during the
Prepare() step so the script can report sensible errors.
Keywords: nsbeta1
Whiteboard: [rtm-][dogfood-] relnote-user → [xpibug][rtm-][dogfood-] relnote-user
Moz 0.9 tasks
Target Milestone: --- → mozilla0.9

Comment 24

18 years ago
adding myself to cc list

Comment 25

18 years ago
We need more than better error reporting here.  At the least, the install must
continue.  What is the impact of skipping this step?  Will the product still
work generally?

Comment 26

18 years ago
There are no files installed when this errors out
(Assignee)

Comment 27

18 years ago
If we try to detect this error and ignore it (or warn the user, then ignore it),
the product should still run fine as far as I can tell.

Let me do some investigation as to exactly what windows registry keys this affects.

Updated

18 years ago
Keywords: dogfood, nsbeta1, relnoteRTM, rtm → nsbeta1+
When you extract mozilla manually you can run it without admin privileges. Why 
should the installer bomb out on this?
See comment above yours: an error is an error, we need to specifically tell the 
installer which problems are safe to ignore.

Comment 30

18 years ago
http://msdn.microsoft.com/library/psdk/winbase/errors_0sdh.htm

The above link shows how to turn a GetLastError() into an error string. Maybe
this is the solution. It takes a language specifier so we can assume it works ok
in an i18n context.
Target Milestone: mozilla0.9 → mozilla0.9.1

Comment 31

18 years ago
This is not an 'error 5' problem, but is related, I think. I extracted the 0.8.1 
mozilla-win32[-talkback].zip a month ago, but I did not run or "install" it 
until yesterday because I did not want to install it, on W2K (SP1) machine, 
separately into more than one user's folder. Yesterday, when not in 
Administrator mode, I idly clicked on mozilla.exe to see what it would do, and 
the program did a setup number. There were some problems with the setup, e.g. 
with the names of folders in messenger that kept changing back to the wrong 
names. I thought maybe it was because of this administrator privileges problem. 
Today, in administrator mode, I tried uninistalling Mozilla, but ControlPanel 
doesn't show Mozilla installed. I clicked on mozilla.exe again. It did a setup 
number, but did not find, import or setup my Netscape 4.76 mail or newsgroups. 
ControlPanel still does not show Mozilla installed.

Comment 32

18 years ago
try removing all profile data and rerunning.
sounds like it may be in many places 

see Windows 2000  : C:\Documents and Settings\<user name>\Application 
Data\Mozilla\users50\profile\salted name

...note users50 has been changed to profiles in mid April....

often application data is a hidden file so you need to 'unhide' - remove or 
rename the mozilla directory and rerun with command line

~installdir\netscp6 -installer 

to call migration into play.
(Assignee)

Comment 33

18 years ago
(Assignee)

Comment 34

18 years ago
(Assignee)

Comment 35

18 years ago
The patches will fix the error 5 problem under restricted users under Win2k.  
Since a restricted user does not have write access to the normal windows 
uninstall registry key, an uninstall shortcut is created (along with the regular 
shortcuts) in such a situation.  The uninstaller will work as well.

This patch does not solve the problem of a restricted user attemping to 
"smartupdate" a .xpi file.  The error 5 message will still show up, but then 
other error messages might as well because the user might not have write access 
to update certain files.

seeking r= now.
(Assignee)

Updated

18 years ago
Blocks: 77244
(Assignee)

Comment 36

18 years ago
fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Updated

18 years ago
QA Contact: gemal → gbush

Comment 37

18 years ago
build 2001052506
Status: RESOLVED → VERIFIED

Comment 38

18 years ago
*** Bug 86070 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.