Addons Manager tries to load custom about dialogs for disabled addons; hangs on Windows

VERIFIED DUPLICATE of bug 553505

Status

()

Toolkit
Add-ons Manager
--
critical
VERIFIED DUPLICATE of bug 553505
8 years ago
8 years ago

People

(Reporter: Ken, Unassigned)

Tracking

({hang, regression})

Trunk
hang, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rewrite])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a5pre) Gecko/20100512 Minefield/3.7a5pre ( .NET CLR 3.5.30729) Firefox/3.6.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a5pre) Gecko/20100512 Minefield/3.7a5pre ( .NET CLR 3.5.30729) Firefox/3.6.3

With Adblock Plus 1.2 Disabled; If you Right Click Adblock Plus then select About, Minefield locks up (becomes unresponsive). Clicking anywhere on the Minefield window just makes a Bing sound. The only way I found to stop/exit Minefield is to use Task Manager to Kill the process tree.

Also after repeatedly causing this problem, I decided to Open the Error Console to see if anything came up when/before Minefield hung. The following Info message came up: "No chrome package registered for chrome://adblockplus/content/ui/about.xul".

IMO, An error in the way a Addon is setup should not freeze the browser. Just a thought.

If Adblock plus is enabled, About Adblock works correctly.

Reproducible: Always

Steps to Reproduce:
1. Make sure Adblock Plus 1.2 is installed & Disabled under Addons Manager.
2. Right click Adblock Plus & select About under Addons Manager.
3. Minefield hangs.
Actual Results:  
Minefield hangs.

Expected Results:  
About information for the addon should display.
(Reporter)

Comment 1

8 years ago
The same thing could be happening when other Addons -> About is pressed.

The way I found the above is, I was Disabling extensions, to try and find out what might be causing "http://www.intellicast.com/Local/Map.aspx" (which uses extensive Adobe Flash) to cause Minefield to continually crash, while watching the weather (with enough time/zooming/looping/loading other Web pages in tabs...).
(Reporter)

Updated

8 years ago
Summary: If Adblock 1.2 is disabled, with new Addons Manager. Right Click -> About; hangs Minefield → If Addon is disabled, with new Addons Manager. Right Click -> About; hangs Minefield
(Reporter)

Comment 2

8 years ago
From "http://forums.mozillazine.org/viewtopic.php?f=23&t=1892195&p=9352725#p9352725":

      I just had the same error when I pressed 'About:addons' -> Right click -> About on another (Chatzilla) disabled Addon.
      I have rebuilt my extensions.* files, I will have to do some more digging...
      Maybe it's another extension, or OS specific (it still happens with today's build).
      I'll retry safe mode, to make sure the same thing happens. :-k

Edit: Same thing in Safe mode. Trying new profile...
Edit2: New profile worked, with default Addons disabled (Java Quick Start, Microsoft .NET...), I could display 'About' information. But, when I added Adblock plus 1.2 and disabled it, the 'About:addons' -> Right click -> About' hung Minefield again...
I guess I will have to wait for another person to get the same error, before the bug (#565616) can be confirmed. :?
(Reporter)

Updated

8 years ago
Component: General → Add-ons Manager
Product: Firefox → Toolkit
Whiteboard: [rewrite]

Comment 3

8 years ago
Confirmed on Windows XP using current Minefield. Linux gets the error but no hang.

(In reply to comment #0)
> Also after repeatedly causing this problem, I decided to Open the Error Console
> to see if anything came up when/before Minefield hung. The following Info
> message came up: "No chrome package registered for
> chrome://adblockplus/content/ui/about.xul".
> 
> IMO, An error in the way a Addon is setup should not freeze the browser. Just a
> thought.

That's not an error in the addon. A custom about dialog is specified and opens fine when the addon is enabled, however with it disabled the addon's files aren't registered and thus can't load. The old manager would just ignore the custom file and use the install.rdf metadata to generate a generic dialog as if no custom was specified.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Summary: If Addon is disabled, with new Addons Manager. Right Click -> About; hangs Minefield → Addons Manager tries to load custom about dialogs for disabled addons; hangs on Windows
Version: unspecified → Trunk

Updated

8 years ago
Blocks: 550048
QA Contact: general → add-ons.manager
Severity: normal → critical
Keywords: hang
OS: Windows XP → All
Hardware: x86 → All
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 553505
No longer blocks: 550048
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.