Command to open the about window should be disabled for addons that are disabled

VERIFIED FIXED in mozilla1.9.3a5

Status

()

defect
--
critical
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: Unfocused, Assigned: mossop)

Tracking

({hang})

Trunk
mozilla1.9.3a5
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +
in-litmus -

Firefox Tracking Flags

(blocking2.0 beta1+)

Details

(Whiteboard: [rewrite])

Attachments

(1 attachment)

The command to open the about window is always enabled. however, it won't work for addons that are available by not installed. It should be disabled for addons that are not installed.

Alternatively, it could get relevant information from AMO and display that.
Flags: in-testsuite?
Flags: in-litmus?
Version: unspecified → Trunk
Assignee

Updated

9 years ago
Duplicate of this bug: 565616
Assignee

Updated

9 years ago
Duplicate of this bug: 566203
Severity: normal → critical
Keywords: hang
Summary: Command to open the about window should be disabled for addons that are not installed → Command to open the about window should be disabled for addons that are not enabled or installed yet
Assignee

Updated

9 years ago
blocking2.0: --- → beta1+
There is no rightclick menu if the extension is not yet installed. You did mean the "Show more information" menu entry, didn't you? So this bug is likely WFM?
It's still there for disabled add-ons. So it's clearly not a WFM. Updating summary.
Summary: Command to open the about window should be disabled for addons that are not enabled or installed yet → Command to open the about window should be disabled for addons that are disabled
Posted patch patch rev 1Splinter Review
This makes the API return null for optionsURL and aboutURL when the add-on is not active. The UI then disabled the preferences option and reverts to the default about UI automatically.
Assignee: nobody → dtownsend
Status: NEW → ASSIGNED
Attachment #447357 - Flags: review?(robert.bugzilla)
Comment on attachment 447357 [details] [diff] [review]
patch rev 1

Why doesn't the aboutURL case fallback to the default about UI when the add-on isn't active like it used to before the rewrite?
bah... I suspect it does but since the code that handles it isn't in the patch I assumed it didn't
(In reply to comment #7)
> bah... I suspect it does but since the code that handles it isn't in the patch
> I assumed it didn't

It does, the UI code handles that.
Comment on attachment 447357 [details] [diff] [review]
patch rev 1

Yep... just got off my butt and looked
Attachment #447357 - Flags: review?(robert.bugzilla) → review+
Landed: http://hg.mozilla.org/mozilla-central/rev/4add03141121
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Flags: in-testsuite?
Flags: in-testsuite+
Flags: in-litmus?
Flags: in-litmus-
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a5
Duplicate of this bug: 567972
Verified fixed with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a5pre) Gecko/20100530 Minefield/3.7a5pre (.NET CLR 3.5.30729) ID:20100530040319
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.