Tab-tearing threshold needs to be more robust

VERIFIED FIXED in Firefox 8

Status

()

Firefox
Tabbed Browser
VERIFIED FIXED
7 years ago
6 years ago

People

(Reporter: John Wayne Hill (UX Intern), Assigned: fryn)

Tracking

(Blocks: 2 bugs, {ux-userfeedback, verified-beta})

Trunk
Firefox 8
ux-userfeedback, verified-beta
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qa!][testday-20110930])

Attachments

(1 obsolete attachment)

(Reporter)

Description

7 years ago
(Note: this is filed as part of the “Paper Cut” bugs — we assume that there may be multiple existing bugs on this. Please make them block this bug, and we will de-dupe if they are indeed exactly the same. Thanks!)

To reproduce:
1. Open a tab
2. Drag the tab around
3. it's too easy to tear the tab off the window, which causes accidental tears

Recommendation:
Increase the tab-tearing threshold to be more robust.
Google Chrome does this very well.
(Reporter)

Updated

7 years ago
Depends on: 501543
Component: General → Tabbed Browser
QA Contact: general → tabbed.browser
How about actually hiding the tab in the tabstrip when the tab has been dragged far enough to initiate the tear?
(Assignee)

Comment 2

7 years ago
Created attachment 460447 [details] [diff] [review]
patch (increases threshold from half a tab to 1 tab height)

While we would love a tab tearing animation like this one ( http://www.stephenhorlander.com/images/blog-posts/tab-animation/animation-tab-tear-off.html ), that's for another day and another bug.

This should be a decent short-term solution.
Assignee: nobody → fyan
Status: NEW → ASSIGNED
Attachment #460447 - Flags: ui-review?(limi)
Attachment #460447 - Flags: review?(dao)

Updated

7 years ago
Attachment #460447 - Flags: review?(dao) → review?(mano)
(Assignee)

Updated

7 years ago
Attachment #460447 - Attachment is obsolete: true
Attachment #460447 - Flags: ui-review?(limi)
Attachment #460447 - Flags: review?(mano)
(Assignee)

Updated

7 years ago
Blocks: 485105
(Assignee)

Updated

7 years ago
Assignee: fyan → nobody
Status: ASSIGNED → NEW
(Assignee)

Comment 3

7 years ago
This will be fixed when bug 455694 is.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 455694
(In reply to comment #3)
> This will be fixed when bug 455694 is.

Because the topics are completely different it would be nice to just add the dependency. That way we do not forget about this specific issue covered by this bug.
Status: RESOLVED → REOPENED
Depends on: 455694
Resolution: DUPLICATE → ---
Whiteboard: [will be fixed by bug 455694]
(Assignee)

Updated

6 years ago
Assignee: nobody → fryn
Status: REOPENED → ASSIGNED
(Assignee)

Comment 5

6 years ago
As KWierso note, this is primarily an issue of lack of feedback from the UI. We've been aware of that; it's just not simple to fix, but my patch in bug 455694 does fix it! :)
Keywords: ux-userfeedback
(Assignee)

Comment 6

6 years ago
Fixed by patch in bug 455694.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago6 years ago
Resolution: --- → FIXED
Whiteboard: [will be fixed by bug 455694]
(Assignee)

Updated

6 years ago
Target Milestone: --- → Firefox 8
Tested in Firefox 8.0b1.

When dragging the tab, I see the following tear behaviour:
 * UP, does not tear until mouse leaves top-bounds of the window
 * DOWN, does not tear until mouse leaves mid-point in Navigation toolbar
 * LEFT, does not tear until mouse leaves left-bounds of the window
 * RIGHT, does not tear until mouse leaves right-bounds of the window

Is this the desired behaviour to call this bug fixed?
Whiteboard: [qa+][testday-20110930]
(Assignee)

Comment 8

6 years ago
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #7)

> Is this the desired behaviour to call this bug fixed?

Yes.
Marking verified based on comment 8.
Status: RESOLVED → VERIFIED
Keywords: verified-beta
Whiteboard: [qa+][testday-20110930] → [qa!][testday-20110930]
You need to log in before you can comment on or make changes to this bug.