Closed Bug 565757 Opened 12 years ago Closed 12 years ago

New Addons Manager has wrong order of addons which start with non-ascii char

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla2.0b1

People

(Reporter: JasnaPaka, Unassigned)

References

Details

(Keywords: regression)

Steps to reproduce:
1) Install addon Web Developer(https://addons.mozilla.org/en-US/firefox/addon/60/)
2) Install addon about:cvrcek (https://addons.mozilla.org/en-US/firefox/addon/8052/)
3) Install addon Český slovník na kontrolu pravopisu (https://addons.mozilla.org/en-US/firefox/addon/3394/)

Expected sort of these addons in Addons Manager:
* about:cvrcek
* Český slovník na kontrolu pravopisu
* Web Developer

Actual result:
* Web Developer
* about:cvrcek
* Český slovník na kontrolu pravopisu

For familiar problem which was fixed in Firefox 3.0 see Bug 386434. Firefox 3.6.x doesn't contain this problem.
No longer blocks: 461973
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 562795
Dave, are you sure that this bug is duplicate of bug 562795? Problem with case-sensitive is just one part of this problem. Second one is problem with non-ascii chars. I don't see something about it in bug 562795.
Will probably be fixed by the same bug (see bug 379745 comment 7). But I'd like to keep this separate, if only to verify it gets fixed.
Status: RESOLVED → REOPENED
Depends on: 379745
Resolution: DUPLICATE → ---
This was fixed by bug 379745, will be tested by the patch in bug 562795.
Status: REOPENED → RESOLVED
Closed: 12 years ago12 years ago
Flags: in-testsuite?
Flags: in-litmus-
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a6
Verified fixed with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.3a6pre) Gecko/20100617 Minefield/3.7a6pre
Status: RESOLVED → VERIFIED
OS: Windows Vista → All
Hardware: x86 → All
Version: unspecified → Trunk
Tests landed in bug 562795
Flags: in-testsuite? → in-testsuite+
You need to log in before you can comment on or make changes to this bug.