The default bug view has changed. See this FAQ.

"forget this password/login" on right click

RESOLVED WONTFIX

Status

()

Firefox
General
RESOLVED WONTFIX
7 years ago
a year ago

People

(Reporter: John Wayne Hill (UX Intern), Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Advo])

(Reporter)

Description

7 years ago
(Note: this is filed as part of the “Paper Cut” bugs — we assume that there may be multiple existing bugs on this. Please make them block this bug, and we will de-dupe if they are indeed exactly the same. Thanks!)

To reproduce:
1. go to a site with a saved password
2. try to set firefox to stop remembering that password for you
3. 

Recommendation:
Allow a user to right click within the password field and select "forget this password/login" to delete that entry within the password manager.

Comment 1

7 years ago
This might be better suited to the password manager's doorhanger notification. (Doesn't exist yet, but it's the future!)

Updated

4 years ago
Whiteboard: [Advo]
Matt, would you consider this "fixed" since users can now click on the "Fill password -> View Saved Logins" and the Remove from that dialog?
Flags: needinfo?(MattN+bmo)
Yeah, that helps for mouse users. For keyboard users they could always just use the delete key (with Shift on Mac) from the autocomplete popup to delete. There has been talk about an [X] in autocomplete popups like the awesomebar before but I don't think that's planned as there are concerns about accidental deletion.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(MattN+bmo)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.