Closed Bug 565768 Opened 10 years ago Closed 7 years ago

Let people nuke individual entries in the AwesomeBar directly from it

Categories

(Firefox :: Address Bar, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 675818

People

(Reporter: limi, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: privacy, Whiteboard: [Advo])

(Note: this is filed as part of the “Paper Cut” bugs — we assume that there may be multiple existing bugs on this. Please make them block this bug, and we will de-dupe if they are indeed exactly the same. Thanks!)

One of the "privacy concerns" about the location bar is that sometimes things show up for people that they'd like to get rid of. Currently, there's no way to do that directly from the interface, and they are forced to figure out the clear history things and don't feel like they have control of what they are removing.

There's shift-delete that does this, of course — but it's completely undiscoverable.

Recommendation:
Add a close (delete) icon in subtle gray on the entry when hovered, so people can delete individual items using the mouse.
Keywords: privacy
Funnily enough, the feature I hate the most in IE is this. Most of the time, I'll click an item on the far right of the bar, in IE, you have the delete button there. It just makes it feel so much more tedious. If this is implemented, then please make it so it can be turned off. Up until this point, simply pressing delete on the keyboard has done the job in a perfect way.
The keyboard shortcut is Shift+Delete on Mac, but simply Delete on platforms with a proper delete button (Windows and Linux).
http://support.mozilla.com/en-US/kb/Location+bar+autocomplete#Removing_autocomplete_results
See Also: → 406239
Steffen is correct. However, on Mac, requiring the shift key modifier to delete even when the entry is focused could be a UX / discoverability problem.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WORKSFORME
Even with the Delete key unmodified, this is a discoverability issue that should be fixed.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
I tend to just hit the delete key for any highlighted history item that I want to remove, so that seems to work too, but it doesn't remove bookmarks from the bookmarks menu if try to delete bookmarks, which show up on subsequent awesomebar searches.
Component: General → Location Bar
QA Contact: general → location.bar
Whiteboard: [Advo]
Bug 675818 has a WIP patch and mockups so I'm duping this there.
Status: REOPENED → RESOLVED
Closed: 10 years ago7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 675818
You need to log in before you can comment on or make changes to this bug.