We should not make build/win32 for Windows 64 bit builds

RESOLVED DUPLICATE of bug 561740

Status

()

Core
Build Config
RESOLVED DUPLICATE of bug 561740
8 years ago
8 years ago

People

(Reporter: armenzg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
I was able to build a Windows 64 bit build only after commenting out the code that calls build/win32 into the build process.

ted what should the if statement look like instead of the following?
> ifeq (WINNT,$(OS_ARCH))
> DIRS = win32
> endif
something similar to?
http://mxr.mozilla.org/mozilla-central/source/gfx/qcms/Makefile.in
line 19 -- ifeq ($(OS_ARCH)_$(OS_TEST),WINNT_x86_64)

Here is code at guilt:
http://hg.mozilla.org/mozilla-central/file/tip/build/Makefile.in#l52

Here is the log for reference:
https://bugzilla.mozilla.org/attachment.cgi?id=445363
and one of the errors:
c:/Users/Administrator/armenzg/mozilla-central/build/win32/vmwarerecordinghelper/vmwarerecordinghelper.cpp(66)
: error C2143: syntax error : missing ';' before '}'
(Reporter)

Updated

8 years ago
Blocks: 558448
Dupe of bug 561740?  The problem isn't build/win32, it's vmwarerecordinghelper in it.  That bug has a r+ed patch too (but doesn't seem to have been checked in yet).
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 561740
You need to log in before you can comment on or make changes to this bug.