Closed Bug 566048 Opened 10 years ago Closed 6 years ago

PluginCheck pollutes browser history (Back button)

Categories

(Websites :: plugins.mozilla.org, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: weisbeek, Unassigned)

References

()

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; nl; rv:1.9.2.4) Gecko/20100503 Firefox/3.6.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; nl; rv:1.9.2.4) Gecko/20100503 Firefox/3.6.4

Although I like the idea of Mozilla's online plugincheck very much, I find it quite inconvenient that this check pollutes the browsing history. When I visit the plugin check and want to return to the page I visited before I cannot reach it (or it is quite hard to find how to return).

Now Mozilla released a badge that other websites can incorporate into their sites. Once again, this is a very good initiative, but when people would include it in their websites it would also pollute the browsing history of their visitors. 

It would be nice when Mozilla could find a way to test the plugins without loading a page for each plugin (or so it seems to an ordinary user). Then this is a really nice service. Now I would only recommend running the plugin check standalone into its own browser tab. But when this check is also hosted on other sites these visitors have not especially asked for this service. However, their browsing history will be hard to read when the plugin check has been run within their browser.

Reproducible: Always

Steps to Reproduce:
1. visit http://www.mozilla.com/en-US/plugincheck/ so the plugincheck will start
2. use your browser's back button to try to return to the previous page
Actual Results:  
You will not get to your previous page, because the history lists Mozilla's plugincheck all over.

Expected Results:  
Return to the previous page.
(In reply to comment #0)
Great find. I was totally unaware of this and it's not something I've seen before.
Assignee: nobody → ozten.bugs
Status: UNCONFIRMED → NEW
Ever confirmed: true
this issue is already tracked by Bug 534178 since it's a core bug.
Perhaps some abusing of history.pushState() and history.replaceState() could help this issue? Testable in Fx4b1+.

https://developer.mozilla.org/en/DOM/Manipulating_the_browser_history#Adding_and_modifying_history_entries
Component: Plugins → www.mozilla.org/firefox
Product: addons.mozilla.org → Websites
QA Contact: plugin-listings → www-mozilla-com
See Bug 614482 for the workaround.
Depends on: 614482
Assignee: ozten.bugs → nobody
Component: www.mozilla.org/firefox → plugins.mozilla.org
OS: Windows 7 → All
QA Contact: www-mozilla-com → plugins-mozilla-org
Hardware: x86 → All
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.