Middle-click on Back button should open the new tab next to the current one

VERIFIED DUPLICATE of bug 539594

Status

()

Firefox
Tabbed Browser
--
minor
VERIFIED DUPLICATE of bug 539594
8 years ago
8 years ago

People

(Reporter: Sylvain Brunerie, Unassigned)

Tracking

3.6 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; fr; rv:1.9.2.3) Gecko/20100407 Ubuntu/9.10 (karmic) Firefox/3.6.3
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; fr; rv:1.9.2.3) Gecko/20100407 Ubuntu/9.10 (karmic) Firefox/3.6.3

Since Firefox 3.6, a middle-click on a link will open a new tab next to the one currently selected, instead of putting it at the end of tabbar. Unfortunately this doesn't working if I middle-click the Back button. Same behaviour if I try to middle-click the "Back" context menu entry.

Reproducible: Always

Steps to Reproduce:
1. Open two pages in two tabs (or more), then go into the first.
2. Click a link.
3. Middle-click the Back button. The previous page opens in a new tab after the second tab, instead of opening a new tab right after the first one.
Actual Results:  
The previous page opens in a new tab after the last tab.

Expected Results:  
The previous page should open in a new tab right after the first one (where the middle-click has been done).

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 539594
Status: RESOLVED → VERIFIED
Version: unspecified → 3.6 Branch
You need to log in before you can comment on or make changes to this bug.