Closed Bug 539594 Opened 10 years ago Closed 10 years ago

Middle-clicking back/forward/reload should open the new tab next to the current one

Categories

(Firefox :: General, defect)

3.6 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 3.7a1

People

(Reporter: eyaler, Assigned: dao)

References

Details

Attachments

(2 files)

When middle-clicking back/forward/reload, the new tab should open next to the current tab. This is in the spirit of the changes of Bug 465673
Do these actions have a relationship to the currently open tab? We don't try to open a link from within the content area but it's more like the new tab button in the tabbar.
in my work flow it usually does. for example sometimes instead of opening several links in new tabs you just left click on one of the links. seeing its relevant you want to open the others, so you duplicate the tab by middle clicking on reload or back.
after getting used to the new behavior due to bug 465673 and bug 515635, i find myself expecting that also the duplicate tabs will open next to the current one.
I agree, I have been thinking the same thing a few times when middle-clicking the back or reload button.
Assignee: nobody → dao
Status: NEW → ASSIGNED
OS: Windows XP → All
Hardware: x86 → All
Component: Tabbed Browser → General
QA Contact: tabbed.browser → general
Attached patch patchSplinter Review
Attachment #421615 - Flags: review?(mconnor)
Comment on attachment 421615 [details] [diff] [review]
patch

>diff --git a/browser/base/content/utilityOverlay.js b/browser/base/content/utilityOverlay.js
>--- a/browser/base/content/utilityOverlay.js
>+++ b/browser/base/content/utilityOverlay.js
>@@ -171,23 +171,32 @@ function whereToOpenLink( e, ignoreButto
>  *  "tabshifted"  same as "tab" but in background if default is to select new tabs, and vice versa
>  *  "window"      new window
>  *  "save"        save to disk (with no filename hint!)
>  *
>  * allowThirdPartyFixup controls whether third party services such as Google's
>  * I Feel Lucky are allowed to interpret this URL. This parameter may be
>  * undefined, which is treated as false.
>  */
>-function openUILinkIn( url, where, allowThirdPartyFixup, postData, referrerUrl )
>-{
>+function openUILinkIn(url, where, aAllowThirdPartyFixup, aPostData, aReferrerURI) {
>   if (!where || !url)
>     return;
> 
>+  var aRelatedToCurrent;
>+  if (arguments.length == 3 &&
>+      typeof arguments[2] == "object") {
>+    let params = arguments[2];
>+    aAllowThirdPartyFixup = params.allowThirdPartyFixup;
>+    aPostData             = params.postData;
>+    aReferrerURI          = params.referrerURI;
>+    aRelatedToCurrent     = params.relatedToCurrent;
>+  }

Ok, so, I appreciate the backwards-compatness here.  Please actually update the comment to explain clearly how this is working.

With that, r=me
Attachment #421615 - Flags: review?(mconnor) → review+
Summary: When middle-clicking back/forward/reload, the new tab should open next to the current tab → Middle-clicking back/forward/reload should open the new tab next to the current one
Ctrl+clicking will have the same behavior, correct?
http://hg.mozilla.org/mozilla-central/rev/f53d65371670
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.7a1
Status: RESOLVED → VERIFIED
Can we get an automated test for it?
Flags: in-testsuite?
Flags: in-litmus?
Duplicate of this bug: 541444
Dao, would the patch apply on 1.9.2? Would be nice to have it for 3.6.1.
Version: unspecified → 3.6 Branch
Attached patch 1.9.2 patchSplinter Review
Attachment #423067 - Flags: approval1.9.2.1?
Duplicate of this bug: 544830
Comment on attachment 423067 [details] [diff] [review]
1.9.2 patch

Missed 1.9.2.2, but I think we should take this in 1.9.2.3 - moving flag.
Attachment #423067 - Flags: approval1.9.2.2? → approval1.9.2.3?
Blocks: 564677
Attachment #423067 - Flags: approval1.9.2.5?
Duplicate of this bug: 566117
Attachment #423067 - Flags: approval1.9.2.7?
Attachment #423067 - Flags: approval1.9.2.6-
Attachment #423067 - Flags: approval1.9.2.5?
Attachment #423067 - Flags: approval1.9.2.4?
Comment on attachment 423067 [details] [diff] [review]
1.9.2 patch

We will not be taking this for 3.6.6. Moving approval request forward.

If you disagree, send me an email.
Duplicate of this bug: 580569
Attachment #423067 - Flags: approval1.9.2.9?
You need to log in before you can comment on or make changes to this bug.