Can't build c-c when configured with a relative path (Fix regression from Bug 560007)

RESOLVED FIXED

Status

defect
P1
normal
RESOLVED FIXED
9 years ago
2 years ago

People

(Reporter: Callek, Assigned: Callek)

Tracking

({regression})

Trunk
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [pymake])

Attachments

(1 attachment)

The perl-msys-wrapper script was fixed for m-c in Bug 518401, and that is the setup I ported to c-c. However when I dropped the 1_9_2 ifdefs I erroneously did not ensure that I kept the relative paths working, as I attempted to make us use the m-c file.

This bug is about restoring that.
Summary: Can't build c-c when configured with a relative path (Fix regression from Bug 560007 → Can't build c-c when configured with a relative path (Fix regression from Bug 560007)
Will take review from whomever gets here first.
Attachment #445570 - Flags: review?(sgautherie.bz)
Attachment #445570 - Attachment is patch: true
Attachment #445570 - Attachment mime type: application/octet-stream → text/plain
Attachment #445570 - Flags: review?(kairo)
Attachment #445570 - Flags: review?(bugzilla)
Comment on attachment 445570 [details] [diff] [review]
Just fix it right.


I don't understand this bug/patch:
MOZILLA_SRCDIR looks to me like it's what c-c wants :-|
How does it break, actually?
Attachment #445570 - Flags: review?(sgautherie.bz) → feedback?(sgautherie.bz)
(In reply to comment #2)
> (From update of attachment 445570 [details] [diff] [review])
> 
> I don't understand this bug/patch:
> MOZILLA_SRCDIR looks to me like it's what c-c wants :-|
> How does it break, actually?

MOZILLA_SRCDIR is set as a relative path if configure is invoked with a relative path.

Whereas _topsrcdir is set as an absolute path (`cd \`dirname $0\`; pwd`) which is what we want here. As the path we set to the msys-perl-wrapper we use is hardcoded into autoconf.mk. Which if we don't use an absolute path here, we'll break.
Comment on attachment 445570 [details] [diff] [review]
Just fix it right.


Ah, got it in the meantime: I missed to read that you added /mozilla too :-<

I wonder if we could/would_want do some additionnal s/$topsrcdir/$_topsrcdir/,
or even use MOZILLA_SRCDIR=$_topsrcdir/mozilla
Attachment #445570 - Flags: feedback?(sgautherie.bz) → feedback+
(In reply to comment #4)
> (From update of attachment 445570 [details] [diff] [review])

If you would feel comfortable marking it r+ from your end, I'm happy to land with that since its a regression. Otherwise I'll wait for mark or robert.

> I wonder if we could/would_want do some additionnal s/$topsrcdir/$_topsrcdir/,
> or even use MOZILLA_SRCDIR=$_topsrcdir/mozilla

I was thinking on that too, but saving it for a followup.
(In reply to comment #5)

> If you would feel comfortable marking it r+ from your end, I'm happy to land
> with that since its a regression. Otherwise I'll wait for mark or robert.

I'm not a reviewer. (and I would leave that one to someone else anyway.)

> I was thinking on that too, but saving it for a followup.

(A followup should be fine.)

Ftr,
there are other ${MOZILLA_SRCDIR}/build/,
and some $srcdir/mozilla/build/.
I don't know if they all work right ... but I would wish to have them unified (as much as possible).
Attachment #445570 - Flags: review?(kairo) → review+
Attachment #445570 - Flags: review?(bugzilla)
(In reply to comment #5)
> (In reply to comment #4)
> > I wonder if we could/would_want do some additionnal s/$topsrcdir/$_topsrcdir/,
> > or even use MOZILLA_SRCDIR=$_topsrcdir/mozilla
> 
> I was thinking on that too, but saving it for a followup.

I once had the idea that the fact that mozilla sources are in mozilla/ is stored only in one or very few cases, so we theoretically could even switch that to something different. In the mean time, I think I grew less idealistic and just want things to work. ;-)
Duplicate of this bug: 566230
Pushed as: http://hg.mozilla.org/comm-central/rev/ef85cd92359d
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.