Form controls are transparent

VERIFIED FIXED

Status

VERIFIED FIXED
9 years ago
5 years ago

People

(Reporter: mbrubeck, Assigned: mbrubeck)

Tracking

(Depends on: 1 bug)

Dependency tree / graph
Bug Flags:
in-testsuite ?

Details

(Whiteboard: rc1.1, URL)

Attachments

(1 attachment)

(Assignee)

Description

9 years ago
Created attachment 445835 [details] [diff] [review]
patch

Bug 556650 caused a new bug when form controls appear against a non-white background, as on the login page at http://touch.facebook.com/ - the background color shows through the form controls because they are now transparent.

This problem also existed before bug 556650, but only for focused inputs (because it only the :focus styles used rgba gradients before).  You can still see this on mobile-1.1.

This patch sets a default background-color to make inputs opaque.  It still works as intended when the background-color is overridden, as in the test case from bug 556650.

For a test case, see: http://people.mozilla.com/~mbrubeck/test/form-background.html  (You may also notice in this test case that some of the disabled inputs do not appear disabled; I will file a separate bug for that.)
Attachment #445835 - Flags: review?(mark.finkle)
(Assignee)

Updated

9 years ago
Assignee: nobody → mbrubeck
Status: NEW → ASSIGNED
Whiteboard: rc1.1
Attachment #445835 - Flags: review?(mark.finkle) → review+
pushed to m-1.1:
http://hg.mozilla.org/releases/mobile-1.1/rev/a52aa2c26e21
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
verified FIXED on builds:

This bug is being moved to a resolved state of invalid due to one of the following reasons:

- we're moving to wordpress and so all drupal cruft is not going to be fixed
- the feature is not supported on the new qmo, at least for this release.
Status: RESOLVED → VERIFIED
Flags: in-testsuite?
shite, wrong copy and paste, 


Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2.5pre) Gecko/20100519 Namoroka/3.6.5pre Fennec/1.1b2pre

and

Mozilla/5.0 (X11; U; Linux armv71; Nokia N900; en-US; rv:1.9.3a5pre) Gecko/20100519 Namoroka/3.7a5pre Fennec/2.0a1pre
Depends on: 718847
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.