If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Line artifacts at some zoom levels

RESOLVED DUPLICATE of bug 566283

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 566283
7 years ago
7 years ago

People

(Reporter: adw, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

7 years ago
Created attachment 446114 [details]
Wikipedia screenshot, zoom +3

Some zoom levels on some pages cause stray lines to appear.  These lines are often black, but not always, and often they happen around images, but not always.  There's a similar bug 468496, but it's Linux- and image-only.

Attached are a few example screenshots.  In the Wikipedia shot there's a horizontal line across near the top the entire width of the page; a vertical black line at the right edge of the Wikipedia logo; black lines around the Discussion, Edit, and View history tabs at the top; and a black line under Toolbox in the left sidebar.

In the Google shot there are lines at the right and bottom sides of the logo.

The worst is Google Maps:  There are gray lines in a grid pattern within the map.
(Reporter)

Comment 1

7 years ago
Created attachment 446116 [details]
Google screenshot, zoom +1
(Reporter)

Comment 2

7 years ago
Created attachment 446117 [details]
Google Maps screenshot, zoom +1
(Reporter)

Comment 3

7 years ago
roc, any ideas?
This probably Mac cairo not doing EXTEND_PAD correctly. Jeff, did I hear something about that maybe being fixed in cairo?
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 566283
You need to log in before you can comment on or make changes to this bug.