Closed Bug 566827 Opened 10 years ago Closed 9 years ago

Privacy Leak: Windows 7 Jump List ignores "Clear history when Firefox closes" setting

Categories

(Firefox :: Shell Integration, defect, major)

x86
Windows 7
defect
Not set
major

Tracking

()

VERIFIED FIXED

People

(Reporter: smrank, Assigned: jimm)

References

Details

(Keywords: privacy, Whiteboard: See comment #7 for updated STR)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a5pre) Gecko/20100518 Minefield/3.7a5pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a5pre) Gecko/20100518 Minefield/3.7a5pre

Even if Firefox is set to clear history on exit the Windows 7 Jump List is not cleared on exit, this allows anyone to see where the user has browsed.


Reproducible: Always

Steps to Reproduce:
1. Pin Firefox to the Windows 7 Taskbar.
2. Create a new Firefox profile and enable Tools->Options->Privacy->"Clear history when Firefox closes".
3. Visit any web page.
4. Close Firefox.
5. Right-click the pinned Firefox icon on the Windows 7 Taskbar to show the Jump List.

Actual Results:  
The Jump List has a section called Frequent that will contain the site you just visited.


Expected Results:  
The Frequent section of the Jump List should not contain the site you just visited.
Keywords: privacy
Is it cleared in normal history menu and locationbar? since we have a regression tracked in bug 562644.
(In reply to comment #1)
> Is it cleared in normal history menu and locationbar? since we have a
> regression tracked in bug 562644.

I just checked and the problem still seems to occur in the following build so I don't think they're related:

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a5pre) Gecko/20100418 Minefield/3.7a5pre
Depends on: 534147
Hmm, I wonder if there's a specific observer event for this, or if the module will need to check the pref value manually. Hopefully the former!
Attached patch patch v.1Splinter Review
Moving this patch from bug 534147. (Sorry for the bug spam gavin!)
Assignee: nobody → jmathies
Attachment #446223 - Flags: review?(gavin.sharp)
Comment on attachment 446223 [details] [diff] [review]
patch v.1

Dao, at some point this got merged out of the original patch during all the revisions.
Attachment #446223 - Flags: review?(gavin.sharp) → review?(dao)
Attachment #446223 - Flags: review?(dao) → review+
http://hg.mozilla.org/mozilla-central/rev/ddf82fd505ae
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
I still see this with:
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a6pre) Gecko/20100620 Minefield/3.7a6pre

I'm not sure if my original STR were incorrect, or if they have changed but I need to do the following to reproduce this (note the new step 3a):
1. Pin Firefox to the Windows 7 Taskbar.
2. Create a new Firefox profile and enable Tools->Options->Privacy->"Clear
history when Firefox closes".
3. Visit any web page.
3a. Switch to a different tab.
4. Close Firefox.
5. Right-click the pinned Firefox icon on the Windows 7 Taskbar to show the
Jump List.

If the tab switching is not done then nothing is added to the frequent list (not sure if that is by design or a bug).
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Whiteboard: See comment #7 for updated STR
(In reply to comment #7)
> I still see this with:
> Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a6pre) Gecko/20100620
> Minefield/3.7a6pre

I no longer see this even with the new STR so I'm reverting this back to FIXED.

Mozilla/5.0 (Windows NT 6.1; rv:2.0b13pre) Gecko/20110321 Firefox/4.0b13pre
Status: REOPENED → RESOLVED
Closed: 10 years ago9 years ago
Resolution: --- → FIXED
Verified with Mozilla/5.0 (Windows NT 6.1; rv:2.2a1pre) Gecko/20110411 Firefox/4.2a1pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.