Last Comment Bug 567280 - In Windows 7 with large font and default theme Manage Identities button is not visible
: In Windows 7 with large font and default theme Manage Identities button is no...
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Theme (show other bugs)
: unspecified
: x86 Windows 7
: -- normal (vote)
: Thunderbird 9.0
Assigned To: Richard Marti (:Paenglab)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-20 17:48 PDT by ob
Modified: 2012-03-30 02:37 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Add scrollbars when needed (1.98 KB, patch)
2011-08-10 09:36 PDT, Richard Marti (:Paenglab)
bwinton: ui‑review+
Details | Diff | Splinter Review
Add scrollbars when needed v2 (5.35 KB, patch)
2011-08-25 09:54 PDT, Richard Marti (:Paenglab)
bwinton: review+
richard.marti: ui‑review+
Details | Diff | Splinter Review
Add scrollbars when needed - patch for check-in (63.23 KB, patch)
2011-09-22 11:17 PDT, Richard Marti (:Paenglab)
richard.marti: review+
richard.marti: ui‑review+
Details | Diff | Splinter Review

Description ob 2010-05-20 17:48:34 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.9) Gecko/20100317 Thunderbird/3.0.4

In Windows 7 with large font and default theme Manage Identities button is not visible

Reproducible: Always

Steps to Reproduce:
1. Set Windows 7 to Large Font
2. Open Account Settings Dialog
3. No Manage Identities!!!
Comment 1 Ludovic Hirlimann [:Usul] 2010-05-31 01:40:18 PDT
Andreas which one of the UX-jargon keyword should I use for this bug ?
Comment 2 Andreas Nilsson (:andreasn) 2010-06-01 06:06:28 PDT
I think you mean ux-keyword, ux-jargon is one of the keywords [1] ;)
I don't think it's any of them (the whole list is here[2]), this is just a regular accessibility theme bug and related to bug 416263 among others.

1. ux-jargon is basically the same as geek-talk.
2. http://spreadsheets.google.com/pub?key=tJxF8zTuLdEj9pUcxnLAemA&output=html
Comment 3 Ludovic Hirlimann [:Usul] 2010-06-09 07:44:07 PDT
True which one would you pick ? And correct me when I don't add the rights one on other bugs.
Comment 4 Ludovic Hirlimann [:Usul] 2010-11-25 22:16:35 PST
Mass move to the new theme component.
Comment 5 Only-me 2011-03-25 10:28:40 PDT
So you have got a name for that bug? 
And where is help? HELP!!!!
I cannot use TB at all, as my new Netbook with Win7 won't show the button for "other identities" in TB and I only send mails from those identities. So I bought the Netbook for nothing and have to use the old computer with TB 2.0 for the mails?
Any hints as to if and when the new TB will have the button for the identities again?
Comment 6 Ludovic Hirlimann [:Usul] 2011-03-28 02:10:32 PDT
The button might become visible if you make the dialog bigger.

Andreas could you look into this one ?
Comment 7 Richard Marti (:Paenglab) 2011-08-10 09:36:54 PDT
Created attachment 552099 [details] [diff] [review]
Add scrollbars when needed

I inserted a vbox with style="overflow: auto". If the pref window is smaller than the content, the scrollbar is shown. Now it is only implemented for "Account Settings", "Server Settings" and "Copies & Folders". The other settings are small enough and IMO don't need scrollbars. But I can add it when desired for consistency.
Comment 8 neil@parkwaycc.co.uk 2011-08-10 10:00:12 PDT
Alternative approach:
1. Add flex="1" to the <groupbox>
2. Remove flex="1" from the <grid>
3. Add flex="1" to the <hbox> immediately following the <grid>
Comment 9 Richard Marti (:Paenglab) 2011-08-10 10:33:44 PDT
(In reply to neil@parkwaycc.co.uk from comment #8)
> Alternative approach:
> 1. Add flex="1" to the <groupbox>
> 2. Remove flex="1" from the <grid>
> 3. Add flex="1" to the <hbox> immediately following the <grid>

Yes this works for the "Account Settings". But I don't see a possibility like this for "Server Settings" and "Copies & Folders". I'll wait for the ui-r if the scrollbars are okay.
Comment 10 Blake Winton (:bwinton) (:☕️) 2011-08-23 13:04:33 PDT
Comment on attachment 552099 [details] [diff] [review]
Add scrollbars when needed

Yeah, I'm not a huge fan of scrollbars, but they seem like the least bad way to fix this.  :)

I would also like to see this for Composition & Addressing, Junk Settings, Synchronization & Storage, Return Receipts, and Security, so ui-r=me with those added.
Comment 11 Richard Marti (:Paenglab) 2011-08-25 09:54:07 PDT
Created attachment 555763 [details] [diff] [review]
Add scrollbars when needed v2

Patch with the additional pages asked in comment 10. Giving ui-r+ after Blake's comment.
Comment 12 Mark Banner (:standard8, limited time in Dec) 2011-09-22 03:55:34 PDT
Comment on attachment 555763 [details] [diff] [review]
Add scrollbars when needed v2

Ok, I'm just not getting to this, in part because I need to test on windows 7 and I've not got that set up.

My only comment is that you should probably be indenting the code inside the vboxes that you are adding to follow the general style elsewhere.
Comment 13 Richard Marti (:Paenglab) 2011-09-22 04:06:10 PDT
The patch affects only XUL files. So this could also be tested under Linux or Mac.

I hesitated to indent the code because this would change almost every line of the files.
Comment 14 Blake Winton (:bwinton) (:☕️) 2011-09-22 09:58:47 PDT
Comment on attachment 555763 [details] [diff] [review]
Add scrollbars when needed v2

Review of attachment 555763 [details] [diff] [review]:
-----------------------------------------------------------------

Any reason you didn't add a scrollbar to the Outgoing Server Settings pane?
And yeah, I agree with Standard8 that the lines should be indented, even though it'll cause the diff to be large.

r=me with those two things fixed.

Thanks,
Blake.
Comment 15 Richard Marti (:Paenglab) 2011-09-22 11:17:06 PDT
Created attachment 561799 [details] [diff] [review]
Add scrollbars when needed - patch for check-in

Patch addressing the review comments:
- Added the scrollbar to the Outgoing Server Settings pane (am-smtp.xul)
- Indented the files.
Comment 16 Jonathan Protzenko [:protz] 2011-09-22 13:25:25 PDT
http://hg.mozilla.org/comm-central/rev/6e41730f8874
Comment 17 Mike Yates 2012-03-29 00:36:18 PDT
This is still an issue because the very existence of the button is unknown to new users. The window defaults to no-scroll-bars with the button removed so, unless you happen to know that it can be resized, the button is simply missing. In Linux the issue is worse because the resizing is made very difficult by the window extending below the 600-line bottom of the screen, so it cannot be resized with the mouse at all.

Would it not be better to replace the button with an "Identities" section in the tree on the left?

Note You need to log in before you can comment on or make changes to this bug.