Crash - OpenBlockingStream is returning the wrong value

VERIFIED DUPLICATE of bug 6188

Status

()

Core
Internationalization
P3
normal
VERIFIED DUPLICATE of bug 6188
19 years ago
18 years ago

People

(Reporter: Stephen P. Morse, Assigned: Warren Harris)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
If there are no property files, then the code used to access the property file
is causing a crash as shown by the stacktrace below.  In particular, the
following line in wallet was being used to access the property file:

     ret = pStringService->CreateBundle(url, locale, &bundle);

and the url variable was set to be a file url for a non-existent file.


ConverterInputStream::ConverterInputStream(nsIInputStream * 0x00000000,
nsIUnicodeDecoder * 0x01b40198, unsigned int 0) line 188 + 12 bytes
NS_NewConverterStream(nsIUnicharInputStream * * 0x026d97d8, nsISupports *
0x00000000, nsIInputStream * 0x00000000, int 0, nsString * 0x00000000) line 309
+ 39 bytes
nsPersistentProperties::Load(nsPersistentProperties * const 0x026d97d0,
nsIInputStream * 0x00000000) line 228 + 22 bytes
nsStringBundle::nsStringBundle(nsIURL * 0x026d8320, nsILocale * 0x00000000,
unsigned int * 0x0012e7d0) line 94 + 22 bytes
nsStringBundleService::CreateBundle(nsStringBundleService * const 0x026d89a0,
nsIURL * 0x026d8320, nsILocale * 0x00000000, nsIStringBundle * * 0x0012e828)
line 151 + 39 bytes
Wallet_Localize(char * 0x013a6cb0) line 432 + 24 bytes
SINGSIGN_DisplaySignonInfoAsHTML() line 2890 + 10 bytes
nsWalletlibService::SI_DisplaySignonInfoAsHTML(nsWalletlibService * const
0x01239eb0) line 82
nsBrowserAppCore::SignonViewer(nsBrowserAppCore * const 0x012d2680) line 511 +
12 bytes
BrowserAppCoreSignonViewer(JSContext * 0x01093eb0, JSObject * 0x01b494a0,
unsigned int 0, long * 0x01afae00, long * 0x0012e9e8) line 435 + 12 bytes
js_Invoke(JSContext * 0x01093eb0, unsigned int 0, int 0) line 650 + 26 bytes
js_Interpret(JSContext * 0x01093eb0, long * 0x0012f1ec) line 2199 + 15 bytes
js_Invoke(JSContext * 0x01093eb0, unsigned int 0, int 0) line 666 + 13 bytes
js_Interpret(JSContext * 0x01093eb0, long * 0x0012f9ac) line 2199 + 15 bytes
js_Invoke(JSContext * 0x01093eb0, unsigned int 1, int 0) line 666 + 13 bytes
js_CallFunctionValue(JSContext * 0x01093eb0, JSObject * 0x01b4a918, long
28616992, unsigned int 1, long * 0x0012fad8, long * 0x0012fae0) line 735 + 15
bytes
JS_CallFunctionValue(JSContext * 0x01093eb0, JSObject * 0x01b4a918, long
28616992, unsigned int 1, long * 0x0012fad8, long * 0x0012fae0) line 2437 + 29
bytes
nsJSEventListener::HandleEvent(nsIDOMEvent * 0x026d7920) line 97 + 34 bytes
nsEventListenerManager::HandleEvent(nsIPresContext & {...}, nsEvent *
0x0012fc98, nsIDOMEvent * * 0x0012fc2c, unsigned int 3, nsEventStatus &
nsEventStatus_eIgnore) line 555 + 21 bytes
RDFElementImpl::HandleDOMEvent(RDFElementImpl * const 0x0135b320, nsIPresContext
& {...}, nsEvent * 0x0012fc98, nsIDOMEvent * * 0x0012fc2c, unsigned int 1,
nsEventStatus & nsEventStatus_eIgnore) line 2247
nsMenuItem::DoCommand(nsMenuItem * const 0x026d7c00) line 364 + 56 bytes
nsMenuItem::MenuItemSelected(const nsMenuEvent & {...}) line 389
nsWindow::ProcessMessage(unsigned int 273, unsigned int 12, long 0, long *
0x0012fe38) line 2118
nsWindow::WindowProc(void * 0x00200168, unsigned int 273, unsigned int 12, long
0) line 478 + 27 bytes
USER3

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M6

Comment 1

19 years ago
Thanks, Steve. Since there are no callers yet, I will mark this M6.

Updated

19 years ago
Assignee: erik → warren
Status: ASSIGNED → NEW
Target Milestone: M6

Comment 2

19 years ago
nsINetService::OpenBlockingStream is returning the wrong value. It should be
returning an nsresult.

Updated

19 years ago
Summary: crash if i18n's property files are missing. → Crash - OpenBlockingStream is returning the wrong value

Comment 3

19 years ago
Changed summary.
  Old: crash if i18n's property files are missing.
  New: Crash - OpenBlockingStream is returning the wrong value
(Assignee)

Updated

19 years ago
Target Milestone: M9
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Depends on: 7232
(Assignee)

Comment 4

19 years ago
Verify that this doesn't happen in necko.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 5

19 years ago
*** This bug has been marked as a duplicate of 6188 ***

Updated

19 years ago
No longer depends on: 7232

Updated

19 years ago
Blocks: 7232

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 6

18 years ago
Verified as dup.
You need to log in before you can comment on or make changes to this bug.