Switch to tab makes opening the correct page harder

RESOLVED DUPLICATE of bug 596485

Status

()

defect
RESOLVED DUPLICATE of bug 596485
9 years ago
8 years ago

People

(Reporter: notforyourmail, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: wontfix? [swith-to-tab])

Reporter

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.3a5pre) Gecko/20100524 Minefield/3.7a5pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.3a5pre) Gecko/20100524 Minefield/3.7a5pre

Recent builds of Minefield have included a "switch to tab" feature in the location bar.  I start typing in something I want to see, and suddenly there is a "switch to tab" listing for it.  Then rather than being able to type "q" for my hulu queue, I have to watch to make sure that I'm not switching to something in an existing tab.  Additionally, the feature is very confusing.  It took me a few days to realize what it was, and why it was doing what it did.  Please provide a way to disable it, or disable it completely.  It makes it much harder to use the location bar.  Plus, I could switch to that tab just by clicking on it...

Reproducible: Always

Steps to Reproduce:
1. Open a tab to a location you visit frequently by typing the first letter into the location bar
2. Repeat.  a listing of "switch to tab" will appear for the tab you have open
3. Now you have to move down an additional listing to get to pages you don't currently have open.  
Actual Results:  
Getting to other results is harder, because switch to tab is in the way.  Getting to an existing result is harder, because you have to figure out if it is already open in a tab, and if what you want is different from that tab.

Expected Results:  
Listing contains urls for pages you visit frequently, not for already open tabs.

Updated

9 years ago
Component: General → Location Bar
OS: Mac OS X → All
QA Contact: general → location.bar
Hardware: x86 → All
Whiteboard: wontfix?
Version: unspecified → Trunk
I agree with the report, "switch to tab" makes it impossible to develop muscle memory in combination the awesome bar. There should be an option to disable it.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

9 years ago
Why can't there be an about:config option at minimum to disable this thing.
please, avoid cross-posting across bugs.

Comment 4

9 years ago
Can this PLEASE have an option to disable it..  It is VERY frustrating and gets in the way of my daily usage of the browser.

Or.. Can you point to which code would need to be "modified" to support ability to disable and I will provide a patch.

This "feature" alone is enough for me to stay with FF 3.6 long term or find another browser as it is exceedingly frustrating.

Comment 5

9 years ago
This is a regression for some users.

It is not a feature which users may get used to in time, it removes existing functionality for some users.

If you want to open multiple copies of a website, or page, you can't do this through the Awesomebar.

The notification that you have this page open in a tab is valuable, as is being able to rapidly switch to it, in a familiar manner.

The inability to either turn off the feature altogether, or to say 'No, I want to open a new tab' removes functionality.

One way that would seem to be discoverable would be to have a separate 'Open new' on the right - analgous to the 'switch to tab' on the left.

Clicking on the right half of the bar allows you to open a new tab.

Alternately, if the user is confused about what's happening, and is hovering over the awesomebar item with 'switch to tab' - they may benefit from a tooltip saying 'click right-hand button to open in a new tab'.




Marco - is there another relevant bug on this issue?

Updated

9 years ago
Duplicate of this bug: 587611

Comment 7

9 years ago
I believe this is a duplicate - it seems functionality already exists - see bug 596485 .
This bug is really a duplicate of that, as it's not discoverable.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 596485
(In reply to comment #2)
> Why can't there be an about:config option at minimum to disable this thing.

Actually there is.. just have to read through bug 530209 to find what your looking for, configure the awesomebar results.  Otherwise its shift or alt.

Comment 9

9 years ago
(In reply to comment #8)
> (In reply to comment #2)
> > Why can't there be an about:config option at minimum to disable this thing.
> 
> Actually there is.. just have to read through bug 530209 to find what your
> looking for, configure the awesomebar results.  Otherwise its shift or alt.

Dennis, after personally testing each of those options in 4.0b10, I can confirm that this is absolutely not the case.  Every option shows the Switch to Tab feature if there is an available match for the filter.
I just meant you should follow the bug about the pref that exists behind it, whether it works as advertised or not is not what I was saying.
Whiteboard: wontfix? → wontfix? [swith-to-tab]
Duplicate of this bug: 657457
You need to log in before you can comment on or make changes to this bug.