Closed Bug 568204 Opened 9 years ago Closed 9 years ago

Fennec on xulrunner does not build with --enable-debug

Categories

(Firefox Build System :: General, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: tero.koskinen, Assigned: romaxa)

References

Details

(Keywords: regression)

Attachments

(5 files)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fi-FI; rv:1.9.2.3) Gecko/20100423 Ubuntu/10.04 (lucid) Firefox/3.6.3
Build Identifier: 

Electrolysis+fennec build dies to "No rule to make target `-lxpcom'" message when I try to compile it with --enable-debug flag.


Reproducible: Always

Steps to Reproduce:
1. Fetch Electrolysis and Mobile-e10s sources from hg.mozilla.org 
2. Add "ac_add_options --enable-debug" line to mozconfig
3. Try to build e10s+fennec combination with "make -f client.mk build"

Actual Results:  
Build fails with error:
make[6]: Leaving directory `/work/tkoskine/mobile/mobilebase-7/xulrunner/layout/xul/base/test'
make[6]: Entering directory `/work/tkoskine/mobile/mobilebase-7/xulrunner/layout/build'
/work/tkoskine/mobile/mobilebase-7/xulrunner/config/nsinstall -R -m 644 libgklayout.a ../../staticlib/components
make[6]: Leaving directory `/work/tkoskine/mobile/mobilebase-7/xulrunner/layout/build'
make[6]: Entering directory `/work/tkoskine/mobile/mobilebase-7/xulrunner/layout/tools/pageloader'
/work/tkoskine/mobile/mobilebase-7/xulrunner/config/nsinstall -R -m 644 /work/tkoskine/mobile/electrolysis/layout/tools/pageloader/tp-cmdline.js ../../../dist/bin/components
/usr/bin/python2.6 /work/tkoskine/mobile/electrolysis/config/JarMaker.py \
           -j ../../../dist/bin/chrome \
          -t /work/tkoskine/mobile/electrolysis -f jar  -DDEBUG -D_DEBUG -DDEBU_tkoskine -DTRACING -DOSTYPE=\"Linux2.6\" -DOSARCH=Linux -DMOZILLA_VERSION=\"1..3a5pre\" -DMOZILLA_VERSION_U=1.9.3a5pre -DD_INO=d_ino -DSTDC_HEADERS=1 -DHAVE_SIZE_T=1 -DHAVE_ST_BLKSIZE=1 -DHAVE_SIGINFO_T=1 -DHAVE_INT16_T=1 -DHAVE_INT32_T1 -DHAVE_INT64_T=1 -DHAVE_UINT=1 -DHAVE_UNAME_DOMAINNAME_FIELD=1 -DHAVE_VISIBILTY_HIDDEN_ATTRIBUTE=1 -DHAVE_VISIBILITY_ATTRIBUTE=1 -DHAVE_DIRENT_H=1 -DHAVE_GEOPT_H=1 -DHAVE_SYS_BITYPES_H=1 -DHAVE_MEMORY_H=1 -DHAVE_UNISTD_H=1 -DHAVE_GNU_LBC_VERSION_H=1 -DHAVE_NL_TYPES_H=1 -DHAVE_MALLOC_H=1 -DHAVE_X11_XKBLIB_H=1 -DHAE_SYS_STATVFS_H=1 -DHAVE_SYS_STATFS_H=1 -DHAVE_SYS_QUOTA_H=1 -DHAVE_SYS_CDEFS_H1 -DHAVE_LIBM=1 -DHAVE_LIBDL=1 -DHAVE_DLADDR=1 -DFUNCPROTO=15 -DHAVE_XSHM=1 -DHVE_FT_BITMAP_SIZE_Y_PPEM=1 -DHAVE_FT_GLYPHSLOT_EMBOLDEN=1 -DHAVE_FT_LOAD_SFNT_TBLE=1 -DHAVE_FT_SELECT_SIZE=1 -D_REENTRANT=1 -DHAVE_RANDOM=1 -DHAVE_STRERROR=1 DHAVE_LCHOWN=1 -DHAVE_FCHMOD=1 -DHAVE_SNPRINTF=1 -DHAVE_MEMMOVE=1 -DHAVE_RINT=1-DHAVE_STAT64=1 -DHAVE_LSTAT64=1 -DHAVE_TRUNCATE64=1 -DHAVE_SETBUF=1 -DHAVE_ISATY=1 -DHAVE_FLOCKFILE=1 -DHAVE_LOCALTIME_R=1 -DHAVE_STRTOK_R=1 -DHAVE_CLOCK_MONTONIC=1 -DHAVE_RES_NINIT=1 -DHAVE_GNU_GET_LIBC_VERSION=1 -DHAVE_LANGINFO_CODESE=1 -DVA_COPY=va_copy -DHAVE_VA_COPY=1 -DHAVE_THREAD_TLS_KEYWORD=1 -DMALLOC_H=\<alloc.h\> -DHAVE_STRNDUP=1 -DHAVE_POSIX_MEMALIGN=1 -DHAVE_MEMALIGN=1 -DHAVE_VALOC=1 -DHAVE_I18N_LC_MESSAGES=1 -DNS_ALWAYS_INLINE=__attribute__\(\(always_inlin\)\) -DNS_ATTR_MALLOC=__attribute__\(\(malloc\)\) -DNS_WARN_UNUSED_RESULT=__attibute__\(\(warn_unused_result\)\) -DNS_NORETURN=__attribute__\(\(noreturn\)\) -MOZ_XULRUNNER=1 -DMOZ_BUILD_APP=xulrunner -DMOZ_X11=1 -DMOZ_WIDGET_GTK2=1 -DMOZENABLE_XREMOTE=1 -DMOZ_DISTRIBUTION_ID=\"org.mozilla\" -DMOZ_PANGO=1 -DMOZ_ENABE_GNOMEVFS=1 -DMOZ_ENABLE_GCONF=1 -DMOZ_ENABLE_LIBNOTIFY=1 -DMOZ_ENABLE_GNOMEUI1 -DMOZ_ENABLE_DBUS=1 -DMOZ_IPC=1 -DIBMBIDI=1 -DMOZ_VIEW_SOURCE=1 -DACCESSIBILIY=1 -DMOZ_JSLOADER=1 -DNS_PRINTING=1 -DNS_PRINT_PREVIEW=1 -DMOZ_OGG=1 -DATTRIBUE_ALIGNED_MAX=64 -DMOZ_WAVE=1 -DMOZ_SYDNEYAUDIO=1 -DMOZ_MEDIA=1 -DMOZ_XTF=1 -DMZ_CRASHREPORTER_ENABLE_PERCENT=100 -DMOZ_MATHML=1 -DMOZ_SVG=1 -DMOZ_SMIL=1 -DMO_UPDATE_CHANNEL=default -DMOZ_FEEDS=1 -DMOZ_STORAGE=1 -DMOZ_DEBUG_SYMBOLS=1 -DMZ_LOGGING=1 -DSIZEOF_INT_P=4 -DMOZ_MEMORY_SIZEOF_PTR_2POW=2 -DMOZ_MEMORY=1 -DMO_MEMORY_DEBUG=1 -DMOZ_MEMORY_LINUX=1 -DHAVE_JEMALLOC_VALLOC=1 -DHAVE_JEMALLOC_PSIX_MEMALIGN=1 -DHAVE_JEMALLOC_MEMALIGN=1 -DHAVE___CXA_DEMANGLE=1 -DMOZ_DEMANGL_SYMBOLS=1 -DHAVE__UNWIND_BACKTRACE=1 -DMOZ_CHROME_FILE_FORMAT_JAR=1 -DMOZ_USERDIR=\".mozilla\" -DMOZ_ENABLE_LIBXUL=1 -DHAVE_STDINT_H=1 -DHAVE_INTTYPES_H=1 -DOZ_TREE_CAIRO=1 -DHAVE_UINT64_T=1 -DMOZ_XUL=1 -DMOZ_PROFILELOCKING=1 -DMOZ_RDF= -DBUILD_CTYPES=1 -DMOZ_MORKREADER=1 -DMOZ_PLACES=1 -DMOZ_DLL_SUFFIX=\".so\" -DAVE_FONTCONFIG_FCFREETYPE_H=1 -DXP_UNIX=1 -DUNIX_ASYNC_DNS=1 -DMOZ_REFLOW_PERF= -DMOZ_REFLOW_PERF_DSP=1 -DMOZ_ACCESSIBILITY_ATK=1 -DATK_MAJOR_VERSION=1 -DATK_INOR_VERSION=30 -DATK_REV_VERSION=0  \
          /work/tkoskine/mobile/electrolysis/layout/tools/pageloader/jar.mn
processing /work/tkoskine/mobile/electrolysis/layout/tools/pageloader/jar.mn
make[6]: Leaving directory `/work/tkoskine/mobile/mobilebase-7/xulrunner/layouttools/pageloader'
make[6]: Entering directory `/work/tkoskine/mobile/mobilebase-7/xulrunner/layou/tools/layout-debug'
make[7]: Entering directory `/work/tkoskine/mobile/mobilebase-7/xulrunner/layou/tools/layout-debug/src'
make[7]: *** No rule to make target `-lxpcom', needed by `libgkdebug.so'.  Stop
make[7]: Leaving directory `/work/tkoskine/mobile/mobilebase-7/xulrunner/layouttools/layout-debug/src'
make[6]: *** [libs] Error 2
make[6]: Leaving directory `/work/tkoskine/mobile/mobilebase-7/xulrunner/layouttools/layout-debug'
make[5]: *** [libs] Error 2
make[5]: Leaving directory `/work/tkoskine/mobile/mobilebase-7/xulrunner/layout
make[4]: *** [libs_tier_platform] Error 2
make[4]: Leaving directory `/work/tkoskine/mobile/mobilebase-7/xulrunner'
make[3]: *** [tier_platform] Error 2
make[3]: Leaving directory `/work/tkoskine/mobile/mobilebase-7/xulrunner'
make[2]: *** [default] Error 2
make[2]: Leaving directory `/work/tkoskine/mobile/mobilebase-7/xulrunner'
make[1]: *** [build] Error 2
make[1]: Leaving directory `/work/tkoskine/mobile/electrolysis'
make: *** [build] Error 2


Expected Results:  
Build is successful.

Used revisions were:
 90fa3f90c0f7 for http://hg.mozilla.org/projects/electrolysis
 3ee20eee5d44 for http://hg.mozilla.org/users/pavlov_mozilla.com/mobile-e10s

I don't know is the problem on the fennec side or on the e10s side. Mozilla-central seems to build ok with --enable-debug.

mozconfig:
# Options for client.mk.
mk_add_options MOZ_BUILD_PROJECTS="xulrunner mobile"
mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/../mobilebase-7

# Global options
ac_add_options --enable-debug
ac_add_options --disable-optimize
ac_add_options --enable-tests
ac_add_options --disable-crashreporter

# XULRunner options
ac_add_app_options xulrunner --enable-application=xulrunner
ac_add_app_options xulrunner --disable-javaxpcom

# mobile options
ac_add_app_options mobile --enable-application=mobile
ac_add_app_options mobile --with-libxul-sdk=../xulrunner/dist

ac_add_app_options mobile --enable-chrome-format=flat

ac_add_options --enable-ipc

# export MOZ_MAKE_FLAGS=-j9
# mk_add_options MOZ_MAKE_FLAGS=-j9
##END
Attached patch works around the build failure by disabling the building of layout-debug and gkdebug.
Blocks: 534694
Keywords: regression
Does the problem go away by removing --enable-ipc?
This has nothing to do with IPC, it looks like a build ordering problem with layout-debug and libxul. http://mxr.mozilla.org/mozilla-central/source/layout/Makefile.in#90 should be TOOL_DIRS
Status: UNCONFIRMED → NEW
Component: IPC → Build Config
Ever confirmed: true
QA Contact: ipc → build-config
Attached patch Patch (v1)Splinter Review
Assignee: nobody → ehsan
Status: NEW → ASSIGNED
Attachment #447665 - Flags: review?(ted.mielczarek)
Attachment #447665 - Flags: review?(benjamin)
Attachment #447665 - Flags: review?(ted.mielczarek)
Attachment #447665 - Flags: review?(benjamin)
Attachment #447665 - Flags: review+
Comment on attachment 447665 [details] [diff] [review]
Patch (v1)

If you tested this, r=me!
(In reply to comment #5)
> (From update of attachment 447665 [details] [diff] [review])
> If you tested this, r=me!

Hmm, well I was under the impression that it worked, but I got curious and tried to reproduce the original problem, but I can't, even without this patch.  So I'm not so sure if this will actually solve the problem.

Tero, could you please test this patch?
(In reply to comment #6)
> (In reply to comment #5)
> > (From update of attachment 447665 [details] [diff] [review] [details])
> > If you tested this, r=me!
> 
> Tero, could you please test this patch?

The patch fixes the original error but with the patch the compilation dies to following error:
make[5]: Entering directory `/home/tkoskine/work/mozilla/mobilebase-8/xulrunner/toolkit/library'
make[5]: *** No rule to make target `../../staticlib/components/libgkdebug.a', needed by `libxul.so'.  Stop.
make[5]: Leaving directory `/home/tkoskine/work/mozilla/mobilebase-8/xulrunner/toolkit/library'


Here is full build log without the patch (on Fedora 13/i386):
http://iki.fi/tero.koskinen/mozilla/mozilla-e10s-build.txt (7MB)

And here is the log with the patch:
http://iki.fi/tero.koskinen/mozilla/mozilla-e10s-build-2.txt (7MB)

Error messages in the logs are in Finnish, sorry about that.
But you probably can get the idea.

I can repeat the error on two different systems, Ubuntu 10.04/i386
and Fedora 13/i386.
Could you try removing this line *without* the patch I posted?

http://mxr.mozilla.org/mozilla-central/source/layout/tools/layout-debug/src/Makefile.in#71

Also, could you please translate this error message?

make[7]: *** "libgkdebug.so"-kohteen tarvitseman kohteen "-lxpcom" tuottamiseen ei ole sääntöä. Seis.
Unassigning from myself for now.  Ted, it would be great if you could take a look at this.
Assignee: ehsan → nobody
Status: ASSIGNED → NEW
Tero's reply to me via email:

> Could you try removing this line *without* the patch I posted?

I'll can probably try it during the weekend or on Monday. Today I am busy with
other things.

> http://mxr.mozilla.org/mozilla-central/source/layout/tools/layout-debug/src/Makefile.in#71
>
> Also, could you please translate this error message?
>
> make[7]: *** "libgkdebug.so"-kohteen tarvitseman kohteen "-lxpcom" tuottamiseen
> ei ole sääntöä. Seis.

The translation is
"make[7]: *** No rule to make target `-lxpcom', needed by `libgkdebug.so'.  Stop"

Same as in the original description.
(In reply to comment #8)
> Could you try removing this line *without* the patch I posted?
> 
> http://mxr.mozilla.org/mozilla-central/source/layout/tools/layout-debug/src/Makefile.in#71

This didn't help. Still same error message.

Change which I tried in diff format:
$ cd electrolysis/
/home/tkoskine/work/fennec-debug-2/electrolysis
$ hg diff
diff --git a/layout/tools/layout-debug/src/Makefile.in b/layout/tools/layout-debug/src/Makefile.in
--- a/layout/tools/layout-debug/src/Makefile.in
+++ b/layout/tools/layout-debug/src/Makefile.in
@@ -63,17 +63,16 @@ EXPORTS             = \
 CPPSRCS                = \
                nsDebugFactory.cpp \
                nsLayoutDebugCLH.cpp \
                nsLayoutDebuggingTools.cpp \
                nsRegressionTester.cpp \
                $(NULL)
 
 EXTRA_DSO_LDOPTS = \
-               $(LIBS_DIRS) \
                $(MOZ_UNICHARUTIL_LIBS) \
                $(MOZ_COMPONENT_LIBS) \
                $(NULL)
 
 include $(topsrcdir)/config/rules.mk
 
 libs::
 
$

Error message below:
c++ -o nsLayoutDebuggingTools.o -c -I../../../../dist/stl_wrappers -I../../../../dist/system_wrappers -include /work/tkoskine/fennec-debug-2/electrolysis/config/gcc_hidden.h -DXPCOM_TRANSLATE_NSGM_ENTRY_POINT=1 -DMOZILLA_INTERNAL_API -D_IMPL_NS_COM -DEXPORT_XPT_API -DEXPORT_XPTC_API -D_IMPL_NS_GFX -D_IMPL_NS_WIDGET -DIMPL_XREAPI -DIMPL_NS_NET -DIMPL_THEBES  -DZLIB_INTERNAL -DOSTYPE=\"Linux2.6\" -DOSARCH=Linux  -I/work/tkoskine/fennec-debug-2/electrolysis/layout/tools/layout-debug/src -I. -I../../../../dist/include -I../../../../dist/include/nsprpub  -I/work/tkoskine/fennec-debug-2/mobilebase-2/xulrunner/dist/include/nspr -I/work/tkoskine/fennec-debug-2/mobilebase-2/xulrunner/dist/include/nss       -fPIC  -fno-rtti -fno-exceptions -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-variadic-macros -Werror=return-type -pedantic -Wno-long-long -fno-strict-aliasing -fshort-wchar -pthread -pipe  -DDEBUG -D_DEBUG -DDEBUG_tkoskine -DTRACING -g   -DMOZILLA_CLIENT -include ../../../../mozilla-config.h -Wp,-MD,.deps/nsLayoutDebuggingTools.pp /work/tkoskine/fennec-debug-2/electrolysis/layout/tools/layout-debug/src/nsLayoutDebuggingTools.cpp
nsRegressionTester.cpp
c++ -o nsRegressionTester.o -c -I../../../../dist/stl_wrappers -I../../../../dist/system_wrappers -include /work/tkoskine/fennec-debug-2/electrolysis/config/gcc_hidden.h -DXPCOM_TRANSLATE_NSGM_ENTRY_POINT=1 -DMOZILLA_INTERNAL_API -D_IMPL_NS_COM -DEXPORT_XPT_API -DEXPORT_XPTC_API -D_IMPL_NS_GFX -D_IMPL_NS_WIDGET -DIMPL_XREAPI -DIMPL_NS_NET -DIMPL_THEBES  -DZLIB_INTERNAL -DOSTYPE=\"Linux2.6\" -DOSARCH=Linux  -I/work/tkoskine/fennec-debug-2/electrolysis/layout/tools/layout-debug/src -I. -I../../../../dist/include -I../../../../dist/include/nsprpub  -I/work/tkoskine/fennec-debug-2/mobilebase-2/xulrunner/dist/include/nspr -I/work/tkoskine/fennec-debug-2/mobilebase-2/xulrunner/dist/include/nss       -fPIC  -fno-rtti -fno-exceptions -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-variadic-macros -Werror=return-type -pedantic -Wno-long-long -fno-strict-aliasing -fshort-wchar -pthread -pipe  -DDEBUG -D_DEBUG -DDEBUG_tkoskine -DTRACING -g   -DMOZILLA_CLIENT -include ../../../../mozilla-config.h -Wp,-MD,.deps/nsRegressionTester.pp /work/tkoskine/fennec-debug-2/electrolysis/layout/tools/layout-debug/src/nsRegressionTester.cpp
make[7]: *** "libgkdebug.so"-kohteen tarvitseman kohteen "-lxpcom" tuottamiseen ei ole sääntöä. Seis.
make[7]: Poistutaan hakemistosta "/work/tkoskine/fennec-debug-2/mobilebase-2/xulrunner/layout/tools/layout-debug/src"
make[6]: *** [libs] Virhe 2
make[6]: Poistutaan hakemistosta "/work/tkoskine/fennec-debug-2/mobilebase-2/xulrunner/layout/tools/layout-debug"
Attached file testcase script
Here is a testcase which reproduces the original build error for me.

Adjust hg repository paths if needed and run "sh testcase.sh".
Problem still reproducible on latest m-c:3559a37d183f

rm -f libgkdebug.so
c++  -fno-rtti -fno-exceptions -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-variadic-macros -Werror=return-type -pedantic -Wno-long-long -fno-strict-aliasing -fshort-wchar -pthread -pipe  -DDEBUG -D_DEBUG -DTRACING -g -fPIC -shared -Wl,-z,defs -Wl,-h,libgkdebug.so -o libgkdebug.so  nsDebugFactory.o nsLayoutDebugCLH.o nsLayoutDebuggingTools.o nsRegressionTester.o     -lpthread    -Wl,-rpath-link,obj-mobilebase-qt-dbg/xulrunner/dist/bin -Wl,-rpath-link,/usr/local/lib  obj-mobilebase-qt-dbg/xulrunner/dist/lib/libunicharutil_s.a -Lobj-mobilebase-qt-dbg/xulrunner/dist/bin -lxpcom -lmozalloc -lxul  -Lobj-mobilebase-qt-dbg/xulrunner/dist/bin -Lobj-mobilebase-qt-dbg/xulrunner/dist/lib -lplds4 -lplc4 -lnspr4 -lpthread -ldl   -Wl,-Bsymbolic -ldl -lm  -lQtNetwork -lQtOpenGL -lQtGui -lQtCore     
nsLayoutDebugCLH.o: In function `nsLayoutDebugCLH::QueryInterface(nsID const&, void**)':
layout/tools/layout-debug/src/nsLayoutDebugCLH.cpp:59: undefined reference to `NS_TableDrivenQI(void*, QITableEntry const*, nsID const&, void**)'
nsLayoutDebugCLH.o: In function `nsLayoutDebugCLH::GetHelpInfo(nsACString_internal&)':
layout/tools/layout-debug/src/nsLayoutDebugCLH.cpp:114: undefined reference to `nsACString_internal::Assign(nsACString_internal const&)'
nsLayoutDebugCLH.o: In function `nsAString_internal::Truncate(unsigned int)':
obj-mobilebase-qt-dbg/xulrunner/layout/tools/layout-debug/src/../../../../dist/include/nsTSubstring.h:470: undefined reference to `nsAString_internal::SetLength(unsigned int)'
nsLayoutDebugCLH.o: In function `nsString':
obj-mobilebase-qt-dbg/xulrunner/layout/tools/layout-debug/src/../../../../dist/include/nsTString.h:426: undefined reference to `nsAString_internal::nsAString_internal(unsigned short*, unsigned int, unsigned int)'
nsLayoutDebugCLH.o: In function `~nsString':
obj-mobilebase-qt-dbg/xulrunner/layout/tools/layout-debug/src/../../../../dist/include/nsTString.h:55: undefined reference to `nsAString_internal::~nsAString_internal()'
nsLayoutDebugCLH.o: In function `nsAutoString':
obj-mobilebase-qt-dbg/xulrunner/layout/tools/layout-debug/src/../../../../dist/include/nsTString.h:493: undefined reference to `nsFixedString::nsFixedString(unsigned short*, unsigned int, unsigned int)'
nsLayoutDebugCLH.o: In function `nsCString':
obj-mobilebase-qt-dbg/xulrunner/layout/tools/layout-debug/src/../../../../dist/include/nsTString.h:426: undefined reference to `nsACString_internal::nsACString_internal(char*, unsigned int, unsigned int)'
nsLayoutDebugCLH.o: In function `~nsCString':
obj-mobilebase-qt-dbg/xulrunner/layout/tools/layout-debug/src/../../../../dist/include/nsTString.h:55: undefined reference to `nsACString_internal::~nsACString_internal()'
nsLayoutDebugCLH.o: In function `nsCreateInstanceByContractID':
obj-mobilebase-qt-dbg/xulrunner/layout/tools/layout-debug/src/../../../../dist/include/nsComponentManagerUtils.h:96: undefined reference to `vtable for nsCreateInstanceByContractID'
/usr/bin/ld: nsLayoutDebugCLH.o: relocation R_386_GOTOFF against undefined hidden symbol `vtable for nsCreateInstanceByContractID' can not be used when making a shared object
/usr/bin/ld: final link failed: Bad value
collect2: ld returned 1 exit status
make[7]: *** [libgkdebug.so] Error 1
make[7]: Leaving directory `obj-mobilebase-qt-dbg/xulrunner/layout/tools/layout-debug/src'
make[6]: *** [libs] Error 2
make[6]: Leaving directory `obj-mobilebase-qt-dbg/xulrunner/layout/tools/layout-debug'
Do we even want layout-debugger in Fennec?  Because if not, the fix to this bug should be very simple (i.e., not build layout-debugger on Fennec at all!).
yes, that is what I'm currently doing (patch commenting out debugger compilation)... do we have configure option for disabling layout-debugger ? should we create one?
Note that this is a xulrunner+mobile build, and it's breaking in the xulrunner half. We probably shouldn't break xulrunner --enable-debug builds.
(In reply to comment #15)
> yes, that is what I'm currently doing (patch commenting out debugger
> compilation)... do we have configure option for disabling layout-debugger ?

We don't.

> should we create one?

I don't think so.  We should just figure out a way to fix this bug.
If I had to guess from comment 13 layout-debug getting built with internal linkage which probably shouldn't happen since it's a XUL app in a XULRunner build.
Was compiling debug build with latest m-c, and got this:
make[7]: *** No rule to make target `-lxpcom', needed by `libgkdebug.so'.  Stop.
make[7]: *** Waiting for unfinished jobs....
make[7]: Leaving directory `obj-mobilebase-qt-arm-dbg/xulrunner/layout/tools/layout-debug/src'
make[6]: *** [libs] Error 2
make[6]: Leaving directory `obj-mobilebase-qt-arm-dbg/xulrunner/layout/tools/layout-debug'
make[5]: *** [libs] Error 2
make[5]: Leaving directory `obj-mobilebase-qt-arm-dbg/xulrunner/layout'
Please | make showtargs | in that directory and paste the output.
Comment on attachment 447665 [details] [diff] [review]
Patch (v1)

Isn't there a typo here, it's supposed to be TOOL_DIRS instead of TOOLS_DIRS?
Summary: [E10S] Fennec+electrolysis does not build with --enable-debug → Fennec on xulrunner does not build with --enable-debug
Attachment #495456 - Flags: review?(benjamin)
Comment on attachment 495456 [details] [diff] [review]
Fix xulrunner debug + libxul build

Gah, can't we actually fix the bug here? Anyway, punting to a layout peer.
Attachment #495456 - Flags: review?(benjamin) → review?(dbaron)
What's different about xulrunner from firefox such that this would work in firefox but not xulrunner?
Comment on attachment 495456 [details] [diff] [review]
Fix xulrunner debug + libxul build

Anyway, this really seems like the wrong fix; it doesn't seem like this should be too hard to fix considering it works fine for Firefox.
Attachment #495456 - Flags: review?(dbaron) → review-
ok, I found this
http://mxr.mozilla.org/mozilla-central/source/layout/tools/layout-debug/Makefile.in#50

so if MOZ_XULRUNNER enabled then we build as a standalone XUL app... that is causing 568204#c13.

When I disabling that block then it works... should I remove that?
Attached patch Another fixSplinter Review
Assignee: nobody → romaxa
Status: NEW → ASSIGNED
Attachment #495980 - Flags: review?(dbaron)
Comment on attachment 495980 [details] [diff] [review]
Another fix

It looks like benjamin landed this patch a while ago, and then it got backed out as part of landing bug 572326 even though the reviewed patch in bug 572326 was simpler.

So I guess this is fine with me, although I suppose benjamin or ted would probably be a better reviewer.
Attachment #495980 - Flags: review?(dbaron) → review+
Attachment #495980 - Flags: review?(benjamin)
Attachment #495980 - Flags: review?(benjamin) → review+
Comment on attachment 495980 [details] [diff] [review]
Another fix

Can we push to 2.0?
Attachment #495980 - Flags: approval2.0?
any + -?
Attachment #495980 - Flags: approval2.0? → approval2.0+
http://hg.mozilla.org/mozilla-central/rev/8075249cd050
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Blocks: 619056
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.