Closed Bug 568409 Opened 10 years ago Closed 8 years ago

The Preferences dialog should not be modal

Categories

(Firefox :: Preferences, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 718011

People

(Reporter: robarnold, Unassigned)

Details

I'm sick of opening a new window so I can switch tabs to help me configure settings. Maybe it should live as an app tab, maybe as a non-modal singleton dialog, I don't care so long as it's not modal.
For starters browser.preferences.instantApply could default to true for Windows.  At least then the options dialog is not modal.
I don't think we want the other side effect of instantApply because that break platform conventions.
Ok so your thinking have the dialog be modeless but don't apply the changes until the ok button is pressed.  

And if it is implemented as a tab then I suppose there would be an apply button.  And the settings changes wouldn't take effect until you hit that button.
Is this bug part of the Preferences UI project here: 
https://wiki.mozilla.org/Firefox/Projects/Preferences_UI
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 718011
You need to log in before you can comment on or make changes to this bug.