Closed Bug 569318 Opened 10 years ago Closed 10 years ago

Favicon is visible during toolbar customisation

Categories

(SeaMonkey :: UI Design, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: neil, Assigned: neil)

References

Details

Attachments

(1 file)

Steps to reproduce problem:
1. Visit a site with a favicon
2. (Optional) Modify the URL in the URLbar, thus hiding the favicon
3. Start toolbar customisation

Actual result: Favicon reappears during and after customisation, even if it was temporarily hidden by URLbar modification.

Expected result: Since a blank URLbar is displayed, I suggest that we use the icon normally displayed when the URLbar is blank, which is the "invalid" icon.
Attached patch Proposed patchSplinter Review
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #448477 - Flags: review?(iann_bugzilla)
Note that bug 479107 will allow the favicon to reappear in some cases (those in which it would reappear when you press ESC to cancel URL modification).
Comment on attachment 448477 [details] [diff] [review]
Proposed patch

It would be nice if the favicon reappeared after customization. Is that possible?
Sorry, you needed to read comment 2 but I failed both to include that as part of the review request and then again to CC you when I did comment...
Comment on attachment 448477 [details] [diff] [review]
Proposed patch

r=me
is there a bug open for the other cases to get the favicon back after customization?
Attachment #448477 - Flags: review?(iann_bugzilla) → review+
Pushed changeset 9c87825cdd57 to comm-central.
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.