Deleting all public versions of an add-on causes unavailable add-on page

RESOLVED FIXED in 5.12.4

Status

addons.mozilla.org Graveyard
Developer Pages
P4
normal
RESOLVED FIXED
8 years ago
2 years ago

People

(Reporter: jorgev, Assigned: andym)

Tracking

unspecified
5.12.4

Details

(Whiteboard: [ReviewTeam])

(Reporter)

Description

8 years ago
I've seen this happen a few times.

The developer has their latest version approved for the public for the first time, and then deletes this version for whatever reason. This puts the add-on in an incorrect state: all versions In Sandbox (or no versions at all) and the add-on status is Public. The end result is that the add-on page becomes inaccessible.

When deleting an add-on version, there should be a check to make sure that the add-on status is still correct. It should change it to In Sandbox if there are no Public versions, and to Incomplete if there are no more versions. There should also be a big warning message to developers for both cases.
Target Milestone: 4.x (triaged) → 5.12.4
Duplicate of this bug: 478697
(Assignee)

Updated

7 years ago
Assignee: nobody → amckay
This is a PHP bug.  Verifying it doesn't do the same thing on the new versions page is good enough to mark fixed.
(Assignee)

Comment 3

7 years ago
The status doesn't change when versions get deleted, so I'll add this in.

Chatted to jorgev and In Sandbox is STATUS_UNREVIEWED and Incomplete is STATUS_NULL.
(Assignee)

Comment 4

7 years ago
https://github.com/jbalogh/zamboni/commit/5e62062ce9f98de1cc4a8f31e5a17884652d6bc7
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

6 years ago
Reclassifying editor bugs and changing to a new whiteboard flag. Spam, spam, spam, spam...
Whiteboard: [required amo-editors] → [ReviewTeam]
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.