Thunderbird does not honour preferred font settings for HTML emails

RESOLVED DUPLICATE of bug 250539

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 250539
7 years ago
7 years ago

People

(Reporter: Thomas Svenson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.9) Gecko/20100317 Lightning/1.0b1 Thunderbird/3.0.4

In Options/Composition I have set TB to use Helvetica, Arial medium as the default font for new emails and replies.

This only seems to work properly when creating a completely blank new email for body text. If I for example want a bulleted list, then the text for the first bullet will revert to a Times type font.

If I create a signature and don't hard code the fontface into the signature, it will also show up as Times type font in the compose window.

It gets even worse when I reply to emails. Only when I start typing and never manually moves the cursor with for example the arrow keys or mouse it will work.

But if I have moved the cursor and then manually places it after the last character in my reply, the new text will come out in Times as well.

All this forces me to do a lot of workaround, hard coding the signature is a minor issue, but to have to multiple times during writing new or replying having to select all my new text to change to font is quite irritating.

Basically during writing there is no point of spending time on formatting as I know that in almost all cases I have to select all my text and change it to Helvetica, Arial. Only after that I can add other formating.

This is actually a problem I had in 2.x as well.

I have also looked at the actual HTML TB is producing and it is quite messy. I'm sure it must be possible to clean that up so this will work as it should.

Reproducible: Always

Steps to Reproduce:
1. Set HTML font to Helvetica, Ariel
2. Create a new email and start writing
3. Click the bulleted list and type in times

2. Add a signature with no font formatting.
3. Create a new email and the text is in Times.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 250539
You need to log in before you can comment on or make changes to this bug.