Image (MAP) renders incorrectly at msnbc.com (<MAP> should be display:inline; in quirks mode)

VERIFIED FIXED

Status

()

Core
Layout
P2
critical
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: Chris Petersen, Assigned: buster)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rtm++] r=rickg, sr=waterson [InLimbo-OOH], URL)

Attachments

(4 attachments)

(Reporter)

Description

18 years ago
Build: 2000101608
Platform:All
Expected Result: Image to be inline in TD element.
What I got: Image renders on top of second image in the TD element.

Steps to reproduce:

1) Go to www.msnbc.com
2) In top portion of the table, one image is rendered on top of another.
3) See attachment.
4) This problem is related to a Map element being rendered as block. It is most 
noticeable when the MAP element is contained in a TD with other inline elements.
(Reporter)

Updated

18 years ago
QA Contact: lorca → petersen
(Reporter)

Comment 1

18 years ago
This bug is related to 57028
http://bugzilla.mozilla.org/show_bug.cgi?id=57028
Severity: normal → major
(Reporter)

Comment 2

18 years ago
Created attachment 17363 [details]
A sample of a Map inside a TD with inline element
(Reporter)

Updated

18 years ago
Component: HTML Element → Evangelism

Comment 3

18 years ago
Reassigning to Buster (from Clayton).
Assignee: clayton → buster
(Reporter)

Comment 4

18 years ago
This is a popular web site and problem is highly noticeable. Nominating RTM.
Keywords: rtm

Comment 5

18 years ago
Is this a top100?  If so, pls add the keyword.

Comment 6

18 years ago
Marking top 100.
Keywords: top100
(Reporter)

Updated

18 years ago
Summary: Image (MAP) to render incorrectly at msnbc.com → Image (MAP) renders incorrectly at msnbc.com
(Reporter)

Comment 7

18 years ago
Created attachment 17792 [details]
Map issue on mactopia.com site
(Reporter)

Comment 8

18 years ago
Simular problem on Microsoft's Mac site (www.mactopia.com).  A Map and image are
contained in the same TD element. Map and image should be inline. But map is
rendered as block and image is rendered below.
(Assignee)

Comment 9

18 years ago
It turns out that if we make <map> display: inline; in quirks.css, then we are
compatible with Nav4/IE5 and we fix a whole lot of pages that now have extra
line breaks.
Status: NEW → ASSIGNED
Component: Evangelism → Layout
Depends on: 11431
Keywords: top100 → 4xp
Summary: Image (MAP) renders incorrectly at msnbc.com → Image (MAP) renders incorrectly at msnbc.com (<MAP> would be display:inline; in quirks mode)
(Assignee)

Comment 10

18 years ago
cc-ing some folks from bug 11431
Severity: major → critical
Priority: P3 → P2
(Reporter)

Updated

18 years ago
(Assignee)

Comment 11

18 years ago
Created attachment 17922 [details] [diff] [review]
proposed quirks-mode fix
(Assignee)

Comment 12

18 years ago
PDT: this fix is extremely safe with respect to stability.  It also gets us
much, much closer to backwards compatible layout on several top100 pages.
Finally, it has no effect on standards or forward compatibility, because it only
effects quirks mode layout.  I think this is a very straightforward fix to take.
(Assignee)

Comment 13

18 years ago
Created attachment 17924 [details] [diff] [review]
oops, this is the REAL patch

Comment 14

18 years ago
r=waterson (or sr, whichever you need)

Comment 15

18 years ago
r=rickg. I've also tested this against the top 100 and it looks fine.
(Assignee)

Comment 16

18 years ago
whiteboard -> rtm+ and reviewer annotations
also, through private email ian agrees that this is a legit quirks-mode solution
Whiteboard: [rtm+] r=rickg, sr=waterson

Comment 17

18 years ago
We'll hold this bug at RTM plus until we have a fallback candidate RTM bulid in 
our pocket, and then we'll reconsider (and probably take).
Whiteboard: [rtm+] r=rickg, sr=waterson → [rtm+] r=rickg, sr=waterson [limbo]

Comment 18

18 years ago
This bug is in candidate limbo.  We will reconsider this fix once we have a 
candidate in hand, but we can't take this fix before then.

Updated

18 years ago
Whiteboard: [rtm+] r=rickg, sr=waterson [limbo] → [rtm+] r=rickg, sr=waterson [InLimbo-OOH]

Comment 19

18 years ago
We are moving toward the candidate.  Please check this fix into the trunk so we 
can get get some cook time.
(Assignee)

Comment 20

18 years ago
checked into trunk
Summary: Image (MAP) renders incorrectly at msnbc.com (<MAP> would be display:inline; in quirks mode) → Image (MAP) renders incorrectly at msnbc.com (<MAP> should be display:inline; in quirks mode)

Comment 21

18 years ago
PDT marking [rtm++]. This bug is now out of limbo and approved for checkin to
the branch. Please check in ASAP.
Whiteboard: [rtm+] r=rickg, sr=waterson [InLimbo-OOH] → [rtm++] r=rickg, sr=waterson [InLimbo-OOH]
(Assignee)

Comment 22

18 years ago
fix checked into branch
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 23

18 years ago
Fixed in the Oct 31 branch build.
Keywords: vtrunk

Comment 24

18 years ago
Looks good using 10-31-14 MN6 candidate build on Win98

Comment 25

18 years ago
also looks good on Macintosh ns6 build from 2000103114
(Assignee)

Comment 26

18 years ago
*** Bug 57028 has been marked as a duplicate of this bug. ***

Comment 27

18 years ago
Verified Fixed on Mozilla trunk builds
linux 122710 RedHat 6.2
win32 122705 NT 4
mac 122708 Mac OS9
Setting bug to Verified and removing vtrunk keyword
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.