MAP with display:block; ruins layout of some pages

RESOLVED DUPLICATE of bug 57054

Status

()

Core
Layout
P3
major
RESOLVED DUPLICATE of bug 57054
18 years ago
17 years ago

People

(Reporter: buster, Assigned: buster)

Tracking

(Blocks: 1 bug)

Trunk
Future
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Assignee)

Description

18 years ago
See bug 11431 for the discussion about setting MAP {display:block;} for NS6 RTM.
See bug 56492 for a reduced test case based on the kia page.

The problem is <MAP> usually contains only <AREA>, and therefore usually doesn't
effect layout at all.  But by mapping it to display: block, we introduce two bad
side effects:
1) extra vertical white space
2) inappropriate line breaks

We need some logic in the source that scans the map's children and changes the
display type dynamically between block and none.  As a first step, the parser
can tell layout whether all the children of a <MAP> are <AREA> or not.  But we
need to handle the case where content is added/removed via the DOM as well.
(Assignee)

Comment 1

18 years ago
marking future.  this won't happen for rtm.
Status: NEW → ASSIGNED
Keywords: 4xp
Target Milestone: --- → Future
*** Bug 57025 has been marked as a duplicate of this bug. ***
Bug 8131 will need to be investigated at a similar time, and required similar
functionality. Adding to the 'blocks' list for conveniance, although there is
no immediate reason that this bug blocks or depends on the other.
Blocks: 7954, 8131
OS: Windows NT → All
Hardware: PC → All

Comment 4

18 years ago
This bug is fixed in the Oct 31 branch build. It is related to bug
http://bugzilla.mozilla.org/show_bug.cgi?id=57054
Keywords: vtrunk
(Assignee)

Comment 5

17 years ago

*** This bug has been marked as a duplicate of 57054 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.