[OOPP] WebM landing causing Silverlight to crash [@ mozilla::plugins::PPluginInstanceChild::CallPStreamNotifyConstructor]

RESOLVED DUPLICATE of bug 560037

Status

()

Core
Plug-ins
--
major
RESOLVED DUPLICATE of bug 560037
8 years ago
6 years ago

People

(Reporter: Jim Jeffery not reading bug-mail 1/2/11, Unassigned)

Tracking

({regression})

Trunk
x86
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

After the landing of the bits for WebM Silverlight plugin is crashing on the URL above. 

http://crash-stats.mozilla.com/report/index/bp-a2930926-b25f-4bca-b4d9-9cf642100609

Looks like maybe same stack as in bug 560037

Blocking needed for 3.6.4 ?
Does not crash with OOPP 'off'
Summary: WebM landing causing Silverlight to crash → [OOPP] WebM landing causing Silverlight to crash

Comment 2

8 years ago
Does not crash WHAT SO EVER

Proof : http://i50.tinypic.com/29a107.png
Seems to be 'racy'.  Reloading the page with Ctrl+F5 will sometimes load the video, other times it crashes.

Comment 4

8 years ago
Signature	mozilla::plugins::PPluginInstanceChild::CallPStreamNotifyConstructor(mozilla::plugins::PStreamNotifyChild*, nsCString const&, nsCString const&, bool const&, nsCString const&, bool const&, short*)
UUID	a2930926-b25f-4bca-b4d9-9cf642100609
Process Type	plugin Version: Filename: npctrl.dll
Time 	2010-06-09 04:59:44.918425
Uptime	98
Product	Firefox
Version	3.7a5pre
Build ID	20100609035919
Branch	1.9.3
OS	Windows NT
OS Version	6.1.7600
CPU	x86
CPU Info	AuthenticAMD family 16 model 2 stepping 3
Crash Reason	EXCEPTION_ACCESS_VIOLATION
Crash Address	0x2c
Email Address	
URL	
User Comments	
Related Bugs

OPEN

        * Bug 560037 NEW Firefox 3.6.4 Crash Report [@ mozilla::plugins::PPluginInstanceChild::CallPStreamNotifyConstructor(mozilla::plugins::PStreamNotifyChild*, nsCString const&, nsCString const&, bool const&, nsCString const&, bool const&, short*) ]

Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	mozilla::plugins::PPluginInstanceChild::CallPStreamNotifyConstructor 	obj-firefox/ipc/ipdl/PPluginInstanceChild.cpp:664
1 	xul.dll 	mozilla::plugins::child::_geturlnotify 	dom/plugins/PluginModuleChild.cpp:871
2 	npctrl.dll 	npctrl.dll@0xca8cd 	
3 	npctrl.dll 	npctrl.dll@0x89b8e 	
4 	npctrl.dll 	npctrl.dll@0x6be82 	
5 	npctrl.dll 	npctrl.dll@0x444dc 	
6 	npctrl.dll 	npctrl.dll@0x1386d 	
7 	npctrl.dll 	npctrl.dll@0x13b53 	
8 	npctrl.dll 	npctrl.dll@0x13cfd 	
9 	npctrl.dll 	npctrl.dll@0x13d94 	
10 	npctrl.dll 	npctrl.dll@0x13de8 	
11 	npctrl.dll 	npctrl.dll@0x13efb 	
12 	npctrl.dll 	npctrl.dll@0x46c1 	
13 	user32.dll 	InternalCallWinProc 	
14 	user32.dll 	UserCallWinProcCheckWow 	
15 	user32.dll 	DispatchMessageWorker 	
16 	user32.dll 	DispatchMessageW 	
17 	xul.dll 	base::MessagePumpForUI::ProcessMessageHelper 	ipc/chromium/src/base/message_pump_win.cc:365
18 	xul.dll 	base::MessagePumpForUI::ProcessNextWindowsMessage 	ipc/chromium/src/base/message_pump_win.cc:340
19 	xul.dll 	base::MessagePumpForUI::DoRunLoop 	ipc/chromium/src/base/message_pump_win.cc:209
20 	xul.dll 	base::MessagePumpWin::RunWithDispatcher 	ipc/chromium/src/base/message_pump_win.cc:52
21 	xul.dll 	base::MessagePumpWin::Run 	ipc/chromium/src/base/message_pump_win.h:78
22 	xul.dll 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:216
23 	xul.dll 	MessageLoop::RunHandler 	
24 	xul.dll 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:173
25 	xul.dll 	XRE_InitChildProcess 	toolkit/xre/nsEmbedFunctions.cpp:414
26 	plugin-container.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp:120
27 	plugin-container.exe 	__tmainCRTStartup 	obj-firefox/memory/jemalloc/crtsrc/crtexe.c:591
28 	kernel32.dll 	kernel32.dll@0x13676 	
29 	ntdll.dll 	ntdll.dll@0x39d71 	
30 	ntdll.dll 	ntdll.dll@0x39d44 	

Filename 	Version 	Debug Identifier 	Debug Filename
coreclr.dll 	4.0.50524.0 	87ABA647C05D44A1B2828F6D57E347CB2 	coreclr.pdb
agcore.dll 	4.0.50524.0 	CF2901BE704D439D8E80278649BE73962 	agcore.pdb
npctrl.dll 	4.0.50524.0 	40AE1273AD864F2E859DC875D3EB259C2 	npctrl.pdb
npctrlui.dll 	4.0.50524.0 		
mscorrc.dll 	4.0.50524.0 	37819AE88C4C4353A8C25034BF4054EA1 	mscorrc.pdb
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Summary: [OOPP] WebM landing causing Silverlight to crash → [OOPP] WebM landing causing Silverlight to crash [@ mozilla::plugins::PPluginInstanceChild::CallPStreamNotifyConstructor]
Duplicate of bug: 560037
You need to log in before you can comment on or make changes to this bug.