Closed Bug 570956 Opened 14 years ago Closed 14 years ago

Messages that are only consisting of unformatted text cannot be sent automatically as HTML

Categories

(Thunderbird :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 136502

People

(Reporter: dfghjkjhg, Unassigned)

Details

User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; de; rv:1.9.2.4)  Gecko/20100526 Lightning/1.0b2pre Thunderbird/3.1

Steps to reproduce:
Tools -> Account Settings -> Composition & Addressing -> Compose messages in HTML format.
Tools -> Options-> Composition -> General -> Send Options -> Text Format -> Send the message in both plain text and HTML.
Create a message in HTML and do not format its text (no colour etc.) !!!
Leave “options – format – autom. decide“ in the compose window.
Sent the message.
-->  PROBLEM:
When you open the sent message, you can see that it’s only sent in plaintext (i. e. the message is sent with unproportional plaintext font Courier New instead of proportional html font Arial in my case).
Also if you display the message’s source text, you can see that there are no html tags included.
Thus the setting “Send the message in both plain text and HTML” is ignored; the message is only sent as plaintext (whereas I want to send it also as html with my proportional html font Arial).


For testing purposes I also tried the following:
I added *.* as the domain name in Tools -> Options -> Composition -> General -> Send Options -> HTML Domains
--> But same problem as before: Unformatted messages are only sent in plaintext (unproportional plaintext font Courier New instead of proportional html font Arial).


Further findings:
The only  way I found to send unformatted messages in html is to set
      Options -> Format -> “plaintext and html”     or     “only html”
manually in the compose window.
Only then the sent message consists of html (proportional html font Arial instead of unproportional plaintext font Courier New).


Background:
The reason for this bug report is, that I want to send the message in proportional font Arial;
i. e. Arial should be the font, the mail recipient gets displayed.
Therfore I need to send the mail in HTML. But I cannot tell TB to do so always and automatically, when sending unformatted mails. I can just tell TB manually (mail by mail) via “options -> format”.
(Or I need to colour at least 1 letter in the mail. Then TB sends the mail in HTML.)


Reproducible: Always
There are a couple of bugs pending on this issue, I'm duping this to the one for disabling the auto-detect mechanism and always respecting user's choice.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.