Last Comment Bug 570990 - Firebug unit test crashes FFx 3.7a5pre x86_64
: Firebug unit test crashes FFx 3.7a5pre x86_64
Status: RESOLVED WORKSFORME
: stackwanted
Product: Firefox
Classification: Client Software
Component: Extension Compatibility (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-09 09:51 PDT by Andrew Halberstadt [:ahal]
Modified: 2010-07-30 12:48 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Andrew Halberstadt [:ahal] 2010-06-09 09:51:34 PDT
1. Install the latest Firebug release: http://getfirebug.com/releases/firebug/1.6X/ (1.6X.0a11)
2. Install the latest FBTest: http://getfirebug.com/releases/fbtest/1.6/ (1.6b14)
3. Tools->Firebug->Open Test Console
4. Under DOM run the 'dom/2558/issue2558.js' test

I couldn't reproduce this on the 32-bit binary.
Comment 1 Jan Honza Odvarko [:Honza] PTO 07/23 - 08/08 2010-06-09 10:46:32 PDT
As expected, it works for me with Firefox 3.7a5pre, 32 bit
Unfortunately, I don't have any 64bit machine to reproduce this.

Anyway, this test is related to a "next" property hidden in a wrappedJSObject,
see bug #536137.

Honza
Comment 2 cmtalbert 2010-06-09 12:56:58 PDT
jst, you might want to mention this for your release notes in the developer preview.  We found that linux 64 bit builds will crash during the firebug unit test suite.
Comment 3 Andrew Halberstadt [:ahal] 2010-07-30 12:48:22 PDT
Haven't been able to reproduce this in any of the 4.0 betas.  WFM

Note You need to log in before you can comment on or make changes to this bug.