Setup 12 new rev3 test slaves in buildbot, graphserver, etc

RESOLVED FIXED

Status

defect
P3
normal
RESOLVED FIXED
9 years ago
6 years ago

People

(Reporter: joduinn, Assigned: lsblakk)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [hardware])

To offset the load of testing firefox with addons, osunick is getting us 12 rev3 minis to put in the production test pool. (thats 2 rev3 minis per 6 desktop OS).

I've already filed dep.bugs for the purchase and imaging of these machines. This bug is to track setting up buildbot master configs, graphserver entries, etc.

Note: we plan to proceed with test runs of these firefox-with-addon perf suites to measure workload, and shake out any bugs, even before these machines arrive and are setup. From a quick SWAG of the numbers, this looks like it should be ok. However, if we see unexpectedly large infrastructure load, we reserve the right to stop and restrict ourselves to fewer addons or less frequent runs.
Priority: -- → P3
Whiteboard: [hardware]
Duplicate of this bug: 578539
bug 572575 already adds these machines to puppet, opsi, and the talos-r3 config, leaving the graphserver config and any updates the windows 7 boxes need. Lukas, can we assign this one to you ?
Assignee: nobody → lsblakk
Depends on: 579623
These have been added to the pool via bug 572575
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.