Closed Bug 572575 Opened 9 years ago Closed 9 years ago

Setup 10 new rev3 test slaves in buildbot, graphserver, etc

Categories

(Release Engineering :: General, defect, P3)

x86
macOS
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: joduinn, Assigned: lsblakk)

References

Details

(Whiteboard: [talos][hardware])

Attachments

(5 files)

Dep.bug is for the imaging of these machines. This bug is to track setting up buildbot master configs, graphserver entries, etc.
Priority: -- → P3
Whiteboard: [talos]
includes the 12 from bug 571121
Assignee: nobody → lsblakk
Status: NEW → ASSIGNED
Attachment #455554 - Flags: review?(anodelman)
Comment on attachment 455554 [details] [diff] [review]
adds new talos-r3 slaves to configs

Seems reasonable.
Attachment #455554 - Flags: review?(anodelman) → review+
also adds the ones from bug 571121
Attachment #455556 - Flags: review?(anodelman)
Attachment #455556 - Flags: review?(anodelman) → review?(bhearsum)
Attachment #455558 - Flags: review?(bhearsum)
Comment on attachment 455558 [details] [diff] [review]
add talos xp slaves to opsi

Neither 051 nor 052 exist.
Attachment #455558 - Flags: review?(bhearsum) → review-
Attachment #455556 - Flags: review?(bhearsum) → review+
Comment on attachment 455558 [details] [diff] [review]
add talos xp slaves to opsi

nm, i see your comment now.
Attachment #455558 - Flags: review- → review+
Whiteboard: [talos] → [talos][hardware]
Depends on: 579623
Comment on attachment 455554 [details] [diff] [review]
adds new talos-r3 slaves to configs

This short of patch should land as the very last step of enabling new minis, otherwise you end up with problems like bug 579623. I haven't backed it out (but probably should have), instead munging the buildbot.tac's.

Note that newly imaged minis get a buildbot.tac generated but don't connect to the master until puppet works (I'm not sure if opsi is blocking). By landing all three patches, but not doing the graphserver work, we allow the slaves to connect to a master and cause spurious orange.
(In reply to comment #10)
> Note that newly imaged minis get a buildbot.tac generated but don't connect to
> the master until puppet works (I'm not sure if opsi is blocking). By landing
> all three patches, but not doing the graphserver work, we allow the slaves to
> connect to a master and cause spurious orange.

OPSI won't block in the same way AFAIK.
this includes the slaves in bug 571121 as well.
Attachment #458332 - Flags: review?(anodelman)
includes slaves from bug 571121 as well
SQL pushed to prod graph server :

mysql> insert into machines values (NULL,12,0,"2.26","talos-r3-w7-051",1,unix_timestamp());
Query OK, 1 row affected (0.01 sec)

mysql> insert into machines values (NULL,12,0,"2.26","talos-r3-w7-052",1,unix_timestamp());
Query OK, 1 row affected (0.00 sec)

mysql> insert into machines values (NULL,12,0,"2.26","talos-r3-w7-053",1,unix_timestamp());
Query OK, 1 row affected (0.00 sec)

mysql> insert into machines values (NULL,1,0,"2.26","talos-r3-xp-051",1,unix_timestamp());
Query OK, 1 row affected (0.00 sec)

mysql> insert into machines values (NULL,1,0,"2.26","talos-r3-xp-052",1,unix_timestamp());
Query OK, 1 row affected (0.00 sec)

mysql> insert into machines values (NULL,1,0,"2.26","talos-r3-xp-053",1,unix_timestamp());
Query OK, 1 row affected (0.00 sec)

mysql> insert into machines values (NULL,13,0,"2.26","talos-r3-leopard-051",1,unix_timestamp());
Query OK, 1 row affected (0.00 sec)

mysql> insert into machines values (NULL,13,0,"2.26","talos-r3-leopard-052",1,unix_timestamp());
Query OK, 1 row affected (0.00 sec)

mysql> insert into machines values (NULL,13,0,"2.26","talos-r3-leopard-053",1,unix_timestamp());
Query OK, 1 row affected (0.00 sec)

mysql> insert into machines values (NULL,14,0,"2.26","talos-r3-fed-051",1,unix_timestamp());
Query OK, 1 row affected (0.01 sec)

mysql> insert into machines values (NULL,14,0,"2.26","talos-r3-fed-052",1,unix_timestamp());
Query OK, 1 row affected (0.00 sec)

mysql> insert into machines values (NULL,14,0,"2.26","talos-r3-fed-053",1,unix_timestamp());
Query OK, 1 row affected (0.00 sec)

mysql> insert into machines values (NULL,15,0,"2.26","talos-r3-fed64-051",1,unix_timestamp());
Query OK, 1 row affected (0.00 sec)

mysql> insert into machines values (NULL,15,0,"2.26","talos-r3-fed64-052",1,unix_timestamp());
Query OK, 1 row affected (0.00 sec)

mysql> insert into machines values (NULL,15,0,"2.26","talos-r3-fed64-053",1,unix_timestamp());
Query OK, 1 row affected (0.00 sec)

mysql> insert into machines values (NULL,15,0,"2.26","talos-r3-fed64-054",1,unix_timestamp());
Query OK, 1 row affected (0.00 sec)

mysql> insert into machines values (NULL,15,0,"2.26","talos-r3-fed64-055",1,unix_timestamp());
Query OK, 1 row affected (0.00 sec)

mysql> insert into machines values (NULL,17,0,"2.26","talos-r3-snow-051",1,unix_timestamp());
Query OK, 1 row affected (0.00 sec)

mysql> insert into machines values (NULL,17,0,"2.26","talos-r3-snow-052",1,unix_timestamp());
Query OK, 1 row affected (0.00 sec)

mysql> insert into machines values (NULL,17,0,"2.26","talos-r3-snow-053",1,unix_timestamp());
Query OK, 1 row affected (0.00 sec)

mysql> insert into machines values (NULL,17,0,"2.26","talos-r3-snow-054",1,unix_timestamp());
Query OK, 1 row affected (0.00 sec)

mysql> insert into machines values (NULL,17,0,"2.26","talos-r3-snow-055",1,unix_timestamp());
Query OK, 1 row affected (0.01 sec)
online in production now.
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Attachment #458332 - Flags: review?(anodelman) → review+
Attachment #458332 - Flags: checked-in+
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.