[Mac][OOPP] No context menu available using Flash Version: 10.1.53.64

VERIFIED FIXED

Status

()

Core
Plug-ins
VERIFIED FIXED
8 years ago
7 years ago

People

(Reporter: marcia, Assigned: BenWa)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

(URL)

(Reporter)

Description

8 years ago
Seen while running Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.3a5pre) Gecko/20100609 Minefield/3.7a5pre.

STR:
1. Load a youtube.com video (see URL field)
2. Right click

Nothing happens.

Using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 I am able to get a context menu running the same version of the Flash plugin

Comment 1

8 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.3a5pre) Gecko/20100608 Minefield/3.7a5pre
Able to reproduce. context menu is not working in normal mode. Context menu is working only in full screen mode.

Comment 2

8 years ago
Build worked : 
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.3a1pre) Gecko/20090826 Minefield/3.7a1pre

http://hg.mozilla.org/mozilla-central/rev/485a319ce5e6

Build Broken : 
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.3a1pre) Gecko/20090827 Minefield/3.7a1pre

http://hg.mozilla.org/mozilla-central/rev/72d25f49cbcb

Pushlog : 
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=485a319ce5e6&tochange=72d25f49cbcb

Comment 3

8 years ago
ebb78acb0087	Josh Aas — Implement Cocoa NPAPI event model. b=435041 sr=roc
blocking2.0: --- → beta2+
(Assignee)

Comment 4

8 years ago
If you are running Flash out-of-process then this is caused by bug 568513. Can you confirm if Flash is running in/out-of process?
(Reporter)

Comment 5

8 years ago
BenWa: Not sure how to check what you asked about in Comment 4. Let me know and I will try.
Summary: No context menu available using Flash Version: 10.1.53.64 → [Mac] No context menu available using Flash Version: 10.1.53.64
(Assignee)

Comment 6

8 years ago
The most reliable way is to start Terminal and run 'ps -ef | grep plugin-container' and check for a result containing 'Flash Player.plugin'. This is only loaded when needed so you'll need to have flash playing first.
(Reporter)

Comment 7

8 years ago
As a further point of information, I do get the menu in full screen mode, but not in regular mode. This is using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.3a5pre) Gecko/20100610 Minefield/3.7a5pre. Will try Comment 6 when I finish alpha5 work.
(Reporter)

Comment 8

8 years ago
Here is what I get when I run that command:

host-4-219:~ marcia$ ps -ef | grep plugin-container
  501  3715  3712   0   0:09.95 ??         1:40.07 /Users/marcia/Desktop/newtrunk/Minefield.app/Contents/MacOS/plugin-container /Library/Internet Plug-Ins/Flash Player.plugin 3712 plugin

(In reply to comment #6)
> The most reliable way is to start Terminal and run 'ps -ef | grep
> plugin-container' and check for a result containing 'Flash Player.plugin'. This
> is only loaded when needed so you'll need to have flash playing first.
(Assignee)

Comment 9

8 years ago
You're running flash out-of-process thus you are seeing bug 568513.
Maybe you want to dupe this bug, but at least setting the depends here to help track the dependency.
Depends on: 568513
Summary: [Mac] No context menu available using Flash Version: 10.1.53.64 → [Mac][OOPP] No context menu available using Flash Version: 10.1.53.64
(Reporter)

Comment 11

8 years ago
Is it possible the issue I am seeing is related to Bug 552520?
(Assignee)

Comment 12

8 years ago
According to bug 552520 the right-click menu is appearing. In your case you are running out-of-process where the right-click menu is not implemented (waiting on review from bug 568513) or are you seeing different behavior?

Full-screen excluded since it does not use the browser to generate the right-click menu.
(Reporter)

Comment 13

8 years ago
Ok, after re-reading bug 552520 I see Charles is getting the context menu. So we are okay here - I am seeing 568513. Might want to relnote that one for beta1 as well. 

(In reply to comment #12)
> According to bug 552520 the right-click menu is appearing. In your case you are
> running out-of-process where the right-click menu is not implemented (waiting
> on review from bug 568513) or are you seeing different behavior?
> 
> Full-screen excluded since it does not use the browser to generate the
> right-click menu.

Updated

7 years ago
blocking2.0: beta2+ → betaN+

Updated

7 years ago
Assignee: nobody → b56girard
(Reporter)

Comment 14

7 years ago
Using 10.6 I now see the context menu, however using Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:2.0b3pre) Gecko/20100730 Minefield/4.0b3pre I do not get one, and the one time I generated one it looked like this: http://tinypic.com/r/xdggfk/3

Using my 10.5 PPC machine, I do see the menu, so this is strange.
(Assignee)

Comment 15

7 years ago
On 10.5 you should not be running OOPP. Can you fill this as a separate issue as the in-process implementation is likely faulty. 

I'm going to resolve this bug. Please verify that this bug works for OOPP (Flash on 10.6), minus the behavior described in bug 583296. Feel free to re-open if we can reproduce this issue on 10.6.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 16

7 years ago
Verified fixed using Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b3pre) Gecko/20100730 Minefield/4.0b3pre.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.