Last Comment Bug 571539 - SVN Account Request - Mihail Chilyashev <chilyashev@gmail.com>
: SVN Account Request - Mihail Chilyashev <chilyashev@gmail.com>
Status: RESOLVED FIXED
:
Product: mozilla.org
Classification: Other
Component: Repository Account Requests (show other bugs)
: other
: All All
: -- normal (vote)
: ---
Assigned To: Justin Lazaro [:jlaz]
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-11 10:58 PDT by Mihail Chilyashev
Modified: 2011-03-23 08:44 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
my public key (601 bytes, text/plain)
2010-06-20 11:37 PDT, Mihail Chilyashev
no flags Details

Description Mihail Chilyashev 2010-06-11 10:58:45 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US) AppleWebKit/533.4 (KHTML, like Gecko) Chrome/5.0.375.70 Safari/533.4
Build Identifier: 

Hi, I'd like to get SVN commit access. I'm the the bg localizer for AMO.
I need write access to the following locations:
  svn.mozilla.org/addons/trunk/site/app/locale/bg/
Thanks.

Reproducible: Always
Comment 1 Wil Clouser [:clouserw] 2010-06-11 11:04:31 PDT
a=clouserw
Comment 2 :Gavin Sharp [email: gavin@gavinsharp.com] 2010-06-11 13:02:31 PDT
Need to attach your public key and send in the committer form per http://www.mozilla.org/hacking/notification/ (unless you already have an account, in which case a reference to the bug for its setup would be sufficient).
Comment 3 Mihail Chilyashev 2010-06-11 14:40:58 PDT
I sent an e-mail to Erica McClure, but had trouble signing it. How bad is that?
Comment 4 :Gavin Sharp [email: gavin@gavinsharp.com] 2010-06-12 02:21:52 PDT
The email needs to be either a scan of a manually signed form, or be S/MIME-signed itself.
Comment 5 Mihail Chilyashev 2010-06-15 04:32:28 PDT
I sent an e-mail with a scan of the signed form. I hope this time I didn't do something wrong.
Comment 6 Mihail Chilyashev 2010-06-20 11:37:29 PDT
Created attachment 452591 [details]
my public key

Sorry for the delay.
I got carried away and totally forgot about it.
Comment 7 Erica McClure 2010-06-24 17:01:53 PDT
I have received Mihail's Committer's Agreement.
Comment 8 Marcia Knous [:marcia - use ni] 2010-06-28 17:21:08 PDT
I assume this is for Level 2 access. Over to server ops for access to svn.mozilla.org/addons/trunk/site/app/locale/bg/.
Comment 9 Justin Lazaro [:jlaz] 2010-06-29 08:33:14 PDT
LDAP chilyashev@gmail.com created, details sent via email.
rw given to chilyashev@gmail.com to /addons/trunk/site/app/locale/bg/
Comment 10 Mihail Chilyashev 2010-06-30 10:35:08 PDT
Thanks, but I get an error when I try to commit. 
Here's what I did:
First I changed my LDAP password.
After that I checked out the code with "svn co https://svn.mozilla.org/addons/trunk/site/app/locale/bg/"
Then I made the changes necessary to z-javascript.po (for example). 
When I tried to commit it with "svn commit -m "z-javascript.po ready for bg" z-javascript.po", it prompted for a password for the current user for my system, after not entering anything, it prompted for a username. I entered my LDAP username and password, after which it asked for username again. I gave it my LDAP username and password again, and got the error.
Here's how it looks like in the shell:

$ svn co https://svn.mozilla.org/addons/trunk/site/app/locale/bg/
------
after editing z-javascript.po
------
$ svn commit -m "z-javasctipt.po ready for bg" z-javascript.po
Authentication realm: <https://svn.mozilla.org:443> Mozilla LDAP
Password for 'chilyashev': [Enter]
Authentication realm: <https://svn.mozilla.org:443> Mozilla LDAP
Username: chilyashev@gmail.com [Enter]
Password for 'chilyashev@gmail.com': ************* [Enter]
Authentication realm: <https://svn.mozilla.org:443> Mozilla LDAP
Username: chilyashev@gmail.com [Enter]
Password for 'chilyashev@gmail.com': ************* [Enter]
svn: Commit failed (details follow):
svn: MKACTIVITY of '/!svn/act/d5ca4768-71ba-4cb5-ad60-566d805e5e53': authorization failed (https://svn.mozilla.org)

(The only thing different are the numbers and letters after "/!svn/act/")

I tried it several times with different usernames (e.g. only chilyashev or replacing the @ with %) and still got the error. 

Am I doing something wrong?
Comment 11 Justin Lazaro [:jlaz] 2010-06-30 14:45:09 PDT
Try once more, I actually missed enabling the svn bit there, my apologies

-jlazaro
Comment 12 Mihail Chilyashev 2010-06-30 19:44:48 PDT
Worked like a charm.
Thanks.
Comment 13 Mihail Chilyashev 2011-03-19 09:11:55 PDT
Hi, 
It seems my LDAP account has been suspended or am I missing something?
I was unable to commit for about 3 weeks because of too much side projects and final exam preparations.
Anyway, a few days ago I tried committing the ready files but got 'authentication failed'. I also tried ldap.mozilla.org/passwordreset, but couldn't get in there either. No one on irc could help.
Can someone here shed some light on this?
Thanks.
Comment 14 Justin Lazaro [:jlaz] 2011-03-21 12:03:07 PDT
I've reset your password, and also re-enabled L2 access (not sure how it was disabled)  Let me know if you continue to have issues
Comment 15 Mihail Chilyashev 2011-03-23 08:44:22 PDT
It worked.
Thanks!

Note You need to log in before you can comment on or make changes to this bug.