Closed Bug 571662 Opened 9 years ago Closed 9 years ago

Toolbar background should be darker

Categories

(Firefox :: Theme, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 4.0b7
Tracking Status
blocking2.0 --- final+

People

(Reporter: Terepin, Assigned: dao)

References

()

Details

Attachments

(5 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; WOW64; en-US; rv:1.9.3a6pre) Gecko/20100611 Minefield/3.7a6pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; WOW64; en-US; rv:1.9.3a6pre) Gecko/20100611 Minefield/3.7a6pre

1. (Tabs At Bottom) Toolbars background should be slightly transparent with use of Aero Glass.
2. (Tabs At Bottom) Toolbars background is missing gradient in upper part.
3. (Tabs At Bottom and Tabs On Top) Toolbars background should have light blue color instead of grey.

Reproducible: Always
Blocks: 568037
Version: unspecified → Trunk
Summary: Adjust toolbars background → Adjust toolbars background to match mockups
4. (Tabs At Bottom) Increase space between Bookmarks bar and Navigation bar (current nav buttons are touching Bookmarks bar).
5. (Tabs On Top) Increase space between Navigation bar and page content/Tab bar (current nav buttons aren't centered. I don't know if this adjusment is neccesary if Bookmarks bar is showed; hard to tell from mockups).
The mockups looks like there are two types of gradient colors.  I prefer the darker one labeled: Large Button mode with Bookmarks Bar, the current brighter one we have is too hard on the eyes and distracting from the UX.
6. (Tabs On Top) Currently, the background is square. It should have curved corners. In fact, background share same style as tabs, so even shadows intruduced in Bug 570278 should be applied to background too and if I'm not mistaken, around page content as well. Also, it should be perfectly alligned with page content.
For this, the color defined in the line

+%define customToolbarColor rgb(227,237,246)

in Bug 568037 should be changed to a darker color like rgb(190,205,220).
According to this: https://wiki.mozilla.org/Firefox/Projects/New_Theme/Timeline#.5BWindows.5D_Beta_1_Theme_Requirements I'm requesting blocking beta1+.
blocking2.0: --- → ?
(In reply to comment #0)
> 3. (Tabs At Bottom and Tabs On Top) Toolbars background should have light blue
> color instead of grey.
Correction:
3. (Tabs At Bottom and Tabs On Top) Toolbars background should have more blueish color.
Sorry for that, Dão.
this might be a dupe to an existing bug, shorlander and dao would know.
I've filled this bug very soon after toolbars have landed. There is no such bug to my knowledge.
Requesting to block beta4+.
Depends on: 576371
Shorlander: do you think this should block release?
(In reply to comment #13)
> Shorlander: do you think this should block release?

Yes.
No longer depends on: 576371
blocking2.0: ? → final+
Morphing, please file individual bugs on any remaining issues.
Summary: Adjust toolbars background to match mockups → Toolbar background should be darker
Attached patch patchSplinter Review
Assignee: nobody → dao
Status: NEW → ASSIGNED
Attachment #469802 - Flags: review?(gavin.sharp)
Can I see screenshot of patch, please?
Comment on attachment 469802 [details] [diff] [review]
patch

rs=me
Attachment #469802 - Flags: review?(gavin.sharp) → review+
http://hg.mozilla.org/mozilla-central/rev/6ce9c793cda3
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b6
Looks fantastic!
I'll fill up bugs for remaining issues.
Dao, are there things that can be grouped into one bug, or I shall create bugs for each one issue?
Separate bugs are generally preferable. If the fix for one issue also fixes another one, bug dependencies can express this.
(In reply to comment #5)
> Created attachment 450919 [details]
> Toolbars background (Tabs On Top)
> 
> 6. (Tabs On Top) Currently, the background is square. It should have curved
> corners. In fact, background share same style as tabs, so even shadows
> intruduced in Bug 570278 should be applied to background too and if I'm not
> mistaken, around page content as well. Also, it should be perfectly alligned
> with page content.

Dao, isn't this being covered in another bug?
(In reply to comment #22)
> (In reply to comment #5)
> > Created attachment 450919 [details] [details]
> > Toolbars background (Tabs On Top)
> > 
> > 6. (Tabs On Top) Currently, the background is square. It should have curved
> > corners. In fact, background share same style as tabs, so even shadows
> > intruduced in Bug 570278 should be applied to background too and if I'm not
> > mistaken, around page content as well. Also, it should be perfectly alligned
> > with page content.
> 
> Dao, isn't this being covered in another bug?

bug 589259
Actually, I had on my mind only the shadow. And found the bug for it: bug 588764.
Well, this bug fixed, I filled bugs for more issues reported in this bug and the last will be fixed in that bug.
You need to log in before you can comment on or make changes to this bug.