Closed Bug 589259 Opened 9 years ago Closed 9 years ago

top outside corners of navigation toolbar need border radius

Categories

(Firefox :: Theme, defect, trivial)

x86
Windows 7
defect
Not set
trivial

Tracking

()

RESOLVED FIXED
Firefox 4.0b7

People

(Reporter: asa, Assigned: dao)

References

Details

Attachments

(2 files, 3 obsolete files)

We need a border radius on the top right corner of the navigation toolbar.
We also need this for the left corner
Summary: top right corner of navigation toolbar needs rounded corner → top outside corners of navigation toolbar need border radius
Blocks: 544820
Already reported in bug 571662.
Depends on: 590873
Assignee: nobody → dao
Attached patch patch (obsolete) — Splinter Review
Attachment #469797 - Flags: review?(gavin.sharp)
Attached image showing a problem with this patch (obsolete) —
This patch doesn't look right when tabs run to the edge of the window (if user hasn't placed buttons the tab toolbar). The tabs' outer edge no longer connects to the toolbar below. On the mockups the tab bar seems to have a little left and right margin to prevent this. 
A second thing is that this effect should be applied in tabs-on-bottom mode, with bookmarks toolbar enabled, too.
(In reply to comment #4)
> This patch doesn't look right when tabs run to the edge of the window (if user
> hasn't placed buttons the tab toolbar).

That's not the only case where the tab bar would need padding. Doesn't need to be handled in this bug.
Severity: normal → trivial
(In reply to comment #5)
> That's not the only case where the tab bar would need padding. Doesn't need to
> be handled in this bug.

Should there just be a general bug for spacing/padding issues? More than one area of the navigation bar needs attention
In tabs-on-bottom mode, this add border radius to the bookmarks toolbar: 

#main-window[sizemode="normal"] [tabsontop="false"] #PersonalToolbar {
  -moz-border-radius-topleft: 3px;
  -moz-border-radius-topright: 3px;
}
Attached patch more adjustmentsSplinter Review
Attachment #469797 - Attachment is obsolete: true
Attachment #470729 - Attachment is obsolete: true
Attachment #477128 - Flags: review?(gavin.sharp)
Attachment #469797 - Flags: review?(gavin.sharp)
Attachment #477128 - Flags: review?(gavin.sharp) → review?(shorlander)
Attachment #477128 - Flags: review?(shorlander) → review?(mano)
Attachment #477128 - Flags: approval2.0?
Attachment #477128 - Flags: approval2.0? → approval2.0+
http://hg.mozilla.org/mozilla-central/rev/2a8b5ed8f29e
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b8
You spend your time to fix such small and almost invisible things, like square corners while the bug with tabbar bouncing caused by making all tabs on tabbar pinned is still present. I even suggested you a fix with css and the bug is still there and even has an "unconfirmed" status.
I hope that when the upcoming beltzner's retirement on pension (which will happen in 1 month) will bring you a new leader - he'll jack your @$$es good.
(In reply to comment #11)
> You spend your time to fix such small and almost invisible things, like square
> corners while the bug with tabbar bouncing caused by making all tabs on tabbar
> pinned is still present. I even suggested you a fix with css and the bug is
> still there and even has an "unconfirmed" status.

Bug comments are for discussing how the bug can be fixed; not being rude to developers and telling them what they should and should not do.

https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

(I apologise for spamming everyone's bugmail with this comment.)
(In reply to comment #11)
(In reply to comment #12)

Dude, you are so not cool.

On topic, Dao, I know there is separate bug for it, but while you were at it, why yiou didn't extend the border to entire window?
(In reply to comment #14)
> On topic, Dao, I know there is separate bug for it, but while you were at it,
> why yiou didn't extend the border to entire window?

Because there are plans to use the native glass border instead. See bug 588764.
Then what was the point of removing them in the first place?
Attached patch tabsonbottom (obsolete) — Splinter Review
Doesn't tabs on bottom need something like this too?
Attachment #484620 - Flags: review?(mano)
Comment on attachment 484620 [details] [diff] [review]
tabsonbottom

Please file a new bug on this.
Attachment #484620 - Attachment is obsolete: true
Attachment #484620 - Flags: review?(mano)
Target Milestone: Firefox 4.0b8 → Firefox 4.0b7
Blocks: 620138
No longer blocks: 620138
Depends on: 620138
You need to log in before you can comment on or make changes to this bug.