Last Comment Bug 571746 - [ug] [Fx] New localization: Uyghur
: [ug] [Fx] New localization: Uyghur
Status: RESOLVED INCOMPLETE
:
Product: Mozilla Localizations
Classification: Client Software
Component: Registration & Management (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Localization Registration Bugs
:
Mentors:
Depends on: 958577
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-13 01:44 PDT by Uyghur
Modified: 2014-08-06 08:58 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Firefox 3.6 Uyghur language pack (133.06 KB, application/octet-stream)
2010-08-02 20:17 PDT, Sahran
no flags Details
Firefox 4.0 Uyghur language files (131.21 KB, application/octet-stream)
2010-08-12 04:46 PDT, Sahran
no flags Details
Firefox 4 Uyghur language file (130.37 KB, application/octet-stream)
2010-08-13 16:23 PDT, Sahran
no flags Details
[ug] translation files 2013-04-30 (153.10 KB, application/x-bzip2)
2013-04-30 00:56 PDT, Dwayne Bailey
no flags Details
[ug] translation files 2013-07-12 (155.52 KB, application/x-bzip2)
2013-07-12 05:36 PDT, Dwayne Bailey
no flags Details
Uighur 25.0a2 2013-08-13 20d14cb (158.27 KB, application/x-bzip2)
2013-08-13 04:00 PDT, Dwayne Bailey
no flags Details
ug 25.0a2 2013-08-19 d74628f (158.88 KB, application/x-bzip)
2013-08-19 10:03 PDT, Dwayne Bailey
no flags Details
ug 25.0a2 2013-09-09 1cefab9 (161.36 KB, application/x-bzip)
2013-09-09 04:37 PDT, Dwayne Bailey
no flags Details
ug 26.0a2 2013-10-24 0b9625b (169.38 KB, application/x-bzip)
2013-10-25 03:14 PDT, Dwayne Bailey
l10n: feedback+
Details

Description Uyghur 2010-06-13 01:44:33 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/533.4 (KHTML, like Gecko) Chrome/5.0.375.70 Safari/533.4
Build Identifier: Mozilla Procducts

Hi,

In the page https://wiki.mozilla.org/L10n:Teams no Uyghur Localization team.
Its possible to create Uyghur translation team?

Language Name: Uyghur
ISO language code: ug,  uig
Unix Locale Name: ug_CN
Text direction: Right To Left


Gheyret T.Kenji
2010/06/13

Reproducible: Always




(Now, we translated FireFox here https://l10n.mozilla.org/narro/narro_project_list.php?l=ug)
Comment 1 Seth Bindernagel 2010-06-14 09:57:26 PDT
Can you upload the source files for ug?  If you have questoins, Alexandru (the developer lead from Narro) should be able to help you do that.  We will need source files to do a review.
Comment 2 Sahran 2010-08-02 20:17:59 PDT
Created attachment 462313 [details]
Firefox 3.6 Uyghur language pack

This is Firefox 3.6 Uyghur language pack installation file.
Comment 3 Seth Bindernagel 2010-08-03 10:22:36 PDT
Thanks, Sahran.  We will do a review soon and get back to you if there is anything to fix.
Comment 4 Seth Bindernagel 2010-08-03 10:28:11 PDT
Just adding a note from the localizers that I received via email:

"We translated Mozilla Firefox in Narro. Attached file is Firefox 3.6 Uyghu language pack installation...I replaced \chrome\ug.jar\locale\ug\global\intl.css  file in .xpi because Uyghur language [is] written by right to left..."
Comment 5 Seth Bindernagel 2010-08-11 03:13:43 PDT
I sent both Uyghur team members in this bug an email proposing we focus on Firefox 4.  Hoping to hear a response soon.
Comment 6 Sahran 2010-08-12 04:46:30 PDT
Created attachment 465205 [details]
Firefox 4.0 Uyghur language files

Firefox 4.0 Uyghur language files. this file build in Narro. I'm replaced intl.css file. Uyghur translation finished 94%, we are finish translation soon.
thanks.
Comment 7 Seth Bindernagel 2010-08-12 12:09:17 PDT
You are finished soon?  Or, you have finished?  If you are not done yet, can you simply attach the 4.0 files when they are complete?  We can proceed from there.
Comment 8 Sahran 2010-08-13 16:23:19 PDT
Created attachment 465886 [details]
Firefox 4 Uyghur language file

Firefox 4 Uyghur language files translation is finish. but I can't install this xpi file to Firefox 4 beta 3.
Comment 9 Axel Hecht [:Pike] 2010-10-19 01:34:31 PDT
Hi Sahran,

sorry for yet another lag here. I've looked at your files, and they seem to be a good starting point.

Next steps would be for us to create a repository based on your work and get it added to the nightly builds, and we'd file a bunch of bugs to track your bugzilla component and a few decisions around search plugins and such. We'd also ask you to update your localization for the current state of firefox 4, this time as an actual patch for that upcoming repository. Based on that patch, we'd vouch for you to get actual commit access to it.

As you've probably seen, the Firefox 4 Beta program is progressing, but not exactly how we planned it. I initially planned to add you in that scheme, which I should have said here in the bug, sorry for that.

Now, plans have changed [1], and for us it'd be a great time to pick this up. Does that work for you guys?

[1] http://groups.google.com/group/mozilla.dev.l10n/browse_frm/thread/4fb6a97e51990b5a#
Comment 10 Axel Hecht [:Pike] 2011-07-01 04:03:15 PDT
Hi Sahran,

as you've probably heard, Firefox is now on a new release cadence. We're trying to release a new version every 6 weeks, including localization updates.

Do I read the status on narro right that you're actively working on the Firefox Aurora version there? If so, it'd probably make sense to go ahead and add you guys to the mozilla-made aurora builds now and start working on making Uyghur an official Firefox localization.
Comment 11 arky [:arky] 2013-04-08 23:34:17 PDT
Sahran, If you could finish remaining 200 strings on 'user1' on pootle[1]. Then we can start the process of landing this in aurora.

Suggest discontinue any translation work on narro[2]. When you are ready we can import those translations to pootle and disable it on narro.


[1] http://mozilla.locamotion.org/ug/firefox/
[2] http://a.maimult.ro/lmo/project.php?l=ug&p=28
Comment 12 Dwayne Bailey 2013-04-30 00:56:05 PDT
Created attachment 743485 [details]
[ug] translation files 2013-04-30

Latest files for Uyghur.  I made some correction to intl.properties
Comment 13 Axel Hecht [:Pike] 2013-07-10 07:28:12 PDT
Comment on attachment 743485 [details]
[ug] translation files 2013-04-30

Can I get a new attachment? In particular given that the export scheme changed, and as there's new contributions, that'd be useful.

Thanks and sorry for the lag
Comment 14 Dwayne Bailey 2013-07-12 05:36:46 PDT
Created attachment 774594 [details]
[ug] translation files 2013-07-12

Update to latest translations using new scheme of only translated strings being exported.
Comment 15 Dwayne Bailey 2013-08-13 04:00:49 PDT
Created attachment 789508 [details]
Uighur 25.0a2 2013-08-13 20d14cb

Updated to latest Aurora 25 and fully translated expect for developer tools.
Comment 16 Dwayne Bailey 2013-08-19 10:03:38 PDT
Created attachment 792269 [details]
ug 25.0a2 2013-08-19 d74628f

Updated to include latest fixes
Comment 17 arky [:arky] 2013-09-04 10:38:42 PDT
Dwayne, Can you upload a new tarball. Filling a bug for this.
Comment 18 Dwayne Bailey 2013-09-09 04:37:15 PDT
Created attachment 801517 [details]
ug 25.0a2 2013-09-09 1cefab9

Update to latest tarball
Comment 19 Dwayne Bailey 2013-10-25 03:14:27 PDT
Created attachment 822225 [details]
ug 26.0a2 2013-10-24 0b9625b

Latest tarball for Aurora 26
Comment 20 Axel Hecht [:Pike] 2014-01-10 09:02:34 PST
Comment on attachment 822225 [details]
ug 26.0a2 2013-10-24 0b9625b

This looks technically OK, but we need a fix for RTL first, I filed that bug to block this one.
Comment 21 Axel Hecht [:Pike] 2014-01-10 09:07:02 PST
Sahran, we'd like to move forward here. Given that we need the RTL fix from bug 958577, Firefox 29 sounds like a good target to me. That's the cycle that's hitting aurora in 3 weeks.

Have you been able to test your work in progress yet? Are you seeing your interface in RTL? If not, you should be able to hack your profile, go to about:config, click yourself through, and right-click to create a new string preference. The name of the preference should be 'intl.uidirection.ur', and the value be 'rtl'. You probably want to restart the browser afterwards, and then see your UI in right-to-left display.
Comment 22 :Ehsan Akhgari 2014-01-10 15:12:07 PST
(In reply to Axel Hecht [:Pike] from comment #21)
> Sahran, we'd like to move forward here. Given that we need the RTL fix from
> bug 958577, Firefox 29 sounds like a good target to me. That's the cycle
> that's hitting aurora in 3 weeks.

Happy to welcome another RTL language to our family!  :-)

> Have you been able to test your work in progress yet? Are you seeing your
> interface in RTL? If not, you should be able to hack your profile, go to
> about:config, click yourself through, and right-click to create a new string
> preference. The name of the preference should be 'intl.uidirection.ur', and
> the value be 'rtl'. You probably want to restart the browser afterwards, and
> then see your UI in right-to-left display.

I believe Axel meant the 'intl.uidirection.ug' pref.  But at any rate, I hope to fix bug 958577 in the next few days.
Comment 23 Axel Hecht [:Pike] 2014-01-11 07:34:11 PST
Doh, yes, copy-and-paste bug. As for testing, the l10n contributors probably test on Aurora, not sure if we should uplift 958577 to 28.
Comment 24 Axel Hecht [:Pike] 2014-08-06 08:58:57 PDT
This bug hasn't seen action since January, resolving INCOMPLETE.

If there's renewed interest, feel free to reopen. My questions from comment 21 would be open questions again then.

Note You need to log in before you can comment on or make changes to this bug.