Closed Bug 571769 Opened 9 years ago Closed 7 years ago

warning: ISO C++ forbids casting between pointer-to-function and pointer-to-object in nsWifiScannerUnix.cpp

Categories

(Core :: Networking, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: jdm, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [build_warning])

/home/t_mattjo/src/firefox/m-c/netwerk/wifi/nsWifiScannerUnix.cpp: In function ‘int scan_wifi(int, char*, char**, int)’:
/home/t_mattjo/src/firefox/m-c/netwerk/wifi/nsWifiScannerUnix.cpp:72: warning: ISO C++ forbids casting between pointer-to-function and pointer-to-object
/home/t_mattjo/src/firefox/m-c/netwerk/wifi/nsWifiScannerUnix.cpp: In member function ‘nsresult nsWifiMonitor::DoScan()’:
/home/t_mattjo/src/firefox/m-c/netwerk/wifi/nsWifiScannerUnix.cpp:142: warning: ISO C++ forbids casting between pointer-to-function and pointer-to-object
/home/t_mattjo/src/firefox/m-c/netwerk/wifi/nsWifiScannerUnix.cpp:143: warning: ISO C++ forbids casting between pointer-to-function and pointer-to-object
/home/t_mattjo/src/firefox/m-c/netwerk/wifi/nsWifiScannerUnix.cpp:144: warning: ISO C++ forbids casting between pointer-to-function and pointer-to-object
/home/t_mattjo/src/firefox/m-c/netwerk/wifi/nsWifiScannerUnix.cpp:162: warning: ISO C++ forbids casting between pointer-to-function and pointer-to-object
Duplicate of this bug: 576657
Blocks: 577718
Whiteboard: [build_warning]
Bug 668194 replaced nsWifiScannerUnix.cpp with nsWifiScannerDBus.cpp

The two files look sufficiently different to me, so I'm assuming these warnings don't apply anymore.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.