Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Hovering "Print" menuitem shows black on blue instead of white on blue

VERIFIED FIXED in Firefox 4.0b1

Status

()

Firefox
Theme
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: John P Baker, Assigned: dao)

Tracking

Trunk
Firefox 4.0b1
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Under the new Firefox Button menu, hovering "Print" shows black on blue which is unreadable.
Not here.

Comment 2

7 years ago
(In reply to comment #1)
> Not here.

Are you using Windows 2000?
My appologize, didn't notice what OS you are using. Consider my comment to be superfluous.
(Assignee)

Updated

7 years ago
Assignee: nobody → dao
Component: Menus → Theme
QA Contact: menus → theme
(Assignee)

Comment 4

7 years ago
Created attachment 454247 [details] [diff] [review]
patch
Attachment #454247 - Flags: review?(gavin.sharp)
Why is that change needed? I.e. what is the cause of this bug?
(Assignee)

Comment 6

7 years ago
menupopup > menu[_moz-menuactive="true"] & co. from http://mxr.mozilla.org/mozilla-central/source/toolkit/themes/winstripe/global/menu.css#198 miss these nodes, as they aren't direct children of the menupopup.
Attachment #454247 - Flags: review?(gavin.sharp) → review+
(Assignee)

Comment 7

7 years ago
http://hg.mozilla.org/mozilla-central/rev/9da3f11ae0b7
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.7a6

Comment 8

7 years ago
Created attachment 454352 [details]
screenshot

After landing the patch,
There are strange behavior in the highlight of label and arrow.
 Left side image: mouse hover label.
 Right side image: mouse hover dropdown arrow.

Comment 9

7 years ago
The sub menu does not open automatically when i mouse hover the label.
Hoever, if i mouse hover the arrow, it open automatically.
(ui.submenuDelay is defalt value)

Comment 10

7 years ago
And  horizontal alignment of Ctrl+P seems wrong.

Comment 11

7 years ago
(In reply to comment #10)
> And  horizontal alignment of Ctrl+P seems wrong.
this was solved by landing Bug 571750
(Assignee)

Comment 12

7 years ago
(In reply to comment #9)
> The sub menu does not open automatically when i mouse hover the label.
> Hoever, if i mouse hover the arrow, it open automatically.

That's intentional, as "Print" is an action on its own.
(Reporter)

Comment 13

7 years ago
Verified fixed.

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.3a6pre) Gecko/20100628 Minefield/3.7a6pre
Status: RESOLVED → VERIFIED
Just wondering if this rules shouldn't live in menu.css?
(Assignee)

Comment 15

7 years ago
They shouldn't, split-menuitem-* is Firefox specific.
You need to log in before you can comment on or make changes to this bug.