Closed Bug 571966 Opened 10 years ago Closed 9 years ago

bookmark manager open close is awkward

Categories

(SeaMonkey :: Bookmarks & History, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: schneidt, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.9) Gecko/20100317 SeaMonkey/2.0.4
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.9) Gecko/20100317 SeaMonkey/2.0.4

When I click on the triangle, the file folder icon or the name of a bookmark folder, I expect it to switch states from open to closed or closed to open.
But the focus point is moving around and it is awkward to manipulate as a result.

Reproducible: Always

Steps to Reproduce:
1. click on a folder triangle - it opens.  close it again.
2. click on the icon or name - nothing happens.
3. double click on the icon or name - it opens.
Actual Results:  
see above


Expected Results:  
A single click anywhere on the folder line should switch the state.
This would be a lot easier to use.
Is this a dupe of bug 571965?
(In reply to comment #1)
> Is this a dupe of bug 571965?

No, they are different bugs.  This bug is about how awkward it is to open and close the folders on the bookmarks list.  Bug 571965 is about the fact that the triangles on new folders are not displayed until the parent folder is closed and opened again.

(I should not have added 'function is awkward' to the title of 571965.)
Well, bug 498596 will probably obsolete both bugs anyhow by completely rewriting the bookmarks system and manager.
(In reply to comment #3)
> Well, bug 498596 will probably obsolete both bugs anyhow by completely
> rewriting the bookmarks system and manager.

Oh, great!  You are working on it!
I will comment over there.
Still the same with the new BM.

I would find it awkward if just clicking a bookmarks folder would open it. The standard ways, which all work, are:
- use the right arrow key when the folder is focused
- double left click the folder
- left click the triangle
- drag something onto the folder (folder opens delayed)

Suggesting WONTFIX.
OS: Mac OS X → All
Hardware: x86 → All
Whiteboard: [CLOSEME INVA/WONT?]
(In reply to comment #5)
> Suggesting WONTFIX.

I concur.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → WONTFIX
Whiteboard: [CLOSEME INVA/WONT?]
I said:

A single click anywhere on the folder line should switch the state.
This would be a lot easier to use.

This would be a lot easier than the complex rules you have made.
One click switches the state and the meaning doesn't change.  Work on a Mac
to see good designs (usually).
You need to log in before you can comment on or make changes to this bug.