'Recently Closed' feature totally undiscoverable with the New Firefox App Button in play

RESOLVED DUPLICATE of bug 583386

Status

()

Firefox
Menus
RESOLVED DUPLICATE of bug 583386
8 years ago
8 years ago

People

(Reporter: ronin.achilles, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0(Windows; U; Windows NT 5.2; rv:1.9.2) Gecko/20100101 Firefox/3.6
Build Identifier: Mozilla/5.0(Windows; U; Windows NT 5.2; rv:1.9.2) Gecko/20100101 Firefox/3.6

When the Menu Bar existed, there was a chance that the users could discover 'Recently Cosed Tabs/Windows' feature. Now with the App Button in Title Bar (and Menu Bar hidden), a typical user will get exposed only to 'History' which is included in the App Button. 

Either we need to add the 'recently closed' feature to the App Button -> History submenu, or find a suitable place for it...

Reproducible: Always
(Reporter)

Updated

8 years ago
Blocks: 556174, 571752

Comment 1

8 years ago
I have this function in my tab contextual menu. I believe it should be there by default in Firefox 4, not only because of the lack of space in Firefox menu, but also because it's where it makes sense: in the tabs and/or tab bar.

(I use Menu Editor to edit my menus)
The current plan is to modify the all tabs menu to expose those options. I think Limi was looking into that and it may have a bug already.

Updated

8 years ago
Component: General → Menus
QA Contact: general → menus
Stephen, I can't find such a bug, could you clarify the mockup with Limi and reuse this bug or create a new one?

Updated

8 years ago
Duplicate of this bug: 577160
Status: UNCONFIRMED → NEW
blocking2.0: --- → ?
Ever confirmed: true
Hardware: x86 → All
Version: unspecified → Trunk
Duplicate of this bug: 578886

Updated

8 years ago
OS: Windows Server 2003 → All
Yep, these commands definitely need to be available.

I'm duping this change forward to bug 583386 so that we can centralize discussion, work, and blocking status for beta 4.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 583386
blocking2.0: ? → ---

Updated

8 years ago
Duplicate of this bug: 586202
You need to log in before you can comment on or make changes to this bug.