Last Comment Bug 572417 - [OOPP]Video control does not work while in full screen mode of the flash
: [OOPP]Video control does not work while in full screen mode of the flash
Status: RESOLVED FIXED
[oopp-watchlist] [verify once bug 596...
: regression
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: 1.9.2 Branch
: x86 Windows 7
: -- normal with 16 votes (vote)
: ---
Assigned To: Jim Mathies [:jimm]
:
Mentors:
http://ve3d.ign.com/videos/69204/PC/P...
Depends on: 596094 628872 634216
Blocks: OOPP
  Show dependency treegraph
 
Reported: 2010-06-16 08:24 PDT by Alice0775 White
Modified: 2011-02-15 02:05 PST (History)
17 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
betaN+
wanted


Attachments
fix for event race v.1 (2.09 KB, patch)
2010-09-27 14:36 PDT, Jim Mathies [:jimm]
no flags Details | Diff | Review
stand alone test case (726 bytes, text/html)
2010-09-29 12:46 PDT, Jim Mathies [:jimm]
no flags Details
rel capture patch (1.20 KB, patch)
2010-09-29 15:14 PDT, Jim Mathies [:jimm]
no flags Details | Diff | Review
rel capture patch (1.24 KB, patch)
2010-09-29 19:26 PDT, Jim Mathies [:jimm]
benjamin: review+
Details | Diff | Review
Browser window context menus instead of flash ones (60.55 KB, image/jpeg)
2010-10-21 18:39 PDT, [not reading bugmail]
no flags Details
move release after CallWindowProc patch (1.48 KB, patch)
2010-12-15 13:35 PST, Jim Mathies [:jimm]
benjamin: review+
Details | Diff | Review

Description Alice0775 White 2010-06-16 08:24:56 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; ja; rv:1.9.2.4) Gecko/20100611 Firefox/3.6.4 ID:20100611143157
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; ja; rv:1.9.2.4) Gecko/20100611 Firefox/3.6.4 ID:20100611143157

Fullscreen video controls on http://ve3d.ign.com/videos/69204/PC/Portal-2/Trailer/E3-2010-Debut-Trailer does not work of Firefox 3.6.4 .

If I disabled OOPP, the video contorol works again.

This problem happens also on the following trunk and branch.
Mozilla/5.0 (Windows; U; Windows NT 6.1; WOW64; en-US; rv:1.9.3a6pre) Gecko/20100616 Minefield/3.7a6pre ID:20100616035900
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.6pre) Gecko/20100616 Namoroka/3.6.6pre ID:20100616042232.

Reproducible: Always

Steps to Reproduce:
1. Start Minfield/Namoroka/Firefox3.6.4 with new profile + Flash 10.1
2. Open URL ( http://ve3d.ign.com/videos/69204/PC/Portal-2/Trailer/E3-2010-Debut-Trailer )
3. Play flash movie
4. Click full screen icon  of the flash video.
5. Click video controls.

Actual Results:
 Video control does not work while in fullscreen mode of the flash video

Expected Results:
 Video control should work while in fullscreen mode of the flash video
Comment 1 XtC4UaLL [:xtc4uall] 2010-06-16 09:25:41 PDT
(In reply to comment #0)
> This problem happens also on the following trunk and branch.
> Mozilla/5.0 (Windows; U; Windows NT 6.1; WOW64; en-US; rv:1.9.3a6pre)
> Gecko/20100616 Minefield/3.7a6pre ID:20100616035900

actually it doesn't work back in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a1) Gecko/20100208 MozillaDeveloperPreview/3.7a1 (http://hg.mozilla.org/mozilla-central/rev/43e818c28059; setting dom.ipc.plugins.enabled;true manually) either.
Comment 2 aravindm 2010-06-16 11:25:41 PDT
Build worked : 
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.4pre) Gecko/20100406 Namoroka/3.6.4pre

http://hg.mozilla.org/releases/mozilla-1.9.2/rev/965a31dcde02

Build broken : 
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.4pre) Gecko/20100407 Lorentz/3.6.4pre

http://hg.mozilla.org/releases/mozilla-1.9.2/rev/ec534329e186

Pushlog : 
http://hg.mozilla.org/releases/mozilla-1.9.2/pushloghtml?fromchange=965a31dcde02&tochange=ec534329e186
Comment 3 christian 2010-06-16 14:07:19 PDT
...which basically points to OOPP, as that's when it landed
Comment 4 Alice0775 White 2010-06-17 21:15:04 PDT
In adittion comment #0
In fullscreen mode, 
Right click on flash video does not work. should popup flash context menu. 
Left click on flash video  does not work. should toggle pause and play.
Comment 5 Alexey Koptev 2010-07-14 17:45:47 PDT
(In addition to comment #0 and comment #4)
http://video.xnxx.com/video435366/perfect_ass_and_videogames
Excuse me for an example :)
If click fullscreen button - bug, and only ESC helps,
but if MENU-fullscreen - no bug!

Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6
With two last stable flash player versions.
Comment 6 Jim Mathies [:jimm] 2010-09-13 10:58:56 PDT
(In reply to comment #5)
> (In addition to comment #0 and comment #4)
> http://video.xnxx.com/video435366/perfect_ass_and_videogames
> Excuse me for an example :)
> If click fullscreen button - bug, and only ESC helps,
> but if MENU-fullscreen - no bug!
> 
> Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.9.2.6) Gecko/20100625
> Firefox/3.6.6
> With two last stable flash player versions.

note - nsfw ^^^
Comment 7 Jim Mathies [:jimm] 2010-09-13 11:32:48 PDT
Appears to be a window activation problem, mouse events are being delivered to the underlying plugin window.
Comment 8 Jim Mathies [:jimm] 2010-09-27 14:36:34 PDT
Created attachment 478865 [details] [diff] [review]
fix for event race v.1
Comment 9 Jim Mathies [:jimm] 2010-09-29 12:46:22 PDT
Created attachment 479517 [details]
stand alone test case
Comment 10 Jim Mathies [:jimm] 2010-09-29 15:14:39 PDT
Created attachment 479586 [details] [diff] [review]
rel capture patch

Makes sure capture is released after the mouse is released.
Comment 11 Jim Mathies [:jimm] 2010-09-29 19:18:36 PDT
Comment on attachment 479586 [details] [diff] [review]
rel capture patch

Doh, that should be the up events!
Comment 12 Jim Mathies [:jimm] 2010-09-29 19:26:09 PDT
Created attachment 479679 [details] [diff] [review]
rel capture patch
Comment 13 Benjamin Smedberg [:bsmedberg] 2010-09-30 10:14:07 PDT
Comment on attachment 479679 [details] [diff] [review]
rel capture patch

Do we need to do this in-process as well, or is this just something peculiar to multiple processes and capture?
Comment 14 Jim Mathies [:jimm] 2010-10-07 00:05:08 PDT
http://hg.mozilla.org/mozilla-central/rev/e05eb865c779
Comment 15 Stebs 2010-10-11 15:40:03 PDT
This is still not fixed on Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101011 Firefox/4.0b8pre

Setting dom.ipc.plugins.enabled to true and controls etc. work in fullscreen.
Comment 16 Jim Mathies [:jimm] 2010-10-11 16:46:03 PDT
(In reply to comment #11)
> Comment on attachment 479586 [details] [diff] [review]
> rel capture patch
> 
> Doh, that should be the up events!

Oh man, I may have made a short sighted last minute change that broke this. Will test and post back.
Comment 17 Jim Mathies [:jimm] 2010-10-12 06:56:22 PDT
(In reply to comment #16)
> (In reply to comment #11)
> > Comment on attachment 479586 [details] [diff] [review] [details]
> > rel capture patch
> > 
> > Doh, that should be the up events!
> 
> Oh man, I may have made a short sighted last minute change that broke this.
> Will test and post back.

Actually, this depends on our sub classes being in place (bug 596094). When I wrote this I had those patches applied underneath. We have to wait for those to land before we can verify this bug is fixed.
Comment 18 [not reading bugmail] 2010-10-21 18:39:36 PDT
Created attachment 485201 [details]
Browser window context menus instead of flash ones

Jim, I just tried the hourly (20101021160721 e5f3177aa3bc) with the subclass fix, but didn't see any improvement here.  I can get the browser context menus to show up if I click enough times (see attachment) but not flash's context menu, nor can I use the left to manipulate the controls.  OOPP enabled.
Comment 19 Jim Mathies [:jimm] 2010-10-21 19:27:47 PDT
Are you sure you grabbed the right hourly? Working here for me:

http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-central-win32/1287702441/
Comment 20 Jim Mathies [:jimm] 2010-10-21 19:37:22 PDT
(In reply to comment #19)
> Are you sure you grabbed the right hourly? Working here for me:
> 
> http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-central-win32/1287702441/

ah crap, sorry, I had ipc disabled. You're right, this still isn't working.
Comment 21 Jim Mathies [:jimm] 2010-10-21 19:48:56 PDT
Odd, in a local debug build this is working fine. Must be something with the timing. I'll see if I can track this down tomorrow.
Comment 22 Jim Mathies [:jimm] 2010-10-22 06:28:21 PDT
(In reply to comment #21)
> Odd, in a local debug build this is working fine. Must be something with the
> timing. I'll see if I can track this down tomorrow.

Ok, now in today's nightly it appears to be fixed again!
Comment 23 Jim Mathies [:jimm] 2010-10-22 06:29:17 PDT
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101022 Firefox/4.0b8pre
Comment 24 XtC4UaLL [:xtc4uall] 2010-10-22 12:52:50 PDT
This is still not working as expected using a Build built from http://hg.mozilla.org/mozilla-central/rev/2842d671052f (Hourly) + Adobe Flash 10.2.161.23 on WinXP.
Comment 25 Christian Ascheberg 2010-10-27 12:10:34 PDT
(In reply to comment #24)
> This is still not working as expected

same for me, it's still not working
Comment 26 Jim Mathies [:jimm] 2010-10-27 12:57:47 PDT
(In reply to comment #25)
> (In reply to comment #24)
> > This is still not working as expected
> 
> same for me, it's still not working

What's the version of fx you're testing with?
Comment 27 Christian Ascheberg 2010-10-27 13:11:57 PDT
(In reply to comment #26)
> What's the version of fx you're testing with?

sorry, it is: latest-trunk nightly with Adobe Flash 10.1.85.3 on Win Vista / Win7 x86
Comment 28 Jim Mathies [:jimm] 2010-10-27 13:18:42 PDT
So what steps are people taking here?  My STR:

1) visit http://ve3d.ign.com/videos/69204/PC/Portal-2/Trailer/E3-2010-Debut-Trailer
2) click through the ad to the video
3) click full screen button on the video
4) click full screen button in the full screen video

or

3) click play
4) click full screen button on the video
5) click full screen button in the full screen video

In both cases the full screen button in step five closes the full screen window.

Is there any variation here for those that still see this?
Comment 29 Christian Ascheberg 2010-10-27 13:53:00 PDT
(In reply to comment #28)

none of the video controls is working as soon as I am in full screen mode.

Something I just found out:
1.: video is in fullscreen mode (stand alone testcase)
2.: - right clicking upper part of the video: tabs context menu appears
and / or
- right clicking right part of the video: website context menu shows up (clicking at the position where those normally would have shown up in non-fullscreen mode, menus will not disappear)
3.: after one of that, I can do a right click on the top of the screen: firefox window menu appears (minimize, close etc...)
4.: then video controls are working fine, previous menus will disappear, right click brings up flashplayer menu!
Comment 30 XtC4UaLL [:xtc4uall] 2010-10-27 14:33:26 PDT
(In reply to comment #28)
> So what steps are people taking here?  My STR:

Regarding Comment 24 I used the one of Comment 0.
Comment 31 Christian Ascheberg 2010-12-08 19:09:51 PST
Note that this is still not fixed for me, but what I described in comment #29 can be shortened now since the landing of bug 595132:

1: firefox is maximized, video is in full screen mode (stand alone testcase)
2: right click top of the screen: firefox window menu appears (minimize, close etc...)
3: clicking in fullscreen flash only then totally works as expected

It just feels as if the firefox window is still in the foreground (although you can only see the fullscreen flash) as I can easily open different types of browser context menus (though I am not able to click on the menus then).
Comment 32 Jim Mathies [:jimm] 2010-12-15 12:27:44 PST
I finally managed to reproduce this again in a vmware image. Will dig into this more today.
Comment 33 Jim Mathies [:jimm] 2010-12-15 13:35:55 PST
Created attachment 497879 [details] [diff] [review]
move release after CallWindowProc patch

Just pushed this to try to get a release build for testing. This fixed the problem in my vmware image.
Comment 34 Jim Mathies [:jimm] 2010-12-15 17:02:33 PST
(In reply to comment #33)
> Created attachment 497879 [details] [diff] [review]
> move release after CallWindowProc patch
> 
> Just pushed this to try to get a release build for testing. This fixed the
> problem in my vmware image.

http://ftp.mozilla.org/pub/mozilla.org/firefox/tryserver-builds/jmathies@mozilla.com-3def17b8a4b8/try-w32/

I'd appreciate anyone who can reproduce this reliable take this build for a spin and see if they still see the problem.
Comment 35 Christian Ascheberg 2010-12-15 17:17:09 PST
(In reply to comment #34)
> http://ftp.mozilla.org/pub/mozilla.org/firefox/tryserver-builds/jmathies@mozilla.com-3def17b8a4b8/try-w32/
> 
> I'd appreciate anyone who can reproduce this reliable take this build for a
> spin and see if they still see the problem.

It is working fine!
Comment 36 Jim Mathies [:jimm] 2010-12-16 08:16:21 PST
Comment on attachment 497879 [details] [diff] [review]
move release after CallWindowProc patch

This is slight change from the original patch. Reset the capture state after the mouse event is delivered.
Comment 37 Benjamin Smedberg [:bsmedberg] 2010-12-16 11:03:19 PST
Comment on attachment 497879 [details] [diff] [review]
move release after CallWindowProc patch

While you're here, add a space after `switch`
Comment 38 Jim Mathies [:jimm] 2010-12-20 06:46:25 PST
http://hg.mozilla.org/mozilla-central/rev/39aba38b8706
Comment 39 XtC4UaLL [:xtc4uall] 2010-12-20 18:07:13 PST
Indeed, it's fixed now for real with Firefox/4.0b9pre ID:20101220150506. Thanks Jim :)

Note You need to log in before you can comment on or make changes to this bug.