Support the "Undo" key on Sun keyboards

RESOLVED FIXED in Future

Status

()

enhancement
P3
normal
RESOLVED FIXED
19 years ago
3 months ago

People

(Reporter: hsivonen, Assigned: vishy)

Tracking

(Blocks 2 bugs)

Trunk
Future
Sun
Solaris
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: SunKey)

Attachments

(1 attachment)

1.94 KB, text/plain
akkzilla
: review+
sfraser_bugs
: superreview+
Details
Reporter

Description

19 years ago
Build ID: 2000101521 Solaris Sparc trunk

Steps to reproduce:
1) Type something in a form field
2) Press the "Undo" key on a Sun keyboard that has that key

Actual reesults:
Nothing

Expected results:
Expected the result to be the same as when pressing Ctrl-Z.

Additional infomation:
The "Copy" and "Paste" keys fuction as expected.
Assignee

Comment 1

19 years ago
Since Don has left, Vishy is taking his bugs in bulk, pending reassignment.
thanks,
	Vishy
Assignee: don → vishy

Updated

18 years ago
Blocks: 48322

Comment 2

18 years ago
It seems that the key should be found to VK_UNDO. I do not think one has to hit
any modifier.

To me, the change must be made in file:
http://lxr.mozilla.org/seamonkey/source/content/xbl/builtin/unix/platformHTMLBindings.xml

I do not know if one must take into consideration a possible redo. (is there a
redo key on Sun OS keyboards). I've asked on IRC #mozilla and there is
apparently not.

Follow the list of changes I would to to support the undo key for the
inputfields, textareas and editor (not navigator, is there a use for undo in
navigator?)
Add the following lines in file content/xbl/builtin/unix/platformHTMLBindings.xml
(note: starting from the end to keep the line numbers valid)

Line 199: 
<handler event="keypress" key="VK_UNDO" command="cmd_undo"/>

Line 155:
<handler event="keypress" key="VK_UNDO" command="cmd_undo"/>

Line 73:
<handler event="keypress" key="VK_UNDO" command="cmd_undo"/>


(sorry I didn't find a way to donwload the file from bonsai to edit it and make
a diff).

Hope this helps...

Comment 3

18 years ago
please read Bug 48322 Comment 5. Rich B (and the Sun HCI group) said that Again 
could be mapped to Redo.

Comment 4

18 years ago
forget about my comment #2, I think its crap (VK_UNDO is not the right key).
Thanks timeless for pointing out the other bug.

Updated

18 years ago
Target Milestone: --- → Future

Updated

18 years ago
Depends on: atfmeta

Updated

18 years ago
No longer depends on: atfmeta

Updated

18 years ago
Blocks: atfmeta

Comment 5

18 years ago
Posted file patch
the explaination for this patch is as same as bug 57262 and bug 113551.
this patch can make Undo key work fine not only for input field, but also for
textarea, browser and editor.

Aaronl, can you review it? thanks.
--Jay
Comment on attachment 72580 [details]
patch

This looks good to me. I assume we know this isn't going to conflict, or rather
cause problems, with other unix systems that don't have the sun keyboards. Do
we know what  F14 maps to on other unix keyboards? (looks like maybe scrolllock
on the one at my desk)

deferring official review to someone who knows a little more about this,
akkana? Is that you?

Comment 7

18 years ago
I've test this patch on Linux(Intel) and Solaris(Sparc), it works fine, but I
have not tried keyboards from other vendors such as HP, IBMAIX...

I think the best way to avoid conflict 100% is to have different folder for
different vendors, now we have windows+os2+mac+unix, can we have
windows+os2+mac+unix+sun+ibm+hp+...., folder sun is for sparc keybinding, and
ibm folder is for aix keybinging,... folder unix is for all other unix paltform
not implemented yet.

how about this suggestion? stupid?

anyway, I am still asking r=? for patch of this bug. thanks.

--Jay

Comment 8

18 years ago
Akkana is our best Unix keyboard guru. She's going to take a look at these Sun
keyboard bugs and tell us what needs to be done.

Comment 9

18 years ago
Comment on attachment 72580 [details]
patch

I'm not entirely happy that we're putting in all these bindings that everyone
has to parse when they're only meaningful on some hardware  of one platform ...
but that's the only option right now, and we've already gone that way with the
other F-high keys, so adding a couple more shouldn't hurt.  r=akkana
Attachment #72580 - Flags: review+
Comment on attachment 72580 [details]
patch

sr=sfraser
Attachment #72580 - Flags: superreview+
Comment on attachment 72580 [details]
patch

a=asa (on behalf of drivers) for checkin to the 1.0 trunk
Attachment #72580 - Flags: approval+

Comment 12

18 years ago
Aaronl, since this patch has been checked in, can you change the status. I have 
no permission. Thanks
--Jay

Comment 13

18 years ago
status->fixd
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
QA Contact: sairuh → nobody

Updated

17 years ago
Blocks: sunkeymeta
Whiteboard: SunKey
Keywords: qawanted
Component: Keyboard: Navigation → User events and focus handling
You need to log in before you can comment on or make changes to this bug.