Last Comment Bug 572668 - Remove the crypto strength token from the UA string
: Remove the crypto strength token from the UA string
Status: RESOLVED FIXED
[parity-IE]
: dev-doc-complete
Product: Core
Classification: Components
Component: Networking: HTTP (show other bugs)
: Trunk
: All All
: -- enhancement (vote)
: mozilla2.0b2
Assigned To: Saint Wesonga
:
: Patrick McManus [:mcmanus]
Mentors:
http://www.delorie.com:81/some/url.txt
Depends on: 579161
Blocks: http-fingerprint 129038 586165
  Show dependency treegraph
 
Reported: 2010-06-17 05:26 PDT by Henri Sivonen (:hsivonen)
Modified: 2011-04-20 13:59 PDT (History)
13 users (show)
bzbarsky: in‑testsuite?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (5.68 KB, patch)
2010-06-17 06:43 PDT, Saint Wesonga
bzbarsky: review+
Details | Diff | Splinter Review

Description Henri Sivonen (:hsivonen) 2010-06-17 05:26:05 PDT
Steps to reproduce:
 1) Load http://www.delorie.com:81/some/url.txt

Actual results:
The User-Agent string has the token " U;", which signifies that the browser provides crypto support that is stronger than what the "international" builds of Netscape offered circa 1995.

Expected results:
Expected this long-obsolete token not to be sent on every HTTP request.

Additional information:
This isn't actually fingerprinting-relevant, but since this is a suggesting UA string change, marking a dependency on the bug tracking suggested UA string changes.

IE doesn't send the " U;" token.
Comment 1 Saint Wesonga 2010-06-17 06:43:29 PDT
Created attachment 451924 [details] [diff] [review]
Patch
Comment 2 Boris Zbarsky [:bz] (still a bit busy) 2010-07-01 20:29:50 PDT
Comment on attachment 451924 [details] [diff] [review]
Patch

r=bzbarsky.  Do you need this landed?
Comment 3 Boris Zbarsky [:bz] (still a bit busy) 2010-07-02 15:42:04 PDT
Pushed http://hg.mozilla.org/mozilla-central/rev/22e19fe61752
Comment 4 Ryan Jones 2010-07-02 15:50:16 PDT
This reference document on the wiki probably needs to be updated after this change.

https://developer.mozilla.org/en/User_Agent_Strings_Reference

Note You need to log in before you can comment on or make changes to this bug.