vmware server 2 web interface does not draw properly

RESOLVED WONTFIX

Status

()

Firefox
Untriaged
RESOLVED WONTFIX
7 years ago
a year ago

People

(Reporter: Carl, Unassigned)

Tracking

50 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

When logging into a vmware server 2 web interface using firefox 4, the first page you go to renders properly.  But if I try to go to any of the virtual machines or any other part of the web interface, it fails to draw.

Reproducible: Always

Steps to Reproduce:
1.  Go to vmware server 2 web interface
2.  Login as an administrator user
3.  Click on one of the virtual machines or any other tab
Actual Results:  
First page that you are shown after you login draws out fine.  Any other part of it fails to draw and just appears as white.

Expected Results:  
It should not fail to draw any part of the web interface.

This worked in firefox 3.5.  Was broken when I upgraded to firefox 4.

Updated

7 years ago
Version: unspecified → 4.0 Branch

Comment 1

5 years ago
I'm having the same problem on SeaMonkey 2.13
(Reporter)

Comment 2

5 years ago
This is still happening in firefox 16.

When will this be important enough to fix?
(Reporter)

Updated

5 years ago
Priority: -- → P3
Version: 4.0 Branch → 16 Branch
I use VMWare web i/f in recent years and see no problem, so closing.
If you still see a problem please update the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

a year ago
Just checked now using firefox 50.1.0 and the bug is still there.  Please check against a vmware server 2.0.2 installation.

You can login and click on the various tabs.  But the moment you click on one of the vm's, the details do not get drawn out.

This works in IE 11.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Updated

a year ago
Hardware: x86 → x86_64
Version: 16 Branch → 50 Branch

Comment 5

a year ago
(In reply to Carl from comment #4)
> Just checked now using firefox 50.1.0 and the bug is still there.  Please
> check against a vmware server 2.0.2 installation.
> 
> You can login and click on the various tabs.  But the moment you click on
> one of the vm's, the details do not get drawn out.
> 
> This works in IE 11.

It seems like 2.0.2 is a very old version of vmware server... can you provide somewhere for us to test? And/or at least provide screenshots of what you see?

It seems pretty likely that this is just a bug in this old version of vmware that then presumably tells modern versions of IE to use an old version of the IE rendering engine. What happens in Chrome, does it behave like IE11 or like Firefox?
Severity: major → normal
Component: General → Untriaged
Flags: needinfo?(carl)
Priority: P3 → --
(Reporter)

Comment 6

a year ago
Hi,

I tested this in Chrome version 55.0.2883.87 m (64-bit).  It works in there.  I'm able to switch between the different tabs and able to click on a vm and have it load.
(Reporter)

Comment 7

a year ago
Created attachment 8821672 [details]
vmware interface.jpg

Here is it happening in firefox for me.  I have clicked on the vm at this point.
Flags: needinfo?(carl)
Attachment #8821672 - Flags: feedback+

Comment 8

a year ago
This is because their webapp is poorly written. It uses a regex to detect Firefox, and we broke that regex at the time of Firefox 4. Specifically, I can get their app to load if I install a user agent override tool and use:

Mozilla/5.0 (Windows; U; Windows NT 6.2; Win64; x64; en-US; rv:2.0b2pre) Gecko/20100703 Minefield/4.0b2pre

as the user agent on my install of Firefox 50.1.0 on my Windows 8 (6.2) machine.

Based on mozregression and the above, I believe this broke when we removed the encryption indicator from the UA string.

We won't put useless information back in the UA string just to fix a 5-year-old product with no updates, but hopefully the above workaround works for you. In my experience, I also needed to clear my cache and cookies and so on before it worked.
Blocks: 572668
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year agoa year ago
Resolution: --- → WONTFIX
(Reporter)

Comment 9

a year ago
Thank you!  At least there is a work around.  I can live with that.
You need to log in before you can comment on or make changes to this bug.