Segmentation fault right after startup [@ nsMsgComposeService::ReplyWithTemplate(nsIMsgDBHdr*, char const*, nsIMsgWindow*, nsIMsgIncomingServer*)]

RESOLVED FIXED in Thunderbird 3.3a1

Status

MailNews Core
Composition
--
critical
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: disposable84, Assigned: m_kato)

Tracking

({crash})

unspecified
Thunderbird 3.3a1
x86_64
All
crash

Thunderbird Tracking Flags

(thunderbird3.1 .5-fixed)

Details

(crash signature)

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.3) Gecko/20100423 Ubuntu/10.04 (lucid) Firefox/3.6.3
Build Identifier: Thunderbird 3.0.4 (3.0.4+nobinonly-0ubuntu4)

After upgrading to Ubuntu 10.04 Thunderbird works fine during day. Then Firefox was requested to restart in due to some updates (not plugins updates). Approximately since then Thunderbird crushes after starting and syncing with mailboxes.

Reproducible: Always

Steps to Reproduce:
1. Run thunderbird with either options in command line.
2. Initial opening Inbox folders messages displayed in status bar.

Actual Results:  
"Segmentation fault" returned in command line.

Expected Results:  
Working without faults :)

strace returns::

execve("/usr/bin/thunderbird", ["thunderbird"], [/* 41 vars */]) = 0
brk(0)                                  = 0x147d000
access("/etc/ld.so.nohwcap", F_OK)      = -1 ENOENT (No such file or directory)
mmap(NULL, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7f8f80e0b000
access("/etc/ld.so.preload", R_OK)      = -1 ENOENT (No such file or directory)
open("/etc/ld.so.cache", O_RDONLY)      = 3
fstat(3, {st_mode=S_IFREG|0644, st_size=117503, ...}) = 0
mmap(NULL, 117503, PROT_READ, MAP_PRIVATE, 3, 0) = 0x7f8f80dee000
close(3)                                = 0
access("/etc/ld.so.nohwcap", F_OK)      = -1 ENOENT (No such file or directory)
open("/lib/libc.so.6", O_RDONLY)        = 3
read(3, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0`\355\1\0\0\0\0\0"..., 832) = 832
fstat(3, {st_mode=S_IFREG|0755, st_size=1568136, ...}) = 0
mmap(NULL, 3676200, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0x7f8f8086b000
mprotect(0x7f8f809e3000, 2097152, PROT_NONE) = 0
mmap(0x7f8f80be3000, 20480, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x178000) = 0x7f8f80be3000
mmap(0x7f8f80be8000, 18472, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x7f8f80be8000
close(3)                                = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7f8f80ded000
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7f8f80dec000
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7f8f80deb000
arch_prctl(ARCH_SET_FS, 0x7f8f80dec700) = 0
mprotect(0x7f8f80be3000, 16384, PROT_READ) = 0
mprotect(0x617000, 4096, PROT_READ)     = 0
mprotect(0x7f8f80e0d000, 4096, PROT_READ) = 0
munmap(0x7f8f80dee000, 117503)          = 0
getpid()                                = 27933
rt_sigaction(SIGCHLD, {SIG_DFL, [CHLD], SA_RESTORER|SA_RESTART, 0x7f8f8089eaf0}, {SIG_DFL, [], 0}, 8) = 0
geteuid()                               = 1000
brk(0)                                  = 0x147d000
brk(0x149e000)                          = 0x149e000
getppid()                               = 27932
stat("/home/user", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
stat(".", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
open("/usr/bin/thunderbird", O_RDONLY)  = 3
fcntl(3, F_DUPFD, 10)                   = 10
close(3)                                = 0
fcntl(10, F_SETFD, FD_CLOEXEC)          = 0
rt_sigaction(SIGINT, NULL, {SIG_DFL, [], 0}, 8) = 0
rt_sigaction(SIGINT, {0x408189, ~[RTMIN RT_1], SA_RESTORER, 0x7f8f8089eaf0}, NULL, 8) = 0
rt_sigaction(SIGQUIT, NULL, {SIG_DFL, [], 0}, 8) = 0
rt_sigaction(SIGQUIT, {SIG_DFL, ~[RTMIN RT_1], SA_RESTORER, 0x7f8f8089eaf0}, NULL, 8) = 0
rt_sigaction(SIGTERM, NULL, {SIG_DFL, [], 0}, 8) = 0
rt_sigaction(SIGTERM, {SIG_DFL, ~[RTMIN RT_1], SA_RESTORER, 0x7f8f8089eaf0}, NULL, 8) = 0
read(10, "#!/bin/sh\n\n# Firefox launcher co"..., 8192) = 4842
pipe([3, 4])                            = 0
clone(child_stack=0, flags=CLONE_CHILD_CLEARTID|CLONE_CHILD_SETTID|SIGCHLD, child_tidptr=0x7f8f80dec9d0) = 27934
close(4)                                = 0
read(3, "/usr/bin/thunderbird\n", 128)  = 21
read(3, "", 128)                        = 0
close(3)                                = 0
wait4(-1, [{WIFEXITED(s) && WEXITSTATUS(s) == 0}], 0, NULL) = 27934
--- SIGCHLD (Child exited) @ 0 (0) ---
pipe([3, 4])                            = 0
clone(child_stack=0, flags=CLONE_CHILD_CLEARTID|CLONE_CHILD_SETTID|SIGCHLD, child_tidptr=0x7f8f80dec9d0) = 27935
close(4)                                = 0
read(3, "thunderbird\n", 128)           = 12
read(3, "", 128)                        = 0
close(3)                                = 0
--- SIGCHLD (Child exited) @ 0 (0) ---
wait4(-1, [{WIFEXITED(s) && WEXITSTATUS(s) == 0}], 0, NULL) = 27935
stat("/usr/lib/thunderbird-3.0.4/thunderbird", {st_mode=S_IFREG|0755, st_size=3885, ...}) = 0
stat("/home/user/.mozilla-thunderbird", {st_mode=S_IFDIR|0700, st_size=4096, ...}) = 0
lstat("/home/user/.mozilla-thunderbird", {st_mode=S_IFLNK|0777, st_size=23, ...}) = 0
stat("/home/user/.thunderbird", {st_mode=S_IFDIR|0700, st_size=4096, ...}) = 0
stat("/home/user/.thunderbird-3.0", 0x7fffee62ea70) = -1 ENOENT (No such file or directory)
stat("/home/user/.thunderbird-2.0-replaced", 0x7fffee62ea30) = -1 ENOENT (No such file or directory)
lstat("/home/user/.mozilla-thunderbird", {st_mode=S_IFLNK|0777, st_size=23, ...}) = 0
stat("/home/user/.mozilla-thunderbird", {st_mode=S_IFDIR|0700, st_size=4096, ...}) = 0
execve("/usr/lib/thunderbird-3.0.4/thunderbird", ["/usr/lib/thunderbird-3.0.4/thund"...], [/* 42 vars */]) = 0
brk(0)                                  = 0x1346000
access("/etc/ld.so.nohwcap", F_OK)      = -1 ENOENT (No such file or directory)
mmap(NULL, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7fbe43757000
access("/etc/ld.so.preload", R_OK)      = -1 ENOENT (No such file or directory)
open("/etc/ld.so.cache", O_RDONLY)      = 3
fstat(3, {st_mode=S_IFREG|0644, st_size=117503, ...}) = 0
mmap(NULL, 117503, PROT_READ, MAP_PRIVATE, 3, 0) = 0x7fbe4373a000
close(3)                                = 0
access("/etc/ld.so.nohwcap", F_OK)      = -1 ENOENT (No such file or directory)
open("/lib/libc.so.6", O_RDONLY)        = 3
read(3, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0`\355\1\0\0\0\0\0"..., 832) = 832
fstat(3, {st_mode=S_IFREG|0755, st_size=1568136, ...}) = 0
mmap(NULL, 3676200, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0x7fbe431b7000
mprotect(0x7fbe4332f000, 2097152, PROT_NONE) = 0
mmap(0x7fbe4352f000, 20480, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x178000) = 0x7fbe4352f000
mmap(0x7fbe43534000, 18472, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x7fbe43534000
close(3)                                = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7fbe43739000
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7fbe43738000
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7fbe43737000
arch_prctl(ARCH_SET_FS, 0x7fbe43738700) = 0
mprotect(0x7fbe4352f000, 16384, PROT_READ) = 0
mprotect(0x617000, 4096, PROT_READ)     = 0
mprotect(0x7fbe43759000, 4096, PROT_READ) = 0
munmap(0x7fbe4373a000, 117503)          = 0
getpid()                                = 27933
rt_sigaction(SIGCHLD, {SIG_DFL, [CHLD], SA_RESTORER|SA_RESTART, 0x7fbe431eaaf0}, {SIG_DFL, [], 0}, 8) = 0
geteuid()                               = 1000
brk(0)                                  = 0x1346000
brk(0x1367000)                          = 0x1367000
getppid()                               = 27932
stat("/home/user", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
stat(".", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
open("/usr/lib/thunderbird-3.0.4/thunderbird", O_RDONLY) = 3
fcntl(3, F_DUPFD, 10)                   = 10
close(3)                                = 0
fcntl(10, F_SETFD, FD_CLOEXEC)          = 0
rt_sigaction(SIGINT, NULL, {SIG_DFL, [], 0}, 8) = 0
rt_sigaction(SIGINT, {0x408189, ~[RTMIN RT_1], SA_RESTORER, 0x7fbe431eaaf0}, NULL, 8) = 0
rt_sigaction(SIGQUIT, NULL, {SIG_DFL, [], 0}, 8) = 0
rt_sigaction(SIGQUIT, {SIG_DFL, ~[RTMIN RT_1], SA_RESTORER, 0x7fbe431eaaf0}, NULL, 8) = 0
rt_sigaction(SIGTERM, NULL, {SIG_DFL, [], 0}, 8) = 0
rt_sigaction(SIGTERM, {SIG_DFL, ~[RTMIN RT_1], SA_RESTORER, 0x7fbe431eaaf0}, NULL, 8) = 0
read(10, "#!/bin/sh\n#\n# ***** BEGIN LICENS"..., 8192) = 3885
pipe([3, 4])                            = 0
clone(child_stack=0, flags=CLONE_CHILD_CLEARTID|CLONE_CHILD_SETTID|SIGCHLD, child_tidptr=0x7fbe437389d0) = 27936
close(4)                                = 0
read(3, "/usr/lib/thunderbird-3.0.4\n", 128) = 27
read(3, "", 128)                        = 0
close(3)                                = 0
wait4(-1, [{WIFEXITED(s) && WEXITSTATUS(s) == 0}], 0, NULL) = 27936
--- SIGCHLD (Child exited) @ 0 (0) ---
pipe([3, 4])                            = 0
clone(child_stack=0, flags=CLONE_CHILD_CLEARTID|CLONE_CHILD_SETTID|SIGCHLD, child_tidptr=0x7fbe437389d0) = 27937
close(4)                                = 0
read(3, "thunderbird\n", 128)           = 12
read(3, "", 128)                        = 0
--- SIGCHLD (Child exited) @ 0 (0) ---
close(3)                                = 0
wait4(-1, [{WIFEXITED(s) && WEXITSTATUS(s) == 0}], 0, NULL) = 27937
stat("/usr/lib/thunderbird-3.0.4/run-mozilla.sh", {st_mode=S_IFREG|0755, st_size=10450, ...}) = 0
geteuid()                               = 1000
getgid()                                = 1000
getegid()                               = 1000
getgroups(0, NULL)                      = 10
getgroups(10, [4, 20, 24, 29, 44, 46, 104, 115, 120, 1000]) = 10
clone(child_stack=0, flags=CLONE_CHILD_CLEARTID|CLONE_CHILD_SETTID|SIGCHLD, child_tidptr=0x7fbe437389d0) = 27938
wait4(-1, [{WIFEXITED(s) && WEXITSTATUS(s) == 139}], 0, NULL) = 27938
--- SIGCHLD (Child exited) @ 0 (0) ---
exit_group(139)                         = ?
(Reporter)

Comment 1

7 years ago
Working offline doens't leads to segmentation fault, but once Inbox checked after returning to online, Thunderbird crushes.
(Reporter)

Comment 2

7 years ago
Installing nscd like suggested in http://ubuntuforums.org/showthread.php?p=9414948 was not helped. Segmentation faults are occured during opening gmail imap account.
(Reporter)

Comment 3

7 years ago
Workarounded by disabling simultaneous opening both gmail mailboxes:

1. open in offline mode ``thunderbird -ProfileManager``, select work offline.
2. in Account Settings - Server Settings disabled checking one of two mailboxes on startup (and following checking as well - it's backup mailbox)
3. check new mail with F9 or with "Get Messages" doesn't lead to Segmentation fault since that.
need a stacktrace with symbols
https://developer.mozilla.org/En/How_to_get_a_stacktrace_for_a_bug_report
Keywords: crash, stackwanted
(Reporter)

Comment 5

7 years ago
It's so pity (not for me, however), but I can't reproduce the error now. I have altered settings back to default and last 8-10 hours the wasn't crushes. Hope this behaviour keeps further :). Thanks Thunderbird team!
(Reporter)

Comment 6

7 years ago
Hi!

Problem reappeared, but looks like this time the root was in message filter, which should perform replying with Template. But Templates folder wasn't subscribed, so after subscribing to the Templates folder problem was gone. Previous receipt with reducing IMAP polling wasn't successful this time and I am not confident either previously haven't manipulations with Templates folder.
Can you provide a stcka trace please ?
(Reporter)

Comment 8

7 years ago
I am pasting strace here and ``strace -fF`` (7.1 MB) at http://rapidshare.com/files/402571316/fb-full.log.html. Will it be enought, Ludovic?

BTW, confirming the cause - now I just unsubscribed from Templates folder and ran filter over single message. Firebird closed right after this.

execve("/usr/bin/thunderbird", ["thunderbird"], [/* 41 vars */]) = 0
brk(0)                                  = 0x1ab3000
access("/etc/ld.so.nohwcap", F_OK)      = -1 ENOENT (No such file or directory)
mmap(NULL, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7fe184654000
access("/etc/ld.so.preload", R_OK)      = -1 ENOENT (No such file or directory)
open("/etc/ld.so.cache", O_RDONLY)      = 3
fstat(3, {st_mode=S_IFREG|0644, st_size=117645, ...}) = 0
mmap(NULL, 117645, PROT_READ, MAP_PRIVATE, 3, 0) = 0x7fe184637000
close(3)                                = 0
access("/etc/ld.so.nohwcap", F_OK)      = -1 ENOENT (No such file or directory)
open("/lib/libc.so.6", O_RDONLY)        = 3
read(3, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0`\355\1\0\0\0\0\0"..., 832) = 832
fstat(3, {st_mode=S_IFREG|0755, st_size=1568136, ...}) = 0
mmap(NULL, 3676200, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0x7fe1840b4000
mprotect(0x7fe18422c000, 2097152, PROT_NONE) = 0
mmap(0x7fe18442c000, 20480, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x178000) = 0x7fe18442c000
mmap(0x7fe184431000, 18472, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x7fe184431000
close(3)                                = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7fe184636000
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7fe184635000
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7fe184634000
arch_prctl(ARCH_SET_FS, 0x7fe184635700) = 0
mprotect(0x7fe18442c000, 16384, PROT_READ) = 0
mprotect(0x617000, 4096, PROT_READ)     = 0
mprotect(0x7fe184656000, 4096, PROT_READ) = 0
munmap(0x7fe184637000, 117645)          = 0
getpid()                                = 22231
rt_sigaction(SIGCHLD, {SIG_DFL, [CHLD], SA_RESTORER|SA_RESTART, 0x7fe1840e7af0}, {SIG_DFL, [], 0}, 8) = 0
geteuid()                               = 1000
brk(0)                                  = 0x1ab3000
brk(0x1ad4000)                          = 0x1ad4000
getppid()                               = 22229
stat("/home/user", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
stat(".", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
open("/usr/bin/thunderbird", O_RDONLY)  = 3
fcntl(3, F_DUPFD, 10)                   = 10
close(3)                                = 0
fcntl(10, F_SETFD, FD_CLOEXEC)          = 0
rt_sigaction(SIGINT, NULL, {SIG_DFL, [], 0}, 8) = 0
rt_sigaction(SIGINT, {0x408189, ~[RTMIN RT_1], SA_RESTORER, 0x7fe1840e7af0}, NULL, 8) = 0
rt_sigaction(SIGQUIT, NULL, {SIG_DFL, [], 0}, 8) = 0
rt_sigaction(SIGQUIT, {SIG_DFL, ~[RTMIN RT_1], SA_RESTORER, 0x7fe1840e7af0}, NULL, 8) = 0
rt_sigaction(SIGTERM, NULL, {SIG_DFL, [], 0}, 8) = 0
rt_sigaction(SIGTERM, {SIG_DFL, ~[RTMIN RT_1], SA_RESTORER, 0x7fe1840e7af0}, NULL, 8) = 0
read(10, "#!/bin/sh\n\n# Firefox launcher co"..., 8192) = 4842
pipe([3, 4])                            = 0
clone(child_stack=0, flags=CLONE_CHILD_CLEARTID|CLONE_CHILD_SETTID|SIGCHLD, child_tidptr=0x7fe1846359d0) = 22232
close(4)                                = 0
read(3, "/usr/bin/thunderbird\n", 128)  = 21
read(3, "", 128)                        = 0
--- SIGCHLD (Child exited) @ 0 (0) ---
close(3)                                = 0
wait4(-1, [{WIFEXITED(s) && WEXITSTATUS(s) == 0}], 0, NULL) = 22232
pipe([3, 4])                            = 0
clone(child_stack=0, flags=CLONE_CHILD_CLEARTID|CLONE_CHILD_SETTID|SIGCHLD, child_tidptr=0x7fe1846359d0) = 22233
close(4)                                = 0
read(3, "thunderbird\n", 128)           = 12
read(3, "", 128)                        = 0
close(3)                                = 0
wait4(-1, [{WIFEXITED(s) && WEXITSTATUS(s) == 0}], 0, NULL) = 22233
--- SIGCHLD (Child exited) @ 0 (0) ---
stat("/usr/lib/thunderbird-3.0.4/thunderbird", {st_mode=S_IFREG|0755, st_size=3885, ...}) = 0
stat("/home/user/.mozilla-thunderbird", {st_mode=S_IFDIR|0700, st_size=4096, ...}) = 0
lstat("/home/user/.mozilla-thunderbird", {st_mode=S_IFLNK|0777, st_size=23, ...}) = 0
stat("/home/user/.thunderbird", {st_mode=S_IFDIR|0700, st_size=4096, ...}) = 0
stat("/home/user/.thunderbird-3.0", 0x7fff15a0f610) = -1 ENOENT (No such file or directory)
stat("/home/user/.thunderbird-2.0-replaced", 0x7fff15a0f5d0) = -1 ENOENT (No such file or directory)
lstat("/home/user/.mozilla-thunderbird", {st_mode=S_IFLNK|0777, st_size=23, ...}) = 0
stat("/home/user/.mozilla-thunderbird", {st_mode=S_IFDIR|0700, st_size=4096, ...}) = 0
execve("/usr/lib/thunderbird-3.0.4/thunderbird", ["/usr/lib/thunderbird-3.0.4/thund"...], [/* 42 vars */]) = 0
brk(0)                                  = 0x8f6000
access("/etc/ld.so.nohwcap", F_OK)      = -1 ENOENT (No such file or directory)
mmap(NULL, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7f9e9ba75000
access("/etc/ld.so.preload", R_OK)      = -1 ENOENT (No such file or directory)
open("/etc/ld.so.cache", O_RDONLY)      = 3
fstat(3, {st_mode=S_IFREG|0644, st_size=117645, ...}) = 0
mmap(NULL, 117645, PROT_READ, MAP_PRIVATE, 3, 0) = 0x7f9e9ba58000
close(3)                                = 0
access("/etc/ld.so.nohwcap", F_OK)      = -1 ENOENT (No such file or directory)
open("/lib/libc.so.6", O_RDONLY)        = 3
read(3, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0`\355\1\0\0\0\0\0"..., 832) = 832
fstat(3, {st_mode=S_IFREG|0755, st_size=1568136, ...}) = 0
mmap(NULL, 3676200, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0x7f9e9b4d5000
mprotect(0x7f9e9b64d000, 2097152, PROT_NONE) = 0
mmap(0x7f9e9b84d000, 20480, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x178000) = 0x7f9e9b84d000
mmap(0x7f9e9b852000, 18472, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x7f9e9b852000
close(3)                                = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7f9e9ba57000
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7f9e9ba56000
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7f9e9ba55000
arch_prctl(ARCH_SET_FS, 0x7f9e9ba56700) = 0
mprotect(0x7f9e9b84d000, 16384, PROT_READ) = 0
mprotect(0x617000, 4096, PROT_READ)     = 0
mprotect(0x7f9e9ba77000, 4096, PROT_READ) = 0
munmap(0x7f9e9ba58000, 117645)          = 0
getpid()                                = 22231
rt_sigaction(SIGCHLD, {SIG_DFL, [CHLD], SA_RESTORER|SA_RESTART, 0x7f9e9b508af0}, {SIG_DFL, [], 0}, 8) = 0
geteuid()                               = 1000
brk(0)                                  = 0x8f6000
brk(0x917000)                           = 0x917000
getppid()                               = 22229
stat("/home/user", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
stat(".", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
open("/usr/lib/thunderbird-3.0.4/thunderbird", O_RDONLY) = 3
fcntl(3, F_DUPFD, 10)                   = 10
close(3)                                = 0
fcntl(10, F_SETFD, FD_CLOEXEC)          = 0
rt_sigaction(SIGINT, NULL, {SIG_DFL, [], 0}, 8) = 0
rt_sigaction(SIGINT, {0x408189, ~[RTMIN RT_1], SA_RESTORER, 0x7f9e9b508af0}, NULL, 8) = 0
rt_sigaction(SIGQUIT, NULL, {SIG_DFL, [], 0}, 8) = 0
rt_sigaction(SIGQUIT, {SIG_DFL, ~[RTMIN RT_1], SA_RESTORER, 0x7f9e9b508af0}, NULL, 8) = 0
rt_sigaction(SIGTERM, NULL, {SIG_DFL, [], 0}, 8) = 0
rt_sigaction(SIGTERM, {SIG_DFL, ~[RTMIN RT_1], SA_RESTORER, 0x7f9e9b508af0}, NULL, 8) = 0
read(10, "#!/bin/sh\n#\n# ***** BEGIN LICENS"..., 8192) = 3885
pipe([3, 4])                            = 0
clone(child_stack=0, flags=CLONE_CHILD_CLEARTID|CLONE_CHILD_SETTID|SIGCHLD, child_tidptr=0x7f9e9ba569d0) = 22234
close(4)                                = 0
read(3, "/usr/lib/thunderbird-3.0.4\n", 128) = 27
read(3, "", 128)                        = 0
close(3)                                = 0
wait4(-1, [{WIFEXITED(s) && WEXITSTATUS(s) == 0}], 0, NULL) = 22234
--- SIGCHLD (Child exited) @ 0 (0) ---
pipe([3, 4])                            = 0
clone(child_stack=0, flags=CLONE_CHILD_CLEARTID|CLONE_CHILD_SETTID|SIGCHLD, child_tidptr=0x7f9e9ba569d0) = 22235
close(4)                                = 0
read(3, "thunderbird\n", 128)           = 12
read(3, "", 128)                        = 0
close(3)                                = 0
wait4(-1, [{WIFEXITED(s) && WEXITSTATUS(s) == 0}], 0, NULL) = 22235
--- SIGCHLD (Child exited) @ 0 (0) ---
stat("/usr/lib/thunderbird-3.0.4/run-mozilla.sh", {st_mode=S_IFREG|0755, st_size=10450, ...}) = 0
geteuid()                               = 1000
getgid()                                = 1000
getegid()                               = 1000
getgroups(0, NULL)                      = 10
getgroups(10, [4, 20, 24, 29, 44, 46, 104, 115, 120, 1000]) = 10
clone(child_stack=0, flags=CLONE_CHILD_CLEARTID|CLONE_CHILD_SETTID|SIGCHLD, child_tidptr=0x7f9e9ba569d0) = 22236
wait4(-1, LoadPlugin: failed to initialize shared library /usr/lib/jvm/java-6-openjdk/jre/lib/amd64/IcedTeaPlugin.so [libxul.so: cannot open shared object file: No such file or directory]
LoadPlugin: failed to initialize shared library /usr/lib/jvm/java-6-openjdk/jre/lib/amd64/IcedTeaPlugin.so [libxul.so: cannot open shared object file: No such file or directory]
Segmentation fault
[{WIFEXITED(s) && WEXITSTATUS(s) == 139}], 0, NULL) = 22236
--- SIGCHLD (Child exited) @ 0 (0) ---
exit_group(139)                         = ?
No we need a stack trace. read our instructiosn above on how to achieve that, are they unclear ?
(Reporter)

Comment 10

7 years ago
I am getting ``error while loading shared libraries: libmozjs.so: cannot open shared object file: No such file or directory`` although it is located in /usr/lib/thunderbird-3.0.4. It's fired before steps of reproducing the Bug (Thunderbird window doesn't appear). Can you suggest me, please, how to deal with this?

Steps I have made:

After installing debugging symbols::

# sudo apt-get install thunderbird-dbg \
     libgtk2.0-0-dbg \
     libnss3-1d-dbg \
     libnspr4-0d-dbg \
     libpango1.0-0-dbg \
     libcairo2-dbg \
     libc6-dbg

and closing Thunderbird I am trying to::

$ gdb /usr/lib/thunderbird-3.0.4/thunderbird-bin 2>&1 | tee /tmp/gdb-thunderbird.txt 
GNU gdb (GDB) 7.1-ubuntu
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/lib/thunderbird-3.0.4/thunderbird-bin...Reading symbols from /usr/lib/debug/usr/lib/thunderbird-3.0.4/thunderbird-bin...done.
done.
(gdb) run
Starting program: /usr/lib/thunderbird-3.0.4/thunderbird-bin 
/usr/lib/thunderbird-3.0.4/thunderbird-bin: error while loading shared libraries: libmozjs.so: cannot open shared object file: No such file or directory

Program exited with code 0177.
(gdb) quit

$ pwd
/usr/lib/thunderbird-3.0.4

$ file libmozjs.so 
libmozjs.so: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, stripped

$ ls
application.ini  defaults      greprefs      libldif60.so    libsqlite3.so     libxpcom.so             platform.ini   res                               thunderbird
chrome           dictionaries  isp           libmozjs.so     libssldap60.so    modules                 README.txt     run-mozilla.sh                    thunderbird-bin
components       extensions    libldap60.so  libprldap60.so  libxpcom_core.so  mozilla-xremote-client  removed-files  tb-beta-profile-migration-dialog  thunderbird.sh
Something is wrong somewhere, maybe the launch script si borked, Micahg thoughts ?

Comment 12

7 years ago
The proper way to start the debugger in Ubuntu is thunderbird -g, but there's a bug at the moment.  This is https://bugs.launchpad.net/ubuntu/+source/thunderbird/+bug/563535
To work around the bug edit /usr/lib/thunderbird-3.0.*/thunderbird.sh and line 158 should have "$LIBDIR/$META_NAME"-bin instead of "$LIBDIR/$META_NAME"
(Reporter)

Comment 13

7 years ago
Created attachment 455153 [details]
traceback
(Reporter)

Comment 14

7 years ago
Thanks Micah!
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: stackwanted
see if this matches up to ug 537835.
and if not, perhaps one of these 3.1 crash sigs
 nsTArray<nsTemplateQuerySet*>::AppendElements<nsTemplateQuerySet*>(nsTemplateQuerySet* const*, unsigned int)
nsXULTemplateBuilder::GetResultResource(nsIXULTemplateResult*, nsIRDFResource**)
nsInterfaceHashtable<nsISupportsHashKey, nsIXULTemplateBuilder>::Get(nsISupports*, nsIXULTemplateBuilder**)
nsMsgTemplateReplyHelper::OnStopRunningUrl(nsIURI*, unsigned int)
nsXULContentBuilder::InsertSortedNode(nsIContent*, nsIContent*, nsIXULTemplateResult*, int)
Summary: Segmentation fault right after start → Segmentation fault right after start [@ nsMsgComposeService::ReplyWithTemplate]

Comment 16

7 years ago
comment 13 is bug 537835

Updated

7 years ago
Duplicate of this bug: 537835
#150 crash for v3.1.1.
approx 2/3 of crashes appear to be startup/early message retrieval 

timeless from bug 535835 comment 3

1171 nsresult rv = GetExistingFolder(folderUri,
getter_AddRefs(templateFolder));
1172 NS_ENSURE_SUCCESS(rv, rv);
1173 rv = templateFolder->GetMsgDatabase(getter_AddRefs(templateDB)); 

750 nsresult GetExistingFolder(const nsCString& aFolderURI, nsIMsgFolder
**aFolder)
768   // Parent doesn't exist means that this folder doesn't exist.
769   nsCOMPtr<nsIMsgFolder> parentFolder;
770   rv = thisFolder->GetParent(getter_AddRefs(parentFolder));
771   if (NS_SUCCEEDED(rv) && parentFolder)
772     NS_ADDREF(*aFolder = thisFolder);
773   return rv;

3 variations of stack: pop, imap, ??? ...

bp-1e905510-10d8-4994-8210-e872b2100802 pop, v3.0.6
Everytime I go to open Thunderbird, it crashes.
2nd frame for pop crashes is 
nsParseNewMailState::ApplyForwardAndReplyFilter mailnews/local/src/nsParseMailbox.cpp:2301

bp-00a40187-8957-4838-bcdd-0965f2100729 imap, v3.0.5
2nd frame for imap crashes is 
nsImapMailFolder::ApplyFilterHit mailnews/imap/src/nsImapMailFolder.cpp:3659

bp-37ba05bf-db15-4866-85a5-192952100721 ???
nsMsgComposeService::ReplyWithTemplate	 mailnews/compose/src/nsMsgComposeService.cpp:1173
nsMsgFilterAfterTheFact::ApplyFilter	mailnews/base/search/src/nsMsgFilterService.cpp:710
nsMsgFilterAfterTheFact::OnSearchDone	mailnews/base/search/src/nsMsgFilterService.cpp:439
nsMsgSearchSession::NotifyListenersDone	mailnews/base/search/src/nsMsgSearchSession.cpp:620 
nsMsgFilterAfterTheFact::ApplyFilter
Component: General → Composition
OS: Linux → All
Product: Thunderbird → MailNews Core
QA Contact: general → composition
Summary: Segmentation fault right after start [@ nsMsgComposeService::ReplyWithTemplate] → Segmentation fault right after startup [@ nsMsgComposeService::ReplyWithTemplate(nsIMsgDBHdr*, char const*, nsIMsgWindow*, nsIMsgIncomingServer*)]
(Assignee)

Comment 19

7 years ago
GetParent(nsIMsgFolder*) can return NS_OK with *aParent is null.
So, GetExistingFolder should return error if parent is null.
(Assignee)

Comment 20

7 years ago
Created attachment 477458 [details] [diff] [review]
fix
Assignee: nobody → m_kato
(Assignee)

Updated

7 years ago
Attachment #477458 - Flags: review?(bienvenu)

Comment 21

7 years ago
Comment on attachment 477458 [details] [diff] [review]
fix

thx for the patch - there are a few call sites for GetExistingFolder that check both for error and a non-hull result. those could now be changed to only check for error, so it would be great if you could do that as well.
Attachment #477458 - Flags: review?(bienvenu) → review+
Keywords: checkin-needed
Checked in: http://hg.mozilla.org/comm-central/rev/22f8aae0d6c8
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Keywords: checkin-needed
Target Milestone: --- → Thunderbird 3.3a1
Attachment #477458 - Flags: approval-thunderbird3.1.5?
Comment on attachment 477458 [details] [diff] [review]
fix

a=Standard8, I'll land this in a few mins along with some others.
Attachment #477458 - Flags: approval-thunderbird3.1.5? → approval-thunderbird3.1.5+
Checked in to 1.9.2 (sorry for forgetting to set the username):

http://hg.mozilla.org/releases/comm-1.9.2/rev/835ac674902f
status-thunderbird3.1: --- → .5-fixed
Crash Signature: [@ nsMsgComposeService::ReplyWithTemplate(nsIMsgDBHdr*, char const*, nsIMsgWindow*, nsIMsgIncomingServer*)]
You need to log in before you can comment on or make changes to this bug.