The default bug view has changed. See this FAQ.

ALT-RETURN (enter) should be equivalent to RETURN when operating on a blank tab

RESOLVED FIXED

Status

()

Firefox
Tabbed Browser
--
minor
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: mdinger.bugzilla@gmail.com, Unassigned)

Tracking

(Depends on: 1 bug)

Trunk
x86
All
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed by bug 596485)

(Reporter)

Description

7 years ago
Steps to reproduce:

1. Open new tab: CTRL-T.
2. Type in address bar: "www.google.com".
3. Hit ALT-RETURN.

Result:
A blank tab is left open.


A pretty minor issue but it might be worth changing.  It could also be done by automatically closing the blank tab.
(Reporter)

Updated

7 years ago
Blocks: 565515

Updated

7 years ago
Depends on: 320989

Comment 1

7 years ago
Modifying the Return key action with the Alt key is a deliberate decision by the user, indicating that the user wishes to open the url in a new tab. Changing this behavior for blank tabs breaks the consistency of the user interface, which is a key user experience principle.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Keywords: ux-consistency
Resolution: --- → WONTFIX
bug 320989 will fix this.
No longer blocks: 565515
Status: RESOLVED → REOPENED
Keywords: ux-consistency
Resolution: WONTFIX → ---
Blocks: 595046
(Reporter)

Updated

7 years ago
Summary: ALT-RETURN should be equivalent to RETURN when operating on a blank tab → ALT-RETURN (enter) should be equivalent to RETURN when operating on a blank tab
(Reporter)

Comment 3

6 years ago
This is fixed now so I will mark WORKSFORME.  Checked with 9.0a1 because I didn't see a latest mozilla central.

Mozilla/5.0 (X11; Linux i686; rv:6.0.2) Gecko/20100101 Firefox/6.0.2
Mozilla/5.0 (X11; Linux i686; rv:9.0a1) Gecko/20110911 Firefox/9.0a1
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago6 years ago
Resolution: --- → WORKSFORME

Updated

6 years ago
No longer blocks: 595046
Depends on: 596485
Resolution: WORKSFORME → FIXED
Whiteboard: fixed by bug 596485
You need to log in before you can comment on or make changes to this bug.